mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
8b19227b58
a/bcachefs-tools-1.7.0-x86_64-1.txz: Added. a/kernel-generic-6.9.0-x86_64-2.txz: Upgraded. a/kernel-huge-6.9.0-x86_64-2.txz: Upgraded. a/kernel-modules-6.9.0-x86_64-2.txz: Upgraded. d/git-2.45.1-x86_64-1.txz: Upgraded. This update fixes security issues: Recursive clones on case-insensitive filesystems that support symbolic links are susceptible to case confusion that can be exploited to execute just-cloned code during the clone operation. Repositories can be configured to execute arbitrary code during local clones. To address this, the ownership checks introduced in v2.30.3 are now extended to cover cloning local repositories. Local clones may end up hardlinking files into the target repository's object database when source and target repository reside on the same disk. If the source repository is owned by a different user, then those hardlinked files may be rewritten at any point in time by the untrusted user. When cloning a local source repository that contains symlinks via the filesystem, Git may create hardlinks to arbitrary user-readable files on the same filesystem as the target repository in the objects/ directory. It is supposed to be safe to clone untrusted repositories, even those unpacked from zip archives or tarballs originating from untrusted sources, but Git can be tricked to run arbitrary code as part of the clone. For more information, see: https://www.cve.org/CVERecord?id=CVE-2024-32002 https://www.cve.org/CVERecord?id=CVE-2024-32004 https://www.cve.org/CVERecord?id=CVE-2024-32020 https://www.cve.org/CVERecord?id=CVE-2024-32021 https://www.cve.org/CVERecord?id=CVE-2024-32465 (* Security fix *) d/kernel-headers-6.9.0-x86-2.txz: Upgraded. d/strace-6.9-x86_64-1.txz: Upgraded. k/kernel-source-6.9.0-noarch-2.txz: Upgraded. BCACHEFS_FS m -> y CRYPTO_CHACHA20 m -> y CRYPTO_LIB_CHACHA_GENERIC m -> y CRYPTO_LIB_POLY1305_GENERIC m -> y CRYPTO_POLY1305 m -> y MITIGATION_GDS_FORCE y -> n kde/wcslib-8.3-x86_64-1.txz: Upgraded. l/gdk-pixbuf2-2.42.12-x86_64-1.txz: Upgraded. ani: Reject files with multiple INA or IART chunks. ani: Reject files with multiple anih chunks. ani: validate chunk size. Thanks to 0xvhp, pedrib, and Benjamin Gilbert. For more information, see: https://www.cve.org/CVERecord?id=CVE-2022-48622 (* Security fix *) l/gtk+3-3.24.42-x86_64-1.txz: Upgraded. n/bind-9.18.27-x86_64-1.txz: Upgraded. This is a bugfix release. n/popa3d-1.0.3-x86_64-8.txz: Rebuilt. This is a bugfix release: Build with AUTH_PAM, not AUTH_SHADOW. Thanks to jayjwa. x/xorg-server-xwayland-23.2.7-x86_64-1.txz: Upgraded. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
115 lines
3.5 KiB
Bash
Executable file
115 lines
3.5 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009, 2010, 2013, 2018 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=popa3d
|
|
VERSION=1.0.3
|
|
BUILD=${BUILD:-8}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i586 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
if [ "$ARCH" = "i586" ]; then
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "i686" ]; then
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "s390" ]; then
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
LIBDIRSUFFIX="64"
|
|
elif [ "$ARCH" = "armv7hl" ]; then
|
|
LIBDIRSUFFIX=""
|
|
else
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-popa3d
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
cd $TMP
|
|
rm -rf popa3d-$VERSION
|
|
tar xvf $CWD/popa3d-$VERSION.tar.?z || exit 1
|
|
cd popa3d-$VERSION || exit 1
|
|
|
|
# Choose correct options for PAM:
|
|
zcat $CWD/popa3d.pam.diff.gz | patch -p1 --verbose --backup --suffix=.orig || exit 1
|
|
|
|
zcat $CWD/popa3d.gcc14.diff.gz | patch -p1 --verbose || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
|
|
# already stripped
|
|
mkdir -p $PKG/usr/sbin
|
|
cat popa3d > $PKG/usr/sbin/popa3d
|
|
chmod 755 $PKG/usr/sbin/popa3d
|
|
|
|
mkdir -p $PKG/usr/man/man8
|
|
cat popa3d.8 | gzip -9c > $PKG/usr/man/man8/popa3d.8.gz
|
|
|
|
# Empty directory to chroot() into. Should already be installed by aaa_base, or
|
|
# openssh, or both:
|
|
#mkdir -p $PKG/var/empty
|
|
|
|
# Docs:
|
|
mkdir -p $PKG/usr/doc/popa3d-$VERSION
|
|
cp -a \
|
|
CHANGES CONTACT DESIGN INSTALL LICENSE VIRTUAL \
|
|
$PKG/usr/doc/popa3d-$VERSION
|
|
chmod 644 $PKG/usr/doc/popa3d-$VERSION/*
|
|
|
|
# Add install script -- this ensures pop user/group are there:
|
|
mkdir -p $PKG/install
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
# Description:
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
# Build the package:
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/popa3d-$VERSION-$ARCH-$BUILD.txz
|
|
|