slackbuilds_ponce/business/ledger/CMakeLists.txt.patch
Sanel Zukan d612ae0eba
Update Ledger to the latest 3.2.1 version
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
2021-01-17 08:44:59 +07:00

13 lines
No EOL
617 B
Diff

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 15cb7ef90..bb8bfa2dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ set(Ledger_TEST_TIMEZONE "America/Chicago")
# Point CMake at any custom modules we may ship
list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/cmake")
-if(${CMAKE_VERSION} VERSION_LESS "3.16.0")
+if ((${CMAKE_VERSION} VERSION_GREATER_EQUAL "3.7.0") AND (${CMAKE_VERSION} VERSION_LESS "3.16.0"))
# use backported module from 3.15 (introduced 3.12) to support older versions of cmake
list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/cmake/python-backport")
endif()