Update Ledger to the latest 3.2.1 version

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Sanel Zukan 2021-01-13 18:02:35 +01:00 committed by Willy Sudiarto Raharjo
parent 2c50c0a9ee
commit d612ae0eba
No known key found for this signature in database
GPG key ID: 3F617144D7238786
3 changed files with 27 additions and 6 deletions

View file

@ -0,0 +1,13 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 15cb7ef90..bb8bfa2dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ set(Ledger_TEST_TIMEZONE "America/Chicago")
# Point CMake at any custom modules we may ship
list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/cmake")
-if(${CMAKE_VERSION} VERSION_LESS "3.16.0")
+if ((${CMAKE_VERSION} VERSION_GREATER_EQUAL "3.7.0") AND (${CMAKE_VERSION} VERSION_LESS "3.16.0"))
# use backported module from 3.15 (introduced 3.12) to support older versions of cmake
list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/cmake/python-backport")
endif()

View file

@ -4,7 +4,7 @@
# Updated by simotrone (simotrone at gmail dot com)
PRGNAM=ledger
VERSION=${VERSION:-3.1.3}
VERSION=${VERSION:-3.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -36,8 +36,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
./acprep --prefix=/usr update
make install DESTDIR=$PKG
patch -p1 < $CWD/CMakeLists.txt.patch
mkdir -p build
cd build
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
..
make
make install DESTDIR=$PKG
cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

View file

@ -1,8 +1,8 @@
PRGNAM="ledger"
VERSION="3.1.3"
VERSION="3.2.1"
HOMEPAGE="https://ledger-cli.org"
DOWNLOAD="https://github.com/ledger/ledger/archive/v3.1.3/ledger-3.1.3.tar.gz"
MD5SUM="6d9b8293f5f909aab4b95cffa2b3c120"
DOWNLOAD="https://github.com/ledger/ledger/archive/v3.2.1/ledger-3.2.1.tar.gz"
MD5SUM="4f82445bf8a39010e51b6367cf82c6d9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="utfcpp"