mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
68d4a9b6cf
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
32 lines
1.3 KiB
Diff
32 lines
1.3 KiB
Diff
--- dao-2.0-devel-2014-01-19/CMakeLists.original.txt 2014-04-03 12:27:09.424917752 +0300
|
|
+++ dao-2.0-devel-2014-01-19/CMakeLists.txt 2014-04-03 12:29:11.000397849 +0300
|
|
@@ -89,12 +89,12 @@
|
|
endif(DAO_HAS_FENV)
|
|
|
|
# Check whether the system has readline.h or not.
|
|
-find_path(DAO_HAS_READLINE NAMES "readline/readline.h" "readline/history.h")
|
|
-if(DAO_HAS_READLINE)
|
|
- include_directories("${DAO_HAS_READLINE}")
|
|
- add_definitions(-DDAO_USE_READLINE)
|
|
- list(APPEND DAO_SYSTEM_LIBS "readline")
|
|
-endif(DAO_HAS_READLINE)
|
|
+# find_path(DAO_HAS_READLINE NAMES "readline/readline.h" "readline/history.h")
|
|
+# if(DAO_HAS_READLINE)
|
|
+# include_directories("${DAO_HAS_READLINE}")
|
|
+# add_definitions(-DDAO_USE_READLINE)
|
|
+# list(APPEND DAO_SYSTEM_LIBS "readline")
|
|
+# endif(DAO_HAS_READLINE)
|
|
|
|
# Setup for Minix:
|
|
if( "${CMAKE_SYSTEM_NAME}" STREQUAL "Minix" )
|
|
@@ -199,8 +199,8 @@
|
|
RUNTIME DESTINATION "bin"
|
|
LIBRARY DESTINATION "lib"
|
|
ARCHIVE DESTINATION "lib"
|
|
- PRIVATE_HEADER DESTINATION "include"
|
|
- PUBLIC_HEADER DESTINATION "include"
|
|
+ PRIVATE_HEADER DESTINATION "include/dao"
|
|
+ PUBLIC_HEADER DESTINATION "include/dao"
|
|
)
|
|
#autobind.dao is obsolete:
|
|
#install(FILES "${PROJECT_SOURCE_DIR}/tools/autobind.dao" DESTINATION "bin")
|