mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
development/dao: Added (The Dao Programming Language).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
eb6d03d83f
commit
68d4a9b6cf
7 changed files with 234 additions and 0 deletions
4
development/dao/README
Normal file
4
development/dao/README
Normal file
|
@ -0,0 +1,4 @@
|
|||
Dao is a lightweight and optionally typed programming language
|
||||
with many interesting features. It includes features that can
|
||||
make concurrent programming much simpler. It has well designed
|
||||
interfaces for easy embedding and extending.
|
111
development/dao/dao.SlackBuild
Normal file
111
development/dao/dao.SlackBuild
Normal file
|
@ -0,0 +1,111 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for dao
|
||||
|
||||
# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=dao
|
||||
VERSION=${VERSION:-2.0}
|
||||
SRCVER=$VERSION-devel-2014-01-19
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$SRCVER
|
||||
tar xvf $CWD/$PRGNAM-$SRCVER.tgz
|
||||
cd $PRGNAM-$SRCVER
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
|
||||
if [ "$ARCH" = "x86_64" ]; then
|
||||
patch -p1 < $CWD/dao_x64.patch
|
||||
else
|
||||
patch -p1 < $CWD/dao_readline.patch
|
||||
fi
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_BUILD_TYPE=Release ..
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
cd ..
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/etc
|
||||
cp -a $PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
|
||||
|
||||
# remove static library
|
||||
rm $PKG/usr/lib${LIBDIRSUFFIX}/libdao.a
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a ChangeLog README credits.txt $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
mv $PKG/usr/share/doc/dao/license.txt $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
rm -rf $PKG/usr/share/
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
development/dao/dao.info
Normal file
10
development/dao/dao.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="dao"
|
||||
VERSION="2.0"
|
||||
HOMEPAGE="http://daovm.net/"
|
||||
DOWNLOAD="http://sourceforge.net/projects/daoscript/files/dao-2.0-devel/dao-2.0-devel-2014-01-19.tgz"
|
||||
MD5SUM="1801d41b8037e9ebc5ed37424183c23c"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Dimitris Zlatanidis"
|
||||
EMAIL="d.zlatanidis@gmail.com"
|
32
development/dao/dao_readline.patch
Normal file
32
development/dao/dao_readline.patch
Normal file
|
@ -0,0 +1,32 @@
|
|||
--- dao-2.0-devel-2014-01-19/CMakeLists.original.txt 2014-04-03 12:27:09.424917752 +0300
|
||||
+++ dao-2.0-devel-2014-01-19/CMakeLists.txt 2014-04-03 12:29:11.000397849 +0300
|
||||
@@ -89,12 +89,12 @@
|
||||
endif(DAO_HAS_FENV)
|
||||
|
||||
# Check whether the system has readline.h or not.
|
||||
-find_path(DAO_HAS_READLINE NAMES "readline/readline.h" "readline/history.h")
|
||||
-if(DAO_HAS_READLINE)
|
||||
- include_directories("${DAO_HAS_READLINE}")
|
||||
- add_definitions(-DDAO_USE_READLINE)
|
||||
- list(APPEND DAO_SYSTEM_LIBS "readline")
|
||||
-endif(DAO_HAS_READLINE)
|
||||
+# find_path(DAO_HAS_READLINE NAMES "readline/readline.h" "readline/history.h")
|
||||
+# if(DAO_HAS_READLINE)
|
||||
+# include_directories("${DAO_HAS_READLINE}")
|
||||
+# add_definitions(-DDAO_USE_READLINE)
|
||||
+# list(APPEND DAO_SYSTEM_LIBS "readline")
|
||||
+# endif(DAO_HAS_READLINE)
|
||||
|
||||
# Setup for Minix:
|
||||
if( "${CMAKE_SYSTEM_NAME}" STREQUAL "Minix" )
|
||||
@@ -199,8 +199,8 @@
|
||||
RUNTIME DESTINATION "bin"
|
||||
LIBRARY DESTINATION "lib"
|
||||
ARCHIVE DESTINATION "lib"
|
||||
- PRIVATE_HEADER DESTINATION "include"
|
||||
- PUBLIC_HEADER DESTINATION "include"
|
||||
+ PRIVATE_HEADER DESTINATION "include/dao"
|
||||
+ PUBLIC_HEADER DESTINATION "include/dao"
|
||||
)
|
||||
#autobind.dao is obsolete:
|
||||
#install(FILES "${PROJECT_SOURCE_DIR}/tools/autobind.dao" DESTINATION "bin")
|
40
development/dao/dao_x64.patch
Normal file
40
development/dao/dao_x64.patch
Normal file
|
@ -0,0 +1,40 @@
|
|||
--- dao-2.0-devel-2014-01-19/CMakeLists.original.txt 2014-04-03 12:51:50.845397447 +0300
|
||||
+++ dao-2.0-devel-2014-01-19/CMakeLists.txt 2014-04-03 12:59:56.966320100 +0300
|
||||
@@ -89,12 +89,12 @@
|
||||
endif(DAO_HAS_FENV)
|
||||
|
||||
# Check whether the system has readline.h or not.
|
||||
-find_path(DAO_HAS_READLINE NAMES "readline/readline.h" "readline/history.h")
|
||||
-if(DAO_HAS_READLINE)
|
||||
- include_directories("${DAO_HAS_READLINE}")
|
||||
- add_definitions(-DDAO_USE_READLINE)
|
||||
- list(APPEND DAO_SYSTEM_LIBS "readline")
|
||||
-endif(DAO_HAS_READLINE)
|
||||
+# find_path(DAO_HAS_READLINE NAMES "readline/readline.h" "readline/history.h")
|
||||
+# if(DAO_HAS_READLINE)
|
||||
+# include_directories("${DAO_HAS_READLINE}")
|
||||
+# add_definitions(-DDAO_USE_READLINE)
|
||||
+# list(APPEND DAO_SYSTEM_LIBS "readline")
|
||||
+# endif(DAO_HAS_READLINE)
|
||||
|
||||
# Setup for Minix:
|
||||
if( "${CMAKE_SYSTEM_NAME}" STREQUAL "Minix" )
|
||||
@@ -194,13 +194,13 @@
|
||||
set_target_properties(daoexe PROPERTIES OUTPUT_NAME ${DAO_EXE_NAME})
|
||||
|
||||
# Installation rules for the interpreter and dao libs
|
||||
-set(DAO_MODULES_INSTALL_DIR "lib/dao/modules")
|
||||
+set(DAO_MODULES_INSTALL_DIR "lib64/dao/modules")
|
||||
install(TARGETS daoexe daolib daolibs
|
||||
RUNTIME DESTINATION "bin"
|
||||
- LIBRARY DESTINATION "lib"
|
||||
- ARCHIVE DESTINATION "lib"
|
||||
- PRIVATE_HEADER DESTINATION "include"
|
||||
- PUBLIC_HEADER DESTINATION "include"
|
||||
+ LIBRARY DESTINATION "lib64"
|
||||
+ ARCHIVE DESTINATION "lib64"
|
||||
+ PRIVATE_HEADER DESTINATION "include/dao"
|
||||
+ PUBLIC_HEADER DESTINATION "include/dao"
|
||||
)
|
||||
#autobind.dao is obsolete:
|
||||
#install(FILES "${PROJECT_SOURCE_DIR}/tools/autobind.dao" DESTINATION "bin")
|
18
development/dao/doinst.sh
Normal file
18
development/dao/doinst.sh
Normal file
|
@ -0,0 +1,18 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
config() {
|
||||
NEW="$1"
|
||||
OLD="$(dirname $NEW)/$(basename $NEW .new)"
|
||||
# If there's no config file by that name, mv it over:
|
||||
if [ ! -r $OLD ]; then
|
||||
mv $NEW $OLD
|
||||
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
|
||||
# toss the redundant copy
|
||||
rm $NEW
|
||||
fi
|
||||
# Otherwise, we leave the .new copy for the admin to consider...
|
||||
}
|
||||
|
||||
config etc/dao.conf.new
|
19
development/dao/slack-desc
Normal file
19
development/dao/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
dao: dao (The Dao Programming Language)
|
||||
dao:
|
||||
dao: Dao is a lightweight and optionally typed programming language
|
||||
dao: with many interesting features. It includes features that can
|
||||
dao: make concurrent programming much simpler. It has well designed
|
||||
dao: interfaces for easy embedding and extending.
|
||||
dao:
|
||||
dao: Homepage: http://daovm.net/
|
||||
dao:
|
||||
dao:
|
||||
dao:
|
Loading…
Reference in a new issue