mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
7001301775
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
17 lines
560 B
Diff
17 lines
560 B
Diff
Description: Use build flags from environment (dpkg-buildflags).
|
|
Necessary for hardening flags.
|
|
Author: Simon Ruderich <simon@ruderich.org>
|
|
Last-Update: 2012-04-24
|
|
Bug-Closed: http://bugs.debian.org/670230
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -173,7 +173,7 @@
|
|
$(MM_DEF) \
|
|
$(SHMEM_DEF)
|
|
|
|
-ALL_FLAGS = $(EXTRA_FLAGS) $(CFLAGS) $(CXXFLAGS)
|
|
+ALL_FLAGS = $(EXTRA_FLAGS) $(CPPFLAGS) $(CFLAGS) $(CXXFLAGS) $(LDFLAGS)
|
|
DEBUG_DEFS = -DCOMPILER_OPTIONS="\"$(DEBUG_FLAGS) $(ALL_FLAGS)\""
|
|
RELEASE_DEFS = -DCOMPILER_OPTIONS="\"$(RELEASE_FLAGS) $(ALL_FLAGS)\""
|
|
|