mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
academic/bowtie: Updated for version 1.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
ca3a131931
commit
7001301775
7 changed files with 118 additions and 13 deletions
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for bowtie
|
||||
|
||||
# Copyright 2013 Petar Petrov, ppetrov@paju.oulu.fi
|
||||
# Copyright 2013 Petar Petrov, petar.petrov@student.oulu.fi
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,7 +23,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=bowtie
|
||||
VERSION=${VERSION:-0.12.9}
|
||||
VERSION=${VERSION:-1.0.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -60,14 +60,20 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
unzip $CWD/$PRGNAM-$VERSION-src.zip
|
||||
tar xvf $CWD/${PRGNAM}_${VERSION}.orig.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Thanks to Debian for the set of patches!
|
||||
patch -p1 -i $CWD/patches/disable_bits_flag.patch
|
||||
patch -p1 -i $CWD/patches/no_hash_style_both_for_mips.patch
|
||||
patch -p1 -i $CWD/patches/seqan-fix-setBegin-call.patch
|
||||
patch -p1 -i $CWD/patches/use-dpkg-buildflags.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
|
@ -92,7 +98,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
|
|||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
AUTHORS COPYING MANUAL NEWS TUTORIAL VERSION doc \
|
||||
AUTHORS LICENSE MANUAL NEWS TUTORIAL VERSION doc \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="bowtie"
|
||||
VERSION="0.12.9"
|
||||
VERSION="1.0.0"
|
||||
HOMEPAGE="http://bowtie-bio.sourceforge.net/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/bowtie-bio/bowtie-0.12.9-src.zip"
|
||||
MD5SUM="3120f57a849ab885e928800c591764f8"
|
||||
DOWNLOAD="http://ftp.de.debian.org/debian/pool/main/b/bowtie/bowtie_1.0.0.orig.tar.gz"
|
||||
MD5SUM="75d402c856b64958ec4bc0f67d011eb9"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Petar Petrov"
|
||||
EMAIL="ppetrov@paju.oulu.fi"
|
||||
EMAIL="petar.petrov@student.oulu.fi"
|
||||
|
|
20
academic/bowtie/patches/disable_bits_flag.patch
Normal file
20
academic/bowtie/patches/disable_bits_flag.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
Description: Disable architecture bits detection.
|
||||
In Debian, you can use multiarch facilities for choosing which version
|
||||
to run.
|
||||
Author: Ognyan Kulev <ogi@debian.org>
|
||||
Forwarded: not-needed
|
||||
Last-Update: 2013-04-24
|
||||
---
|
||||
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
||||
--- bowtie-1.0.0.orig/Makefile
|
||||
+++ bowtie-1.0.0/Makefile
|
||||
@@ -121,6 +121,9 @@
|
||||
BITS_FLAG = -m64
|
||||
endif
|
||||
|
||||
+# Debian: Disable selection of 32/64-bits. Use multiarch instead.
|
||||
+BITS_FLAG =
|
||||
+
|
||||
DEBUG_FLAGS = -O0 -g3 $(BITS_FLAG)
|
||||
RELEASE_FLAGS = -O3 $(BITS_FLAG)
|
||||
NOASSERT_FLAGS = -DNDEBUG
|
20
academic/bowtie/patches/no_hash_style_both_for_mips.patch
Normal file
20
academic/bowtie/patches/no_hash_style_both_for_mips.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
Description: Disable -Wl,--hash-style=both on mips machines.
|
||||
It's not supported on mips and mipsel ports and leads to build errors.
|
||||
Author: Ognyan Kulev <ogi@debian.org>
|
||||
Forwarded: not-needed
|
||||
Last-Update: 2013-04-24
|
||||
---
|
||||
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
||||
--- bowtie-1.0.0.orig/Makefile
|
||||
+++ bowtie-1.0.0/Makefile
|
||||
@@ -45,7 +45,9 @@
|
||||
LINUX = 0
|
||||
ifneq (,$(findstring Linux,$(shell uname)))
|
||||
LINUX = 1
|
||||
- EXTRA_FLAGS += -Wl,--hash-style=both
|
||||
+ ifeq (,$(findstring mips,$(shell uname -m)))
|
||||
+ EXTRA_FLAGS += -Wl,--hash-style=both
|
||||
+ endif
|
||||
endif
|
||||
|
||||
MM_DEF =
|
42
academic/bowtie/patches/seqan-fix-setBegin-call.patch
Normal file
42
academic/bowtie/patches/seqan-fix-setBegin-call.patch
Normal file
|
@ -0,0 +1,42 @@
|
|||
Description: Proper type-casting in using seqan::_setBegin().
|
||||
Required by newer versions of GCC.
|
||||
Forwarded: no
|
||||
Author: Ognyan Kulev <ogi@debian.org>
|
||||
Last-Update: 2013-04-18
|
||||
|
||||
--- a/pat.h
|
||||
+++ b/pat.h
|
||||
@@ -82,20 +82,20 @@
|
||||
~ReadBuf() {
|
||||
clearAll(); reset();
|
||||
// Prevent seqan from trying to free buffers
|
||||
- _setBegin(patFw, NULL);
|
||||
- _setBegin(patRc, NULL);
|
||||
- _setBegin(qual, NULL);
|
||||
- _setBegin(patFwRev, NULL);
|
||||
- _setBegin(patRcRev, NULL);
|
||||
- _setBegin(qualRev, NULL);
|
||||
- _setBegin(name, NULL);
|
||||
+ _setBegin(patFw, (Dna5*)NULL);
|
||||
+ _setBegin(patRc, (Dna5*)NULL);
|
||||
+ _setBegin(qual, (char*)NULL);
|
||||
+ _setBegin(patFwRev, (Dna5*)NULL);
|
||||
+ _setBegin(patRcRev, (Dna5*)NULL);
|
||||
+ _setBegin(qualRev, (char*)NULL);
|
||||
+ _setBegin(name, (char*)NULL);
|
||||
for(int j = 0; j < 3; j++) {
|
||||
- _setBegin(altPatFw[j], NULL);
|
||||
- _setBegin(altPatFwRev[j], NULL);
|
||||
- _setBegin(altPatRc[j], NULL);
|
||||
- _setBegin(altPatRcRev[j], NULL);
|
||||
- _setBegin(altQual[j], NULL);
|
||||
- _setBegin(altQualRev[j], NULL);
|
||||
+ _setBegin(altPatFw[j], (Dna5*)NULL);
|
||||
+ _setBegin(altPatFwRev[j], (Dna5*)NULL);
|
||||
+ _setBegin(altPatRc[j], (Dna5*)NULL);
|
||||
+ _setBegin(altPatRcRev[j], (Dna5*)NULL);
|
||||
+ _setBegin(altQual[j], (char*)NULL);
|
||||
+ _setBegin(altQualRev[j], (char*)NULL);
|
||||
}
|
||||
}
|
||||
|
17
academic/bowtie/patches/use-dpkg-buildflags.patch
Normal file
17
academic/bowtie/patches/use-dpkg-buildflags.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
Description: Use build flags from environment (dpkg-buildflags).
|
||||
Necessary for hardening flags.
|
||||
Author: Simon Ruderich <simon@ruderich.org>
|
||||
Last-Update: 2012-04-24
|
||||
Bug-Closed: http://bugs.debian.org/670230
|
||||
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -173,7 +173,7 @@
|
||||
$(MM_DEF) \
|
||||
$(SHMEM_DEF)
|
||||
|
||||
-ALL_FLAGS = $(EXTRA_FLAGS) $(CFLAGS) $(CXXFLAGS)
|
||||
+ALL_FLAGS = $(EXTRA_FLAGS) $(CPPFLAGS) $(CFLAGS) $(CXXFLAGS) $(LDFLAGS)
|
||||
DEBUG_DEFS = -DCOMPILER_OPTIONS="\"$(DEBUG_FLAGS) $(ALL_FLAGS)\""
|
||||
RELEASE_DEFS = -DCOMPILER_OPTIONS="\"$(RELEASE_FLAGS) $(ALL_FLAGS)\""
|
||||
|
|
@ -13,7 +13,7 @@ bowtie: toward quickly aligning large sets of short DNA sequences (reads)
|
|||
bowtie: to large genomes.
|
||||
bowtie:
|
||||
bowtie: Home: http://bowtie-bio.sourceforge.net/
|
||||
bowtie: References: /usr/doc/bowtie-$VERSION/References
|
||||
bowtie: References: /usr/doc/bowtie-1.0.0/References
|
||||
bowtie:
|
||||
bowtie:
|
||||
bowtie:
|
||||
|
|
Loading…
Reference in a new issue