mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
games/bsnes: Updated for version 0.068.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
5875a1eacd
commit
eaf7f4d9be
4 changed files with 21 additions and 19 deletions
|
@ -63,12 +63,12 @@ diff --git a/src/Makefile b/src/Makefile
|
||||||
index c3c1fe9..4b5de6d 100755
|
index c3c1fe9..4b5de6d 100755
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -4,7 +4,7 @@ ui := ui_qt
|
@@ -4,7 +4,7 @@ ui := qt
|
||||||
# compiler
|
# compiler
|
||||||
c := $(compiler) -std=gnu99
|
c := $(compiler) -std=gnu99
|
||||||
cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
|
cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
|
||||||
-flags := -O3 -fomit-frame-pointer -I.
|
-flags := -O3 -fomit-frame-pointer -I. -I$(snes)
|
||||||
+flags := $(CXXFLAGS) -fomit-frame-pointer -I.
|
+flags := $(CXXFLAGS) -fomit-frame-pointer -I. -I$(snes)
|
||||||
link :=
|
link :=
|
||||||
objects :=
|
objects :=
|
||||||
|
|
||||||
|
@ -84,11 +84,12 @@ index c3c1fe9..4b5de6d 100755
|
||||||
@@ -60,8 +60,8 @@ endif
|
@@ -60,8 +60,8 @@ endif
|
||||||
install:
|
install:
|
||||||
ifeq ($(platform),x)
|
ifeq ($(platform),x)
|
||||||
install -D -m 755 ../bsnes $(DESTDIR)$(prefix)/bin/bsnes
|
- install -D -m 755 out/bsnes-$(profile) $(DESTDIR)$(prefix)/bin/bsnes-$(profile)
|
||||||
- install -D -m 644 data/bsnes.png $(DESTDIR)$(prefix)/share/pixmaps/bsnes.png
|
- install -D -m 644 qt/data/bsnes.png $(DESTDIR)$(prefix)/share/pixmaps/bsnes.png
|
||||||
- install -D -m 644 data/bsnes.desktop $(DESTDIR)$(prefix)/share/applications/bsnes.desktop
|
- install -D -m 644 qt/data/bsnes.desktop $(DESTDIR)$(prefix)/share/applications/bsnes.desktop
|
||||||
+ install -D -m 644 data/bsnes.png $(DESTDIR)/usr/share/pixmaps/bsnes.png
|
+ install -D -m 755 out/bsnes-$(profile) $(DESTDIR)$(prefix)/bin/bsnes
|
||||||
+ install -D -m 644 data/bsnes.desktop $(DESTDIR)/usr/share/applications/bsnes.desktop
|
+ install -D -m 644 qt/data/bsnes.png $(DESTDIR)$(prefix)/share/pixmaps/bsnes.png
|
||||||
|
+ install -D -m 644 qt/data/bsnes.desktop $(DESTDIR)$(prefix)/share/applications/bsnes.desktop
|
||||||
endif
|
endif
|
||||||
|
|
||||||
uninstall:
|
uninstall:
|
|
@ -5,7 +5,7 @@
|
||||||
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
|
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||||
|
|
||||||
PRGNAM=bsnes
|
PRGNAM=bsnes
|
||||||
VERSION=${VERSION:-0.067}
|
VERSION=${VERSION:-0.068}
|
||||||
SRCVER=${VERSION:2}
|
SRCVER=${VERSION:2}
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
@ -46,6 +46,7 @@ rm -rf $PRGNAM-$VERSION
|
||||||
mkdir $PRGNAM-$VERSION
|
mkdir $PRGNAM-$VERSION
|
||||||
cd $PRGNAM-$VERSION
|
cd $PRGNAM-$VERSION
|
||||||
tar xvf $CWD/${PRGNAM}_v${SRCVER}.tar.bz2
|
tar xvf $CWD/${PRGNAM}_v${SRCVER}.tar.bz2
|
||||||
|
find . -type d -exec chmod -R 0755 {} \;
|
||||||
chown -R root:root .
|
chown -R root:root .
|
||||||
find . \
|
find . \
|
||||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||||
|
@ -53,10 +54,10 @@ find . \
|
||||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||||
-exec chmod 644 {} \;
|
-exec chmod 644 {} \;
|
||||||
|
|
||||||
cd src
|
cd $PRGNAM
|
||||||
|
|
||||||
# Patch makefile so SLKCFLAGS and LIBDIRSUFFIX are recognized.
|
# Patch makefile so SLKCFLAGS and LIBDIRSUFFIX are recognized.
|
||||||
cat $CWD/bsnes-0.064-makefile.patch \
|
cat $CWD/bsnes-0.068-makefile.patch \
|
||||||
| sed -e "/^\+/s|/lib/|/lib${LIBDIRSUFFIX}/|g" \
|
| sed -e "/^\+/s|/lib/|/lib${LIBDIRSUFFIX}/|g" \
|
||||||
| patch -p1
|
| patch -p1
|
||||||
|
|
||||||
|
@ -65,7 +66,7 @@ cat $CWD/bsnes-0.064-makefile.patch \
|
||||||
sed -i \
|
sed -i \
|
||||||
-e 's|audio.pulseaudio ||' \
|
-e 's|audio.pulseaudio ||' \
|
||||||
-e 's|audio.pulseaudiosimple ||' \
|
-e 's|audio.pulseaudiosimple ||' \
|
||||||
-e '/pulse/d' ui_qt/Makefile
|
-e '/pulse/d' qt/Makefile
|
||||||
|
|
||||||
CXXFLAGS="$SLKCFLAGS" \
|
CXXFLAGS="$SLKCFLAGS" \
|
||||||
make \
|
make \
|
||||||
|
@ -92,7 +93,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||||
|
|
||||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
cp -a data/*.html $PKG/usr/doc/$PRGNAM-$VERSION
|
cp -a qt/data/*.html $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
find $PKG/usr/doc -type f -exec chmod 0644 {} \;
|
find $PKG/usr/doc -type f -exec chmod 0644 {} \;
|
||||||
|
|
||||||
|
|
|
@ -1,10 +1,10 @@
|
||||||
PRGNAM="bsnes"
|
PRGNAM="bsnes"
|
||||||
VERSION="0.067"
|
VERSION="0.068"
|
||||||
HOMEPAGE="http://byuu.org/bsnes/"
|
HOMEPAGE="http://byuu.org/bsnes/"
|
||||||
DOWNLOAD="http://bsnes.googlecode.com/files/bsnes_v067.tar.bz2"
|
DOWNLOAD="http://bsnes.googlecode.com/files/bsnes_v068.tar.bz2"
|
||||||
MD5SUM="c0cc823fe0b15a892af9e6d864214e29"
|
MD5SUM="9ff2f6dc64f54f0da538cefade64b3a7"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
MAINTAINER="Larry Hajali"
|
MAINTAINER="Larry Hajali"
|
||||||
EMAIL="larryhaja[at]gmail[dot]com"
|
EMAIL="larryhaja[at]gmail[dot]com"
|
||||||
APPROVED="Erik Hanson"
|
APPROVED="dsomero"
|
||||||
|
|
|
@ -7,13 +7,13 @@
|
||||||
|
|
||||||
|-----handy-ruler------------------------------------------------------|
|
|-----handy-ruler------------------------------------------------------|
|
||||||
bsnes: bsnes (SNES Emulator)
|
bsnes: bsnes (SNES Emulator)
|
||||||
bsnes:
|
bsnes:
|
||||||
bsnes: bsnes is an emulator that began development on 2004-10-14. The purpose
|
bsnes: bsnes is an emulator that began development on 2004-10-14. The purpose
|
||||||
bsnes: of this emulator is a bit different from others: it focuses on
|
bsnes: of this emulator is a bit different from others: it focuses on
|
||||||
bsnes: accuracy, debugging functionality, and clean code. The emulator does
|
bsnes: accuracy, debugging functionality, and clean code. The emulator does
|
||||||
bsnes: not focus on things that would hinder accuracy. This includes speed
|
bsnes: not focus on things that would hinder accuracy. This includes speed
|
||||||
bsnes: and game-specific hacks for compatibility. As a result, the minimum
|
bsnes: and game-specific hacks for compatibility. As a result, the minimum
|
||||||
bsnes: system requirements for bsnes are very high.
|
bsnes: system requirements for bsnes are very high.
|
||||||
bsnes:
|
bsnes:
|
||||||
bsnes: Homepage: http://byuu.org/bsnes/
|
bsnes: Homepage: http://byuu.org/bsnes/
|
||||||
bsnes:
|
bsnes:
|
||||||
|
|
Loading…
Reference in a new issue