games/assaultcube: Updated for version 1.1.0.1.

Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
Larry Hajali 2010-08-25 20:35:14 -04:00 committed by Erik Hanson
parent 79131597cb
commit 5875a1eacd
7 changed files with 43 additions and 57 deletions

View file

@ -1,28 +1,10 @@
diff -Naur update.orig/source/src/Makefile update/source/src/Makefile
--- update.orig/source/src/Makefile 2009-02-14 16:02:36.000000000 +0000
+++ update/source/src/Makefile 2009-06-29 16:57:39.000000000 +0000
@@ -1,12 +1,12 @@
-CXXOPTFLAGS=-O3 -fomit-frame-pointer
-INCLUDES1=-I/usr/X11R6/include -I../enet/include -I../src
+CXXOPTFLAGS?=-O3 -fomit-frame-pointer
+INCLUDES1=-I../enet/include -I/usr/X11R6/include -I../src
INCLUDES2=`sdl-config --cflags`
CXXCUSTOMFLAGS=-fsigned-char -Wall -Wextra -Wno-missing-field-initializers -Wno-unused -Wpointer-arith -Wwrite-strings -Wconversion -rdynamic
CXXFLAGS=$(CXXOPTFLAGS) $(INCLUDES1) $(INCLUDES2) $(CUSTOMFLAGS)
CXXFLAGSSERVER=$(CXXOPTFLAGS) $(INCLUDES1) $(CUSTOMFLAGS)
diff -Naur 1.1.0.0.orig/source/src/Makefile 1.1.0.0/source/src/Makefile
--- 1.1.0.0.orig/source/src/Makefile 2010-08-03 17:33:18.000000000 +0000
+++ 1.1.0.0/source/src/Makefile 2010-08-05 23:42:36.631639906 +0000
@@ -1,5 +1,5 @@
//CXX=g++-gcc-4.2.3
-CXXFLAGS= -O3 -fomit-frame-pointer
+CXXFLAGS= $(EXTRA_CXXFLAGS) -fomit-frame-pointer
override CXXFLAGS+= -Wall -fsigned-char
PLATFORM_PREFIX=native
-CLIENT_LIBS=-L/usr/X11R6/lib -L../enet -lenet `sdl-config --libs` -lSDL_image -lz -lGL -lopenal -lvorbisfile
+CLIENT_LIBS=-L../enet -lenet -L/usr/X11R6/lib `sdl-config --libs` -lSDL_image -lz -lGL -lopenal -lvorbisfile
CLIENT_OBJS1= \
client.o \
clientgame.o \
@@ -69,7 +69,7 @@
all: libenet client server
../enet/Makefile:
- cd ../enet; ./configure
+ cd ../enet; ./configure --enable-crc32
libenet: ../enet/Makefile
-$(MAKE) -C ../enet all
PLATFORM= $(shell uname -s)

View file

@ -1,5 +1,10 @@
AssaultCube (formerly ActionCube) is a free first-person-shooter based on
the game Cube. Set in a realistic looking environment, as far as that's
possible with this engine, while gameplay stays fast and arcade.
formerly ActionCube, is a free first-person-shooter
based on the game Cube. Set in a realistic looking
environment, as far as that´s possible with this
engine, while gameplay stays fast and arcade.
This requires OpenAL.
AssaultCube requires OpenAL.
Note: If upgrading from version 1.0 or earlier then the new
directory "~/.assaultcube_v1.1" will be created and previous
settings will not be applied to new version.

View file

@ -6,8 +6,8 @@
SRCNAM=AssaultCube
PRGNAM=assaultcube
VERSION=1.0.4
BUILD=${BUILD:-2}
VERSION=1.1.0.1
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -38,9 +38,10 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf ${SRCNAM}_v${VERSION}
rm -rf $VERSION
tar xvf $CWD/${SRCNAM}_v${VERSION}.tar.bz2
cd ${SRCNAM}_v${VERSION}
tar xvf $CWD/${SRCNAM}_v${VERSION}.source.tar.bz2
cd $VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@ -48,25 +49,22 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# We need to change the order of the enet libs and includes. Enet libs and include
# directories need to be declared first as compile will fail if enet is already
# installed on the system and the Makefile uses system files instead. Also, use
# custom SLKCFLAGS and remove precompiled binaries.
# Use custom SLKCFLAGS and remove precompiled binaries.
patch -p1 < $CWD/Makefile.patch
sed -i "s|-O2|$SLKCFLAGS|" source/enet/configure
rm -f bin_unix/*
CXXOPTFLAGS="$SLKCFLAGS -fomit-frame-pointer" \
EXTRA_CXXFLAGS="$SLKCFLAGS" \
make -C source/src
CXXOPTFLAGS="$SLKCFLAGS -fomit-frame-pointer" \
make -C source/src install
EXTRA_CXXFLAGS="$SLKCFLAGS" \
make -C source/src client_install
mkdir -p $PKG/usr/games $PKG/usr/share/$PRGNAM
sed -i "/^CUBE_DIR/s|=.*|=\"/usr/share/${PRGNAM}\"|" $PRGNAM.sh
install -m 0755 $PRGNAM.sh $PKG/usr/games/$PRGNAM
chmod 0755 bin_unix/*
cp -ar \
bin_unix config bot demos mods packages screenshots \
bin_unix config demos mods packages screenshots \
$PKG/usr/share/$PRGNAM
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
@ -75,7 +73,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
mkdir -p $PKG/usr/share/applications
install -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications
for i in 16 32 64 96 128; do
convert icon.ico -resize ${i}x${i}! $PRGNAM-$i.png
convert source/vcpp/buildEnv/icon.ico -resize ${i}x${i}! $PRGNAM-$i.png
install -D -m 0644 $PRGNAM-$i-0.png \
$PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM.png
done

View file

@ -1,11 +1,11 @@
[Desktop Entry]
Type=Application
Exec=assaultcube
Icon=assaultcube
Type=Application
X-MultipleArgs=false
Terminal=false
Name=AssaultCube
GenericName=Realistic Multiplayer FPS
MimeType=text/html;
StartupNotify=false
Terminal=false
Categories=Game;ActionGame;
Name=AssaultCube
Comment=Fast paced first-person shooter based upon the Cube engine
Comment[pl]=Szybka strzelanka oparta na silniku gry Cube
Comment[de]=Schneller Ego-Shooter basierend auf der Cube-Engine

View file

@ -1,10 +1,12 @@
PRGNAM="assaultcube"
VERSION="1.0.4"
VERSION="1.1.0.1"
HOMEPAGE="http://assault.cubers.net/"
DOWNLOAD="http://downloads.sourceforge.net/actiongame/AssaultCube_v1.0.4.tar.bz2"
MD5SUM="310dfc4c225329cdf1333e08a35ff175"
DOWNLOAD="http://downloads.sourceforge.net/actiongame/AssaultCube_v1.1.0.1.tar.bz2
http://downloads.sourceforge.net/actiongame/AssaultCube_v1.1.0.1.source.tar.bz2"
MD5SUM="9ad55a9e032efc59eb1f2f89577647c3
566388ec0cf5d3a910c90763656e5292"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
APPROVED="rworkman"
APPROVED="dsomero"

View file

@ -7,4 +7,3 @@ if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
fi
fi

View file

@ -7,13 +7,13 @@
|-----handy-ruler------------------------------------------------------|
assaultcube: AssaultCube (First person shooter game)
assaultcube:
assaultcube:
assaultcube: AssaultCube, formerly ActionCube, is a free first-person-shooter
assaultcube: based on the game Cube. Set in a realistic looking environment,
assaultcube: as far as that's possible with this engine, while gameplay stays
assaultcube: fast and arcade. This game is all about team oriented multiplayer
assaultcube: fun. Network game also 56k and up.
assaultcube:
assaultcube:
assaultcube: Homepage: http://assault.cubers.net/
assaultcube:
assaultcube: