academic/btf: Updated for version 1.2.6.

Signed-off-by: Kyle Guinn <elyk03@gmail.com>
This commit is contained in:
Kyle Guinn 2016-11-19 01:50:03 -06:00 committed by David Spencer
parent 2faa53bf58
commit dbcd6295df
3 changed files with 22 additions and 20 deletions

View file

@ -25,14 +25,14 @@
PRGNAM=btf
SRCNAM=SuiteSparse
SUBDIR=BTF
VERSION=${VERSION:-1.2.1}
SRCVER=${SRCVER:-4.4.6}
BUILD=${BUILD:-2}
VERSION=${VERSION:-1.2.6}
SRCVER=${SRCVER:-4.5.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
i?86) ARCH=i486 ;;
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$(uname -m) ;;
esac
@ -43,11 +43,14 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
DOCS="README.txt Doc/ChangeLog Doc/lesser.txt"
DOCS="README.txt Doc/ChangeLog Doc/License.txt Doc/lesser.txt"
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
@ -73,10 +76,9 @@ cd $SRCNAM/$SUBDIR
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
patch -p1 < $CWD/autotoolize.diff
patch -p1 < $CWD/patches/autotoolize.diff
autoreconf -vif
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
@ -88,7 +90,8 @@ CFLAGS="$SLKCFLAGS" \
--enable-shared \
--disable-static \
--disable-dependency-tracking \
--build=$ARCH-slackware-linux
--build=$ARCH-slackware-linux \
CFLAGS="$SLKCFLAGS" \
make
make check

View file

@ -1,8 +1,8 @@
PRGNAM="btf"
VERSION="1.2.1"
VERSION="1.2.6"
HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.4.6.tar.gz"
MD5SUM="131a3a5e2dee784cd946284e44ce9af2"
DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.5.3.tar.gz"
MD5SUM="8ec57324585df3c6483ad7f556afccbd"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="suitesparseconfig"

View file

@ -9,11 +9,10 @@ diff --git a/Makefile.am b/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,5 @@
@@ -0,0 +1,4 @@
+SUBDIRS = Include Source
+EXTRA_DIST = README.txt Doc/ChangeLog Doc/lesser.txt
+EXTRA_DIST = README.txt Doc/ChangeLog Doc/License.txt Doc/lesser.txt
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = btf.pc
diff --git a/Source/Makefile.am b/Source/Makefile.am
new file mode 100644
@ -64,21 +63,19 @@ new file mode 100644
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
+AC_INIT([BTF],[1.2.1],[DrTimothyAldenDavis@gmail.com],[btf],[http://www.suitesparse.com/])
+AC_INIT([BTF],[1.2.6],[DrTimothyAldenDavis@gmail.com],[btf],[http://www.suitesparse.com/])
+AC_CONFIG_SRCDIR([Source/btf_order.c])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign])
+LT_INIT
+
+# Checks for programs.
+PKG_PROG_PKG_CONFIG
+AC_PROG_INSTALL
+AC_PROG_CC
+
+# Checks for libraries.
+PKG_PROG_PKG_CONFIG
+PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
+ [],
+ [AC_MSG_ERROR([cannot find suitesparseconfig])])
+PKG_CHECK_MODULES([SUITESPARSECONFIG], [suitesparseconfig])
+
+# Checks for header files.
+
@ -86,9 +83,11 @@ new file mode 100644
+
+# Checks for library functions.
+
+PKG_INSTALLDIR
+AC_CONFIG_FILES([
+ btf.pc
+ Makefile
+ Include/Makefile
+ Source/Makefile])
+ Source/Makefile
+])
+AC_OUTPUT