mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
academic/ldl: Updated for version 2.2.6.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
This commit is contained in:
parent
50100e1876
commit
2faa53bf58
3 changed files with 35 additions and 32 deletions
|
@ -25,14 +25,14 @@
|
|||
PRGNAM=ldl
|
||||
SRCNAM=SuiteSparse
|
||||
SUBDIR=LDL
|
||||
VERSION=${VERSION:-2.2.1}
|
||||
SRCVER=${SRCVER:-4.4.6}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-2.2.6}
|
||||
SRCVER=${SRCVER:-4.5.3}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$(uname -m)" in
|
||||
i?86) ARCH=i486 ;;
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$(uname -m) ;;
|
||||
esac
|
||||
|
@ -43,11 +43,14 @@ TMP=${TMP:-/tmp/SBo}
|
|||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
DOCS="README.txt Doc/ChangeLog Doc/lesser.txt"
|
||||
DOCS="README.txt Doc/ChangeLog Doc/License.txt Doc/lesser.txt"
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
|
@ -73,10 +76,12 @@ cd $SRCNAM/$SUBDIR
|
|||
chown -R root:root .
|
||||
chmod -R u+w,go-w,a+rX-st .
|
||||
|
||||
patch -p1 < $CWD/autotoolize.diff
|
||||
patch -p1 < $CWD/patches/autotoolize.diff
|
||||
autoreconf -vif
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
# Avoid rebuilding the docs.
|
||||
touch Doc/ldl_userguide.pdf
|
||||
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
|
@ -88,7 +93,8 @@ CFLAGS="$SLKCFLAGS" \
|
|||
--enable-shared \
|
||||
--disable-static \
|
||||
--disable-dependency-tracking \
|
||||
--build=$ARCH-slackware-linux
|
||||
--build=$ARCH-slackware-linux \
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
|
||||
make
|
||||
make check
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="ldl"
|
||||
VERSION="2.2.1"
|
||||
VERSION="2.2.6"
|
||||
HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
|
||||
DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.4.6.tar.gz"
|
||||
MD5SUM="131a3a5e2dee784cd946284e44ce9af2"
|
||||
DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.5.3.tar.gz"
|
||||
MD5SUM="8ec57324585df3c6483ad7f556afccbd"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="suitesparseconfig"
|
||||
|
|
|
@ -30,11 +30,11 @@ new file mode 100644
|
|||
+ ldllamd
|
||||
+
|
||||
+ldlamd_SOURCES = ldlmain.c
|
||||
+ldlamd_CPPFLAGS = $(AM_CPPFLAGS) -DUSE_AMD
|
||||
+ldlamd_CPPFLAGS = $(AM_CPPFLAGS) -DUSE_AMD
|
||||
+ldlamd_LDADD = $(LDADD) $(AMD_LIBS)
|
||||
+
|
||||
+ldllamd_SOURCES = ldlmain.c
|
||||
+ldllamd_CPPFLAGS = $(AM_CPPFLAGS) -DUSE_AMD -DLDL_LONG
|
||||
+ldllamd_CPPFLAGS = $(AM_CPPFLAGS) -DUSE_AMD -DLDL_LONG
|
||||
+ldllamd_LDADD = $(LDADD) $(AMD_LIBS)
|
||||
+endif
|
||||
+
|
||||
|
@ -65,7 +65,7 @@ new file mode 100644
|
|||
--- /dev/null
|
||||
+++ b/Doc/Makefile.am
|
||||
@@ -0,0 +1,23 @@
|
||||
+EXTRA_DIST = ChangeLog lesser.txt
|
||||
+EXTRA_DIST = ChangeLog License.txt lesser.txt
|
||||
+
|
||||
+dist_noinst_DATA = ldl_userguide.tex ldl.bib
|
||||
+dist_pdf_DATA = ldl_userguide.pdf
|
||||
|
@ -98,11 +98,10 @@ diff --git a/Makefile.am b/Makefile.am
|
|||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Makefile.am
|
||||
@@ -0,0 +1,5 @@
|
||||
@@ -0,0 +1,4 @@
|
||||
+SUBDIRS = Include Source Matrix Demo Doc
|
||||
+EXTRA_DIST = README.txt
|
||||
+
|
||||
+pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfig_DATA = ldl.pc
|
||||
diff --git a/Matrix/Makefile.am b/Matrix/Makefile.am
|
||||
new file mode 100644
|
||||
|
@ -138,35 +137,31 @@ diff --git a/configure.ac b/configure.ac
|
|||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/configure.ac
|
||||
@@ -0,0 +1,50 @@
|
||||
@@ -0,0 +1,48 @@
|
||||
+# -*- Autoconf -*-
|
||||
+# Process this file with autoconf to produce a configure script.
|
||||
+
|
||||
+AC_PREREQ([2.69])
|
||||
+AC_INIT([LDL],[2.2.1],[DrTimothyAldenDavis@gmail.com],[ldl],[http://www.suitesparse.com/])
|
||||
+AC_INIT([LDL],[2.2.6],[DrTimothyAldenDavis@gmail.com],[ldl],[http://www.suitesparse.com/])
|
||||
+AC_CONFIG_SRCDIR([Source/ldl.c])
|
||||
+AC_CONFIG_HEADERS([config.h])
|
||||
+AM_INIT_AUTOMAKE([foreign])
|
||||
+LT_INIT
|
||||
+
|
||||
+# Checks for programs.
|
||||
+PKG_PROG_PKG_CONFIG
|
||||
+AC_PROG_INSTALL
|
||||
+AC_PROG_CC
|
||||
+AC_PROG_LN_S
|
||||
+
|
||||
+LIBS_SAVED=$LIBS
|
||||
+AS_VAR_SET([LIBS_SAVED], [$LIBS])
|
||||
+
|
||||
+# Checks for libraries.
|
||||
+PKG_PROG_PKG_CONFIG
|
||||
+PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
|
||||
+ [],
|
||||
+ [AC_MSG_ERROR([cannot find suitesparseconfig])])
|
||||
+PKG_CHECK_MODULES([AMD],[amd],
|
||||
+ [amd="yes"],
|
||||
+ [amd="no"])
|
||||
+if test "x$amd" != "xyes"; then
|
||||
+ AC_MSG_WARN([cannot find amd, disabling some functionality])
|
||||
+fi
|
||||
+PKG_CHECK_MODULES([SUITESPARSECONFIG], [suitesparseconfig])
|
||||
+PKG_CHECK_MODULES([AMD], [amd],
|
||||
+ [AS_VAR_SET([have_amd], [yes])],
|
||||
+ [AS_VAR_SET([have_amd], [no])
|
||||
+ AC_MSG_WARN([$AMD_PKG_ERRORS (required by some demos), disabling some functionality])])
|
||||
+
|
||||
+# Checks for header files.
|
||||
+AC_CHECK_HEADERS([stdlib.h])
|
||||
|
@ -176,10 +171,11 @@ new file mode 100644
|
|||
+# Checks for library functions.
|
||||
+AC_FUNC_MALLOC
|
||||
+
|
||||
+LIBS=$LIBS_SAVED
|
||||
+AS_VAR_SET([LIBS], [$LIBS_SAVED])
|
||||
+
|
||||
+AM_CONDITIONAL([AMD], [test "x$amd" = "xyes"])
|
||||
+AM_CONDITIONAL([AMD], [test "x$have_amd" = "xyes"])
|
||||
+
|
||||
+PKG_INSTALLDIR
|
||||
+AC_CONFIG_FILES([
|
||||
+ ldl.pc
|
||||
+ Makefile
|
||||
|
@ -187,7 +183,8 @@ new file mode 100644
|
|||
+ Doc/Makefile
|
||||
+ Include/Makefile
|
||||
+ Matrix/Makefile
|
||||
+ Source/Makefile])
|
||||
+ Source/Makefile
|
||||
+])
|
||||
+AC_OUTPUT
|
||||
diff --git a/ldl.pc.in b/ldl.pc.in
|
||||
new file mode 100644
|
Loading…
Reference in a new issue