mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
academic/octave: Updated for version 4.0.0.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
This commit is contained in:
parent
dd0696e586
commit
bfa2855877
6 changed files with 22 additions and 321 deletions
|
@ -2,3 +2,9 @@ if [ -x /usr/bin/update-desktop-database ]; then
|
|||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
||||
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for octave
|
||||
|
||||
# Copyright 2012-2014 Kyle Guinn <elyk03@gmail.com>, USA
|
||||
# Copyright 2012-2015 Kyle Guinn <elyk03@gmail.com>, USA
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,15 +23,15 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=octave
|
||||
VERSION=${VERSION:-3.8.2}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-4.0.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
case "$(uname -m)" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
*) ARCH=$(uname -m) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
|
@ -69,32 +69,20 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go-w,a+rX-st .
|
||||
|
||||
# Auto-detect OpenBLAS.
|
||||
cat $CWD/patches/ax_blas.m4 > m4/ax_blas.m4
|
||||
|
||||
# Add a patch from bug 41055. See below.
|
||||
patch -p1 < $CWD/patches/missing-info-error.diff
|
||||
|
||||
# Don't try to detect Qt5. It's not supported yet.
|
||||
# https://savannah.gnu.org/bugs/?40252
|
||||
patch -p1 < $CWD/patches/no-qt5.diff
|
||||
autoreconf -vif
|
||||
|
||||
# Avoid rebuilding the documentation by making stamp-vti newer than its
|
||||
# dependencies (in particular ./configure, which we just modified above).
|
||||
# dependencies (in particular ./configure, which we may need to patch).
|
||||
# If you live far enough east or west that the date contained in version.texi
|
||||
# does not match that file's timestamp when printed accounting for your
|
||||
# timezone, then the docs get rebuilt with your local date.
|
||||
#
|
||||
# The TeX environment in Slackware 14.1 fails to build the DVI and PDF
|
||||
# targets in Octave 3.8.1. Maybe it works with a recent version of TeXLive?
|
||||
touch doc/liboctave/stamp-vti
|
||||
touch doc/interpreter/stamp-vti
|
||||
find . -name stamp-vti -exec touch {} +
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
|
@ -113,14 +101,15 @@ FFLAGS="$SLKCFLAGS" \
|
|||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make check
|
||||
make install-strip DESTDIR=$PKG
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
find $PKG/usr/lib${LIBDIRSUFFIX} -name '*.la' -delete
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} +
|
||||
|
||||
rm -f $PKG/usr/info/dir
|
||||
# Don't compress info pages, `octave --force-gui` can't handle them compressed.
|
||||
# https://savannah.gnu.org/bugs/?41055
|
||||
#gzip -9 $PKG/usr/info/*.info*
|
||||
gzip -9 $PKG/usr/info/*.info*
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="octave"
|
||||
VERSION="3.8.2"
|
||||
VERSION="4.0.0"
|
||||
HOMEPAGE="https://www.gnu.org/software/octave/"
|
||||
DOWNLOAD="ftp://ftp.gnu.org/gnu/octave/octave-3.8.2.tar.bz2"
|
||||
MD5SUM="188bd97e22054f9c62701ee0e6800dc1"
|
||||
DOWNLOAD="ftp://ftp.gnu.org/gnu/octave/octave-4.0.0.tar.xz"
|
||||
MD5SUM="f3de0a0d9758e112f13ce1f5eaf791bf"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="%README% blas lapack"
|
||||
|
|
|
@ -1,238 +0,0 @@
|
|||
# ===========================================================================
|
||||
# http://www.gnu.org/software/autoconf-archive/ax_blas.html
|
||||
# ===========================================================================
|
||||
#
|
||||
# SYNOPSIS
|
||||
#
|
||||
# AX_BLAS([ACTION-IF-FOUND[, ACTION-IF-NOT-FOUND]])
|
||||
#
|
||||
# DESCRIPTION
|
||||
#
|
||||
# This macro looks for a library that implements the BLAS linear-algebra
|
||||
# interface (see http://www.netlib.org/blas/). On success, it sets the
|
||||
# BLAS_LIBS output variable to hold the requisite library linkages.
|
||||
#
|
||||
# To link with BLAS, you should link with:
|
||||
#
|
||||
# $BLAS_LIBS $LIBS $FLIBS
|
||||
#
|
||||
# in that order. FLIBS is the output variable of the
|
||||
# AC_F77_LIBRARY_LDFLAGS macro (called if necessary by AX_BLAS), and is
|
||||
# sometimes necessary in order to link with F77 libraries. Users will also
|
||||
# need to use AC_F77_DUMMY_MAIN (see the autoconf manual), for the same
|
||||
# reason.
|
||||
#
|
||||
# Many libraries are searched for, from ATLAS to CXML to ESSL. The user
|
||||
# may also use --with-blas=<lib> in order to use some specific BLAS
|
||||
# library <lib>. In order to link successfully, however, be aware that you
|
||||
# will probably need to use the same Fortran compiler (which can be set
|
||||
# via the F77 env. var.) as was used to compile the BLAS library.
|
||||
#
|
||||
# ACTION-IF-FOUND is a list of shell commands to run if a BLAS library is
|
||||
# found, and ACTION-IF-NOT-FOUND is a list of commands to run it if it is
|
||||
# not found. If ACTION-IF-FOUND is not specified, the default action will
|
||||
# define HAVE_BLAS.
|
||||
#
|
||||
# LICENSE
|
||||
#
|
||||
# Copyright (c) 2008 Steven G. Johnson <stevenj@alum.mit.edu>
|
||||
#
|
||||
# This program is free software: you can redistribute it and/or modify it
|
||||
# under the terms of the GNU General Public License as published by the
|
||||
# Free Software Foundation, either version 3 of the License, or (at your
|
||||
# option) any later version.
|
||||
#
|
||||
# This program is distributed in the hope that it will be useful, but
|
||||
# WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
|
||||
# Public License for more details.
|
||||
#
|
||||
# You should have received a copy of the GNU General Public License along
|
||||
# with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
#
|
||||
# As a special exception, the respective Autoconf Macro's copyright owner
|
||||
# gives unlimited permission to copy, distribute and modify the configure
|
||||
# scripts that are the output of Autoconf when processing the Macro. You
|
||||
# need not follow the terms of the GNU General Public License when using
|
||||
# or distributing such scripts, even though portions of the text of the
|
||||
# Macro appear in them. The GNU General Public License (GPL) does govern
|
||||
# all other use of the material that constitutes the Autoconf Macro.
|
||||
#
|
||||
# This special exception to the GPL applies to versions of the Autoconf
|
||||
# Macro released by the Autoconf Archive. When you make and distribute a
|
||||
# modified version of the Autoconf Macro, you may extend this special
|
||||
# exception to the GPL to apply to your modified version as well.
|
||||
|
||||
#serial 14
|
||||
|
||||
AU_ALIAS([ACX_BLAS], [AX_BLAS])
|
||||
AC_DEFUN([AX_BLAS], [
|
||||
AC_PREREQ(2.50)
|
||||
AC_REQUIRE([AC_F77_LIBRARY_LDFLAGS])
|
||||
AC_REQUIRE([AC_CANONICAL_HOST])
|
||||
ax_blas_ok=no
|
||||
|
||||
AC_ARG_WITH(blas,
|
||||
[AS_HELP_STRING([--with-blas=<lib>], [use BLAS library <lib>])])
|
||||
case $with_blas in
|
||||
yes | "") ;;
|
||||
no) ax_blas_ok=disable ;;
|
||||
-* | */* | *.a | *.so | *.so.* | *.o) BLAS_LIBS="$with_blas" ;;
|
||||
*) BLAS_LIBS="-l$with_blas" ;;
|
||||
esac
|
||||
|
||||
# Get fortran linker names of BLAS functions to check for.
|
||||
AC_F77_FUNC(sgemm)
|
||||
AC_F77_FUNC(dgemm)
|
||||
|
||||
ax_blas_save_LIBS="$LIBS"
|
||||
LIBS="$LIBS $FLIBS"
|
||||
|
||||
# First, check BLAS_LIBS environment variable
|
||||
if test $ax_blas_ok = no; then
|
||||
if test "x$BLAS_LIBS" != x; then
|
||||
save_LIBS="$LIBS"; LIBS="$BLAS_LIBS $LIBS"
|
||||
AC_MSG_CHECKING([for $sgemm in $BLAS_LIBS])
|
||||
AC_TRY_LINK_FUNC($sgemm, [ax_blas_ok=yes], [BLAS_LIBS=""])
|
||||
AC_MSG_RESULT($ax_blas_ok)
|
||||
LIBS="$save_LIBS"
|
||||
fi
|
||||
fi
|
||||
|
||||
# BLAS linked to by default? (happens on some supercomputers)
|
||||
if test $ax_blas_ok = no; then
|
||||
save_LIBS="$LIBS"; LIBS="$LIBS"
|
||||
AC_MSG_CHECKING([if $sgemm is being linked in already])
|
||||
AC_TRY_LINK_FUNC($sgemm, [ax_blas_ok=yes])
|
||||
AC_MSG_RESULT($ax_blas_ok)
|
||||
LIBS="$save_LIBS"
|
||||
fi
|
||||
|
||||
# BLAS in OpenBLAS library? (http://xianyi.github.com/OpenBLAS/)
|
||||
if test $ax_blas_ok = no; then
|
||||
AC_CHECK_LIB(openblas, $sgemm, [ax_blas_ok=yes
|
||||
BLAS_LIBS="-lopenblas"])
|
||||
fi
|
||||
|
||||
# BLAS in ATLAS library? (http://math-atlas.sourceforge.net/)
|
||||
if test $ax_blas_ok = no; then
|
||||
AC_CHECK_LIB(atlas, ATL_xerbla,
|
||||
[AC_CHECK_LIB(f77blas, $sgemm,
|
||||
[AC_CHECK_LIB(cblas, cblas_dgemm,
|
||||
[ax_blas_ok=yes
|
||||
BLAS_LIBS="-lcblas -lf77blas -latlas"],
|
||||
[], [-lf77blas -latlas])],
|
||||
[], [-latlas])])
|
||||
fi
|
||||
|
||||
# BLAS in PhiPACK libraries? (requires generic BLAS lib, too)
|
||||
if test $ax_blas_ok = no; then
|
||||
AC_CHECK_LIB(blas, $sgemm,
|
||||
[AC_CHECK_LIB(dgemm, $dgemm,
|
||||
[AC_CHECK_LIB(sgemm, $sgemm,
|
||||
[ax_blas_ok=yes; BLAS_LIBS="-lsgemm -ldgemm -lblas"],
|
||||
[], [-lblas])],
|
||||
[], [-lblas])])
|
||||
fi
|
||||
|
||||
# BLAS in Intel MKL library?
|
||||
if test $ax_blas_ok = no; then
|
||||
# MKL for gfortran
|
||||
if test x"$ac_cv_fc_compiler_gnu" = xyes; then
|
||||
# 64 bit
|
||||
if test $host_cpu = x86_64; then
|
||||
AC_CHECK_LIB(mkl_gf_lp64, $sgemm,
|
||||
[ax_blas_ok=yes;BLAS_LIBS="-lmkl_gf_lp64 -lmkl_sequential -lmkl_core -lpthread"],,
|
||||
[-lmkl_gf_lp64 -lmkl_sequential -lmkl_core -lpthread])
|
||||
# 32 bit
|
||||
elif test $host_cpu = i686; then
|
||||
AC_CHECK_LIB(mkl_gf, $sgemm,
|
||||
[ax_blas_ok=yes;BLAS_LIBS="-lmkl_gf -lmkl_sequential -lmkl_core -lpthread"],,
|
||||
[-lmkl_gf -lmkl_sequential -lmkl_core -lpthread])
|
||||
fi
|
||||
# MKL for other compilers (Intel, PGI, ...?)
|
||||
else
|
||||
# 64-bit
|
||||
if test $host_cpu = x86_64; then
|
||||
AC_CHECK_LIB(mkl_intel_lp64, $sgemm,
|
||||
[ax_blas_ok=yes;BLAS_LIBS="-lmkl_intel_lp64 -lmkl_sequential -lmkl_core -lpthread"],,
|
||||
[-lmkl_intel_lp64 -lmkl_sequential -lmkl_core -lpthread])
|
||||
# 32-bit
|
||||
elif test $host_cpu = i686; then
|
||||
AC_CHECK_LIB(mkl_intel, $sgemm,
|
||||
[ax_blas_ok=yes;BLAS_LIBS="-lmkl_intel -lmkl_sequential -lmkl_core -lpthread"],,
|
||||
[-lmkl_intel -lmkl_sequential -lmkl_core -lpthread])
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
# Old versions of MKL
|
||||
if test $ax_blas_ok = no; then
|
||||
AC_CHECK_LIB(mkl, $sgemm, [ax_blas_ok=yes;BLAS_LIBS="-lmkl -lguide -lpthread"],,[-lguide -lpthread])
|
||||
fi
|
||||
|
||||
# BLAS in Apple vecLib library?
|
||||
if test $ax_blas_ok = no; then
|
||||
save_LIBS="$LIBS"; LIBS="-framework vecLib $LIBS"
|
||||
AC_MSG_CHECKING([for $sgemm in -framework vecLib])
|
||||
AC_TRY_LINK_FUNC($sgemm, [ax_blas_ok=yes;BLAS_LIBS="-framework vecLib"])
|
||||
AC_MSG_RESULT($ax_blas_ok)
|
||||
LIBS="$save_LIBS"
|
||||
fi
|
||||
|
||||
# BLAS in Alpha CXML library?
|
||||
if test $ax_blas_ok = no; then
|
||||
AC_CHECK_LIB(cxml, $sgemm, [ax_blas_ok=yes;BLAS_LIBS="-lcxml"])
|
||||
fi
|
||||
|
||||
# BLAS in Alpha DXML library? (now called CXML, see above)
|
||||
if test $ax_blas_ok = no; then
|
||||
AC_CHECK_LIB(dxml, $sgemm, [ax_blas_ok=yes;BLAS_LIBS="-ldxml"])
|
||||
fi
|
||||
|
||||
# BLAS in Sun Performance library?
|
||||
if test $ax_blas_ok = no; then
|
||||
if test "x$GCC" != xyes; then # only works with Sun CC
|
||||
AC_CHECK_LIB(sunmath, acosp,
|
||||
[AC_CHECK_LIB(sunperf, $sgemm,
|
||||
[BLAS_LIBS="-xlic_lib=sunperf -lsunmath"
|
||||
ax_blas_ok=yes],[],[-lsunmath])])
|
||||
fi
|
||||
fi
|
||||
|
||||
# BLAS in SCSL library? (SGI/Cray Scientific Library)
|
||||
if test $ax_blas_ok = no; then
|
||||
AC_CHECK_LIB(scs, $sgemm, [ax_blas_ok=yes; BLAS_LIBS="-lscs"])
|
||||
fi
|
||||
|
||||
# BLAS in SGIMATH library?
|
||||
if test $ax_blas_ok = no; then
|
||||
AC_CHECK_LIB(complib.sgimath, $sgemm,
|
||||
[ax_blas_ok=yes; BLAS_LIBS="-lcomplib.sgimath"])
|
||||
fi
|
||||
|
||||
# BLAS in IBM ESSL library? (requires generic BLAS lib, too)
|
||||
if test $ax_blas_ok = no; then
|
||||
AC_CHECK_LIB(blas, $sgemm,
|
||||
[AC_CHECK_LIB(essl, $sgemm,
|
||||
[ax_blas_ok=yes; BLAS_LIBS="-lessl -lblas"],
|
||||
[], [-lblas $FLIBS])])
|
||||
fi
|
||||
|
||||
# Generic BLAS library?
|
||||
if test $ax_blas_ok = no; then
|
||||
AC_CHECK_LIB(blas, $sgemm, [ax_blas_ok=yes; BLAS_LIBS="-lblas"])
|
||||
fi
|
||||
|
||||
AC_SUBST(BLAS_LIBS)
|
||||
|
||||
LIBS="$ax_blas_save_LIBS"
|
||||
|
||||
# Finally, execute ACTION-IF-FOUND/ACTION-IF-NOT-FOUND:
|
||||
if test x"$ax_blas_ok" = xyes; then
|
||||
ifelse([$1],,AC_DEFINE(HAVE_BLAS,1,[Define if you have a BLAS library.]),[$1])
|
||||
:
|
||||
else
|
||||
ax_blas_ok=no
|
||||
$2
|
||||
fi
|
||||
])dnl AX_BLAS
|
|
@ -1,38 +0,0 @@
|
|||
|
||||
# HG changeset patch
|
||||
# User Torsten <ttl@justmail.de>
|
||||
# Date 1388608160 -3600
|
||||
# Node ID d03a6d272fee1d167473a2aa25e530443fcbe5cc
|
||||
# Parent 5f7f5886692263efacc7141f0bbba341ae7804d1
|
||||
display error message in document browser when info file is missing
|
||||
|
||||
* webinfo.cc (constructor): display a message if info file does not exist
|
||||
|
||||
diff --git a/libgui/src/qtinfo/webinfo.cc b/libgui/src/qtinfo/webinfo.cc
|
||||
--- a/libgui/src/qtinfo/webinfo.cc
|
||||
+++ b/libgui/src/qtinfo/webinfo.cc
|
||||
@@ -94,8 +94,22 @@
|
||||
|
||||
resize (500, 300);
|
||||
|
||||
- set_info_path (QString::fromStdString (Vinfo_file));
|
||||
+ QFileInfo info_file = QFileInfo (QString::fromStdString (Vinfo_file));
|
||||
|
||||
+ if (info_file.exists ())
|
||||
+ set_info_path (QString::fromStdString (Vinfo_file));
|
||||
+ else
|
||||
+ { // Info file does not exist
|
||||
+ _search_check_box->setEnabled (false);
|
||||
+ _search_line_edit->setEnabled (false);
|
||||
+
|
||||
+ QTextBrowser *msg = addNewTab (tr ("Error"));
|
||||
+ QString msg_text = QString ("<html><body><br><br><center><b>%1"
|
||||
+ "</b></center></body></html>").
|
||||
+ arg (tr ("The info file %1 does not exist").
|
||||
+ arg(info_file.absoluteFilePath ()));
|
||||
+ msg->setHtml (msg_text);
|
||||
+ }
|
||||
}
|
||||
|
||||
void
|
||||
|
|
@ -1,18 +0,0 @@
|
|||
diff --git a/configure.ac b/configure.ac
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2745,10 +2745,10 @@
|
||||
fi
|
||||
|
||||
if test $build_gui = yes; then
|
||||
- AC_CHECK_TOOLS(MOC, [moc-qt5 moc-qt4 moc])
|
||||
- AC_CHECK_TOOLS(UIC, [uic-qt5 uic-qt4 uic])
|
||||
- AC_CHECK_TOOLS(RCC, [rcc-qt5 rcc-qt4 rcc])
|
||||
- AC_CHECK_TOOLS(LRELEASE, [lrelease-qt5 lrelease-qt4 lrelease])
|
||||
+ AC_CHECK_TOOLS(MOC, [moc-qt4 moc])
|
||||
+ AC_CHECK_TOOLS(UIC, [uic-qt4 uic])
|
||||
+ AC_CHECK_TOOLS(RCC, [rcc-qt4 rcc])
|
||||
+ AC_CHECK_TOOLS(LRELEASE, [lrelease-qt4 lrelease])
|
||||
if test -n "$MOC" && test -n "$UIC" && test -n "$RCC" && test -n "$LRELEASE"; then
|
||||
AC_DEFINE(HAVE_QT, 1,
|
||||
[Define to 1 if Qt is available (libraries, developer header files, utility programs (moc, uic, rcc, and lrelease))])
|
Loading…
Reference in a new issue