mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
academic/spqr: Updated for version 2.0.1.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
This commit is contained in:
parent
3589d04ece
commit
dd0696e586
3 changed files with 39 additions and 33 deletions
|
@ -2,13 +2,12 @@ diff --git a/Demo/Makefile.am b/Demo/Makefile.am
|
|||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Demo/Makefile.am
|
||||
@@ -0,0 +1,109 @@
|
||||
@@ -0,0 +1,111 @@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(CHOLMOD_CFLAGS) $(SUITESPARSECONFIG_CFLAGS)
|
||||
+LDADD = $(top_builddir)/Source/libspqr.la
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
+ README.txt \
|
||||
+ qrdemo_diary.txt \
|
||||
+ qrdemo_out.txt \
|
||||
+ qrdemoc_out.txt
|
||||
+
|
||||
|
@ -51,7 +50,8 @@ new file mode 100644
|
|||
+ $(top_srcdir)/Matrix/r2.mtx \
|
||||
+ $(top_srcdir)/Matrix/s32.mtx \
|
||||
+ $(top_srcdir)/Matrix/west0067.mtx \
|
||||
+ $(top_srcdir)/Matrix/young1c.mtx
|
||||
+ $(top_srcdir)/Matrix/young1c.mtx \
|
||||
+ $(top_srcdir)/Matrix/lp_e226_transposed.mtx
|
||||
+
|
||||
+check-local: $(check_PROGRAMS) $(MATRICES)
|
||||
+ -./qrsimple < $(top_srcdir)/Matrix/ash219.mtx
|
||||
|
@ -85,6 +85,7 @@ new file mode 100644
|
|||
+ -./qrdemo < $(top_srcdir)/Matrix/GD98_a.mtx
|
||||
+ -./qrdemo < $(top_srcdir)/Matrix/Ragusa16.mtx
|
||||
+ -./qrdemo < $(top_srcdir)/Matrix/young1c.mtx
|
||||
+ -./qrdemo < $(top_srcdir)/Matrix/lp_e226_transposed.mtx
|
||||
+ -./qrdemoc < $(top_srcdir)/Matrix/a2.mtx
|
||||
+ -./qrdemoc < $(top_srcdir)/Matrix/r2.mtx
|
||||
+ -./qrdemoc < $(top_srcdir)/Matrix/a04.mtx
|
||||
|
@ -112,6 +113,7 @@ new file mode 100644
|
|||
+ -./qrdemoc < $(top_srcdir)/Matrix/GD98_a.mtx
|
||||
+ -./qrdemoc < $(top_srcdir)/Matrix/Ragusa16.mtx
|
||||
+ -./qrdemoc < $(top_srcdir)/Matrix/young1c.mtx
|
||||
+ -./qrdemoc < $(top_srcdir)/Matrix/lp_e226_transposed.mtx
|
||||
diff --git a/Doc/Makefile.am b/Doc/Makefile.am
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
|
@ -169,7 +171,7 @@ diff --git a/Matrix/Makefile.am b/Matrix/Makefile.am
|
|||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Matrix/Makefile.am
|
||||
@@ -0,0 +1,32 @@
|
||||
@@ -0,0 +1,36 @@
|
||||
+EXTRA_DIST = \
|
||||
+ README.txt
|
||||
+
|
||||
|
@ -201,7 +203,11 @@ new file mode 100644
|
|||
+ r2.mtx \
|
||||
+ s32.mtx \
|
||||
+ west0067.mtx \
|
||||
+ young1c.mtx
|
||||
+ young1c.mtx \
|
||||
+ Franz6_id1959_aug.mtx \
|
||||
+ Groebner_id2003_aug.mtx \
|
||||
+ lp_e226.mtx \
|
||||
+ lp_e226_transposed.mtx
|
||||
diff --git a/Source/Makefile.am b/Source/Makefile.am
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
|
@ -260,7 +266,7 @@ new file mode 100644
|
|||
+ spqr_type.cpp
|
||||
+
|
||||
+libspqr_la_LIBADD = $(TBB_LIBS) $(CHOLMOD_LIBS) $(SUITESPARSECONFIG_LIBS) $(LAPACK_LIBS) $(BLAS_LIBS) -lm
|
||||
+libspqr_la_LDFLAGS = -no-undefined -version-number 1:3:1
|
||||
+libspqr_la_LDFLAGS = -no-undefined -release $(PACKAGE_VERSION)
|
||||
diff --git a/ax_blas.m4 b/ax_blas.m4
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
|
@ -649,7 +655,7 @@ new file mode 100644
|
|||
+# Process this file with autoconf to produce a configure script.
|
||||
+
|
||||
+AC_PREREQ([2.69])
|
||||
+AC_INIT([SPQR],[1.3.1],[DrTimothyAldenDavis@gmail.com],[spqr],[http://www.suitesparse.com/])
|
||||
+AC_INIT([SPQR],[2.0.1],[DrTimothyAldenDavis@gmail.com],[spqr],[http://www.suitesparse.com/])
|
||||
+AC_CONFIG_SRCDIR([Source/spqr_kernel.cpp])
|
||||
+AC_CONFIG_HEADERS([config.h])
|
||||
+AM_INIT_AUTOMAKE([foreign])
|
||||
|
|
|
@ -2,29 +2,31 @@
|
|||
|
||||
# Slackware build script for SPQR
|
||||
|
||||
# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
|
||||
# Copyright 2013-2015 Kyle Guinn <elyk03@gmail.com>, USA
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=spqr
|
||||
SRCNAM=SPQR
|
||||
VERSION=${VERSION:-1.3.1}
|
||||
SRCNAM=SuiteSparse
|
||||
SUBDIR=SPQR
|
||||
VERSION=${VERSION:-2.0.1}
|
||||
SRCVER=${SRCVER:-4.4.4}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -58,7 +60,7 @@ else
|
|||
fi
|
||||
|
||||
# Recommended by SuiteSparse
|
||||
SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
|
||||
SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64"
|
||||
|
||||
set -e
|
||||
|
||||
|
@ -66,14 +68,10 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $SRCNAM
|
||||
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
|
||||
cd $SRCNAM
|
||||
tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
|
||||
cd $SRCNAM/$SUBDIR
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
chmod -R u+w,go-w,a+rX-st .
|
||||
|
||||
patch -p1 < $CWD/autotoolize.diff
|
||||
patch -p1 < $CWD/atlas-threaded-blas.diff
|
||||
|
@ -98,6 +96,8 @@ make
|
|||
make check
|
||||
make install-strip DESTDIR=$PKG
|
||||
|
||||
find $PKG/usr/lib${LIBDIRSUFFIX} -name '*.la' -delete
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="spqr"
|
||||
VERSION="1.3.1"
|
||||
HOMEPAGE="https://www.cise.ufl.edu/research/sparse/SPQR/"
|
||||
DOWNLOAD="https://www.cise.ufl.edu/research/sparse/SPQR/SPQR-1.3.1.tar.gz"
|
||||
MD5SUM="c1a55e7ac6208f7657186aa01356c8f2"
|
||||
VERSION="2.0.1"
|
||||
HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
|
||||
DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.4.4.tar.gz"
|
||||
MD5SUM="e0af74476935c9ff6d971df8bb6b82fc"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="blas lapack suitesparseconfig cholmod tbb"
|
||||
|
|
Loading…
Reference in a new issue