mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
libraries/libvmime-zarafa: Adapted for Slackware 13.37
Added patch for newer gcc versions. Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
parent
89ed7e0e9c
commit
93d4ecdfe4
2 changed files with 14 additions and 4 deletions
|
@ -5,19 +5,17 @@
|
|||
# (with patches from zarafa)
|
||||
|
||||
# Written by Niels Horn <niels.horn@gmail.com>
|
||||
# revision date 2010/05/27
|
||||
# revision date 2011/03/09
|
||||
|
||||
PRGNAM=libvmime-zarafa
|
||||
VERSION=${VERSION:-0.7.1_p20100503}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
@ -67,6 +65,8 @@ done
|
|||
patch -p1 < $CWD/patches/flags.patch
|
||||
# Patch "configure" & src/Makefile.in to rename the library to "libvmime-zarafa"
|
||||
patch -p1 < $CWD/patches/name.patch
|
||||
# Patch for newer gcc versions (based on tips from the Zarafa forum)
|
||||
patch -p1 < $CWD/patches/libvmime_signal.patch
|
||||
|
||||
CFLAGS=$SLKCFLAGS \
|
||||
CXXFLAGS=$SLKCFLAGS \
|
||||
|
|
10
libraries/libvmime-zarafa/patches/libvmime_signal.patch
Normal file
10
libraries/libvmime-zarafa/patches/libvmime_signal.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- libvmime-0.7.1/vmime/platforms/posix/posixChildProcess.hpp 2005-05-25 16:14:54.000000000 -0300
|
||||
+++ libvmime-0.7.1_patched/vmime/platforms/posix/posixChildProcess.hpp 2011-03-09 01:09:18.000000000 -0300
|
||||
@@ -20,6 +20,7 @@
|
||||
#ifndef VMIME_PLATFORMS_POSIX_POSIXCHILDPROCESS_HPP_INCLUDED
|
||||
#define VMIME_PLATFORMS_POSIX_POSIXCHILDPROCESS_HPP_INCLUDED
|
||||
|
||||
+#include <signal.h>
|
||||
|
||||
#include "vmime/utility/childProcess.hpp"
|
||||
|
Loading…
Reference in a new issue