libraries/gtkextra: Adapted for Slackware 13.37

Added patch to build with gtk >= 2.21

Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
Niels Horn 2011-03-09 22:04:35 -03:00 committed by Robby Workman
parent 0f113124b0
commit 89ed7e0e9c
2 changed files with 32 additions and 3 deletions

View file

@ -4,11 +4,11 @@
# A set of extra widgets for GTK+
# Written by Niels Horn <niels.horn@gmail.com>
# Revision date: 2010/11/01
# Revision date: 2011/03/09
PRGNAM=gtkextra
VERSION=${VERSION:-2.1.2}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
SRCNAM=gtk+extra
@ -56,12 +56,14 @@ find . \
-exec chmod 644 {} \;
# Solve a problem with spaces in gtkextra/Makefile.in
# (This only breaks with make 3.82 from -current, but won't harm in 13.1)
patch -p1 < $CWD/make382.patch
# Resolve a bug in the code (thanks to the Gentoo people for finding it)
patch -p1 < $CWD/gtkcolorcombo.patch
# Patch code for gtk >= 2.21 (based on work by the folks from GTKada)
patch -p1 < $CWD/gtkextra_gtk2.21.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \

View file

@ -0,0 +1,27 @@
--- gtk+extra-2.1.2/gtkextra/gtkitementry.c 2010-03-13 02:49:00.000000000 -0300
+++ gtk+extra-2.1.2_patched/gtkextra/gtkitementry.c 2011-03-09 00:29:54.000000000 -0300
@@ -131,7 +131,6 @@
static PangoLayout *gtk_entry_ensure_layout (GtkEntry *entry,
gboolean include_preedit);
static void gtk_entry_queue_draw (GtkEntry *entry);
-static void gtk_entry_reset_im_context (GtkEntry *entry);
static void gtk_entry_recompute (GtkEntry *entry);
static void gtk_entry_get_cursor_locations (GtkEntry *entry,
CursorType type,
@@ -1755,16 +1754,6 @@
}
static void
-gtk_entry_reset_im_context (GtkEntry *entry)
-{
- if (entry->need_im_reset)
- {
- entry->need_im_reset = 0;
- gtk_im_context_reset (entry->im_context);
- }
-}
-
-static void
gtk_entry_get_cursor_locations (GtkEntry *entry,
CursorType type,
gint *strong_x,