mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
office/fbreader: Updated for Slackware 13.37
Included a patch for gcc-4.5.x Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
parent
7a1b4848a3
commit
0f113124b0
2 changed files with 17 additions and 8 deletions
|
@ -3,18 +3,17 @@
|
|||
# Slackware build script for fbreader
|
||||
# Originally written by Audrius Kazukauskas <audrius@neutrino.lt>
|
||||
# Maintained as of version 0.12.1 by Niels Horn <niels.horn@gmail.com>
|
||||
# revision date: 2010/06/01
|
||||
# revision date: 2011/03/09
|
||||
|
||||
PRGNAM=fbreader
|
||||
VERSION=${VERSION:-0.12.10}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
@ -41,17 +40,13 @@ elif [ "$ARCH" = "x86_64" ]; then
|
|||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
ARCHQUADLET=""
|
||||
elif [ "$ARCH" = "arm" ]; then
|
||||
SLKCFLAGS="-O2 -march=armv4t"
|
||||
LIBDIRSUFFIX=""
|
||||
ARCHQUADLET="-gnueabi"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
ARCHQUADLET=""
|
||||
fi
|
||||
|
||||
set -e # Exit on most errors
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
|
@ -83,6 +78,9 @@ sed -i 's|moc-qt4|moc|' makefiles/arch/desktop.mk
|
|||
sed -i 's|-I /usr/include/qt4|$(shell pkg-config --cflags QtGui)|' makefiles/arch/desktop.mk
|
||||
sed -i 's|-lQtGui|$(shell pkg-config --libs QtGui)|' makefiles/arch/desktop.mk
|
||||
|
||||
# Patch source for gcc45x hickup (from the friendly ARCH people)
|
||||
patch -p1 < $CWD/fbreader_gcc45x.patch
|
||||
|
||||
# Use "-j1" to avoid some warnings
|
||||
make -j1 LIBDIR=/usr/lib${LIBDIRSUFFIX}
|
||||
make install LIBDIR=/usr/lib${LIBDIRSUFFIX} DESTDIR=$PKG
|
||||
|
|
11
office/fbreader/fbreader_gcc45x.patch
Normal file
11
office/fbreader/fbreader_gcc45x.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- fbreader-0.12.10/fbreader/src/library/Library.cpp 2010-04-01 10:14:24.000000000 -0300
|
||||
+++ fbreader-0.12.10_patched/fbreader/src/library/Library.cpp 2011-03-09 01:48:27.000000000 -0300
|
||||
@@ -39,7 +39,7 @@
|
||||
shared_ptr<Library> Library::ourInstance;
|
||||
const size_t Library::MaxRecentListSize = 10;
|
||||
|
||||
-Library::Library &Library::Instance() {
|
||||
+Library &Library::Instance() {
|
||||
if (ourInstance.isNull()) {
|
||||
ourInstance = new Library();
|
||||
}
|
Loading…
Reference in a new issue