mirror of
git://slackware.nl/current.git
synced 2024-11-16 07:48:02 +01:00
b690812684
a/kernel-firmware-20241111_6482750-noarch-1.txz: Upgraded. d/tree-sitter-0.24.4-x86_64-1.txz: Upgraded. l/openexr-3.3.2-x86_64-1.txz: Upgraded. n/libgpg-error-1.51-x86_64-1.txz: Upgraded. n/wget-1.25.0-x86_64-1.txz: Upgraded. [Breaking change] Drop support for shorthand FTP URLs (CVE-2024-10524) [Breaking change] Switch to continuous reading from stdin pipes For more information, see: https://www.cve.org/CVERecord?id=CVE-2024-10524 (* Security fix *) xap/xine-lib-1.2.13-x86_64-9.txz: Rebuilt. Apparently this needed to be recompiled against imagemagick-7.1.1_40 even though there wasn't a shared library .so-version bump. Thanks to Petri Kaukasoina.
144 lines
4.5 KiB
Bash
Executable file
144 lines
4.5 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009, 2012, 2017, 2018, 2019, 2022, 2023, 2024 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# Copyright 2011, 2012 Eric Hameleers, Eindhoven, NL
|
|
# Copyright 2017 Heinz Wiesinger, Amsterdam, NL
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=xine-lib
|
|
# Version on the tarball
|
|
VERSION=1.2.13
|
|
# Version used in the source directory to cd into
|
|
DIRVER=1.2.13
|
|
# Version used for the Slackware package
|
|
PKGVER=1.2.13
|
|
|
|
BUILD=${BUILD:-9}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
TARGET=${TARGET:-$ARCH-pc-linux-gnu}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
if [ "$ARCH" = "x86_64" ]; then
|
|
LIBDIRSUFFIX="64"
|
|
FFARCHOPTS="--arch=x86_64 --enable-pic"
|
|
elif [ "$ARCH" = "i686" ]; then
|
|
LIBDIRSUFFIX=""
|
|
# 32bit x86 fails without this... let me know if you have a fix
|
|
FFARCHOPTS="--disable-asm"
|
|
else
|
|
LIBDIRSUFFIX=""
|
|
FFARCHOPTS=""
|
|
fi
|
|
|
|
# If this package is being built for ALSA (no PulseAudio), use the _alsa $TAG:
|
|
if [ ! -r /usr/lib${LIBDIRSUFFIX}/pkgconfig/libpulse.pc ]; then
|
|
TAG="_alsa"
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$PKGVER-$ARCH-$BUILD$TAG.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-xine-lib
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG/usr
|
|
|
|
cd $TMP
|
|
rm -rf xine-lib-$DIRVER ; rm -rf xine-lib.$DIRVER
|
|
tar xvf $CWD/xine-lib-$VERSION.tar.xz || exit 1
|
|
cd xine-lib-$DIRVER || cd xine-lib.$DIRVER || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# Fix build with binutils 2.39:
|
|
sed '/xine_set_flags/s/XINE_PROTECTED//' -i include/xine.h
|
|
|
|
cat $CWD/xine-lib-1.2.13-ffmpeg6-compatibility.patch | patch -p1 --verbose || exit 1
|
|
cat $CWD/xine-lib-1.2.13-ffmpeg6-compatibility_2.patch | patch -p1 --verbose || exit 1
|
|
cat $CWD/xine-lib-1.2.13-ffmpeg7-compatibility.patch | patch -p1 --verbose || exit 1
|
|
cat $CWD/xine-lib-configure-c99.patch | patch -p1 --verbose || exit 1
|
|
|
|
autoreconf -vif || exit 1
|
|
|
|
XINE_BUILD=$TARGET \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--docdir=/usr/doc/xine-lib-$VERSION \
|
|
--mandir=/usr/man \
|
|
--with-w32-path=/usr/lib${LIBDIRSUFFIX}/codecs \
|
|
--with-wavpack \
|
|
--disable-nosefart \
|
|
--disable-vcd \
|
|
--without-speex \
|
|
--without-xcb \
|
|
--with-external-dvdnav || exit 1
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
# Remove .la files:
|
|
rm -f $PKG//usr/lib${LIBDIRSUFFIX}/*.la
|
|
|
|
mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/codecs
|
|
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" \
|
|
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
( cd $PKG/usr/man
|
|
find . -type f -exec gzip -9 {} \+
|
|
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
|
|
)
|
|
|
|
# Copy a few missed docs, and remove the redundant html FAQ (we have a txt)
|
|
cp -a \
|
|
ABOUT-NLS AUTHORS NEWS \
|
|
$PKG/usr/doc/xine-lib-$VERSION
|
|
rm -f $PKG/usr/doc/xine-lib-$VERSION/faq.html
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/xine-lib-$PKGVER-$ARCH-$BUILD$TAG.txz
|
|
|