slackware-current/source/x/xdg-utils/xdg-utils.SlackBuild
Patrick J Volkerding b1547e7faa Tue Feb 6 21:45:37 UTC 2024
a/kernel-firmware-20240203_b4b04a5-noarch-1.txz:  Upgraded.
ap/inxi-3.3.32_1-noarch-1.txz:  Upgraded.
d/ccache-4.9.1-x86_64-1.txz:  Upgraded.
d/cmake-3.28.3-x86_64-1.txz:  Upgraded.
l/jasper-4.2.0-x86_64-1.txz:  Upgraded.
x/libpciaccess-0.18-x86_64-1.txz:  Upgraded.
x/xdg-utils-1.2.1-noarch-1.txz:  Upgraded.
xfce/garcon-4.18.2-x86_64-1.txz:  Upgraded.
xfce/libxfce4ui-4.18.5-x86_64-1.txz:  Upgraded.
xfce/libxfce4util-4.18.2-x86_64-1.txz:  Upgraded.
2024-02-06 23:44:07 +01:00

98 lines
3.1 KiB
Bash
Executable file

#!/bin/bash
# Slackware build script for xdg-utils
# Written by Erik Hanson erik@slackbuilds.org
# Modified for VERSION version by Patrick Volkerding <volkerdi@slackware.com>
# Copyright 2008, 2009, 2010, 2013, 2018, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=xdg-utils
VERSION=1.2.1
PKG_VERSION=${VERSION/-/_}
ARCH=noarch
BUILD=${BUILD:-1}
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$PKG_VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP || exit 1
rm -rf $PKGNAM-$VERSION $PKGNAM-v$VERSION
tar xvf $CWD/$PKGNAM-v$VERSION.tar.?z || tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
cd $PKGNAM-v$VERSION || cd $PKGNAM-$VERSION || exit 1
# Fix xdg-open usage in LXDE:
zcat $CWD/xdg-open.no.relative.paths.diff.gz | patch -p1 --verbose || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
|| exit 1
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
gzip -9 $PKG/usr/man/man1/*
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a \
COPYING* LICENSE RE* TODO \
$PKG/usr/doc/$PKGNAM-$VERSION
# If there's a ChangeLog, installing at least part of the recent history
# is useful, but don't let it get totally out of control:
if [ -r ChangeLog ]; then
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
touch -r ChangeLog $DOCSDIR/ChangeLog
fi
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$PKG_VERSION-$ARCH-$BUILD.txz