mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
6e6f0c6efb
a/tcsh-6.24.14-x86_64-1.txz: Upgraded. ap/sudo-1.9.16p2-x86_64-1.txz: Upgraded. n/netatalk-4.0.7-x86_64-2.txz: Rebuilt. Fixed config file handling. Thanks to marav. n/openldap-2.6.9-x86_64-1.txz: Upgraded. t/texlive-2024.240409-x86_64-3.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/dejavu-fonts-ttf-2.37-noarch-7.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/font-bh-ttf-1.0.4-noarch-2.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/fontconfig-2.15.0-x86_64-1.txz: Upgraded. Thanks to Didier Spaier for the updated patches and meson build script! x/liberation-fonts-ttf-2.1.5-noarch-2.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/noto-cjk-fonts-ttf-2.001-noarch-4.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/ttf-indic-fonts-0.5.14-noarch-6.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/ttf-tlwg-0.7.3-noarch-2.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/wqy-zenhei-font-ttf-0.8.38_1-noarch-10.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. xap/xlockmore-5.81-x86_64-1.txz: Upgraded. testing/packages/mesa-24.3.0-x86_64-1.txz: Added.
147 lines
5 KiB
Bash
Executable file
147 lines
5 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009 Eric Hameleers, Eindhoven, NL
|
|
# Copyright 2008, 2009, 2017, 2018 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Permission to use, copy, modify, and distribute this software for
|
|
# any purpose with or without fee is hereby granted, provided that
|
|
# the above copyright notice and this permission notice appear in all
|
|
# copies.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
|
|
# IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
|
|
# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
|
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
|
|
# USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
|
|
# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
|
|
# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
|
|
# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
|
|
# SUCH DAMAGE.
|
|
# -----------------------------------------------------------------------------
|
|
#
|
|
# Slackware SlackBuild script
|
|
# ===========================
|
|
# By: Eric Hameleers <alien@slackware.com>
|
|
# For: wqy-zenhei-font-ttf
|
|
# Descr: Wen Quan Yi Zen Hei CJK Font
|
|
# URL: http://wqy.sourceforge.net/en/
|
|
#
|
|
# -----------------------------------------------------------------------------
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=wqy-zenhei-font-ttf
|
|
SRCNAM=wqy-zenhei
|
|
VERSION=${VERSION:-0.8.38}
|
|
SUB=${SUB:-1}
|
|
ARCH=noarch
|
|
BUILD=${BUILD:-10}
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-${VERSION}_${SUB}-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-$PKGNAM
|
|
|
|
SOURCE="$CWD/${SRCNAM}-${VERSION}-${SUB}.tar.lz"
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
# Font directory location depends on the X build prefix:
|
|
# Determine what X we're running (the modular X returns the prefix
|
|
# in the next command, while older versions stay silent):
|
|
XPREF=$(pkg-config --variable=prefix x11)
|
|
if [ "$XPREF" = "" ]; then
|
|
XPREF='/usr/X11R6'
|
|
FONTDIR="$XPREF/lib/X11/fonts/TTF"
|
|
else
|
|
FONTDIR="/usr/share/fonts/TTF"
|
|
fi
|
|
mkdir -p $PKG$FONTDIR
|
|
|
|
cd $TMP
|
|
rm -rf ${PKGNAM}-${VERSION}
|
|
tar -xvf ${SOURCE} || exit 1
|
|
mv ${SRCNAM} ${PKGNAM}-${VERSION} || exit 1
|
|
cd ${PKGNAM}-${VERSION}
|
|
|
|
zcat $CWD/fixup-fontconfig-file.diff.gz | patch -p1 || exit 1
|
|
zcat $CWD/wqy-zenhei.fix.fontconfig.warning.diff.gz | patch -p1 || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# The following causes an error since the package no longer contains any ttf
|
|
# fonts, but it is harmless. It's probably safer to leave the cp command the
|
|
# way it is in case future versions include any ttf fonts.
|
|
# Install font:
|
|
cp -a *.ttf *.ttc $PKG$FONTDIR/ 2> /dev/null
|
|
chmod 644 $PKG$FONTDIR/*
|
|
chown root:root $PKG$FONTDIR/*
|
|
|
|
# Add the fontconfig file and symlink.
|
|
mkdir -p $PKG/etc/fonts/conf.d $PKG/usr/share/fontconfig/conf.avail
|
|
zcat $CWD/64-wqy-zenhei.conf.gz > $PKG/usr/share/fontconfig/conf.avail/64-wqy-zenhei.conf
|
|
( cd $PKG/etc/fonts/conf.d && \
|
|
ln -sf ../../../usr/share/fontconfig/conf.avail/64-wqy-zenhei.conf .
|
|
)
|
|
|
|
# We install the upstream fontconfig files, but do not activate them with
|
|
# symlinks.
|
|
cp -a \
|
|
44-wqy-zenhei.conf 66-wqy-zenhei-sharp.conf 66-wqy-zenhei-sharp-no13px.conf \
|
|
$PKG/etc/fonts/conf.avail/
|
|
chmod 644 $PKG/etc/fonts/conf.avail/*
|
|
chown root:root $PKG/etc/fonts/conf.avail/*
|
|
# Rename this one to avoid confusion:
|
|
mv $PKG/etc/fonts/conf.avail/44-wqy-zenhei.conf $PKG/etc/fonts/conf.avail/44-wqy-zenhei-upstream-orig.conf
|
|
|
|
# Add a shell script that can set the Zen Hei default display styles:
|
|
mkdir -p $PKG/usr/sbin
|
|
install -m755 zenheiset $PKG/usr/sbin/zenheiset
|
|
|
|
# Post-install script:
|
|
mkdir -p $PKG/install
|
|
cat << EOT > $PKG/install/doinst.sh
|
|
# There's no need to chroot and do this during initial
|
|
# install, since there is a post-install script that
|
|
# does the same thing, saving time.
|
|
# Update X font indexes and the font cache:
|
|
if [ -x /usr/bin/mkfontdir ]; then
|
|
/usr/bin/mkfontscale $FONTDIR 2> /dev/null
|
|
/usr/bin/mkfontdir $FONTDIR 2> /dev/null
|
|
fi
|
|
if [ -x /usr/bin/fc-cache ]; then
|
|
/usr/bin/fc-cache $FONTDIR 2> /dev/null
|
|
fi
|
|
EOT
|
|
|
|
# Add documentation:
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
|
|
cp -a \
|
|
AUTHORS COPYING ChangeLog INSTALL README \
|
|
$PKG/usr/doc/$PKGNAM-$VERSION
|
|
find $PKG/usr/doc -type f -exec chmod 644 {} \+
|
|
|
|
# Add a package description:
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
# Build the package:
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/${PKGNAM}-${VERSION}_${SUB}-${ARCH}-${BUILD}.txz
|
|
|