slackware-current/source/x/ttf-indic-fonts/ttf-indic-fonts.SlackBuild
Patrick J Volkerding 6e6f0c6efb Thu Nov 28 00:18:02 UTC 2024
a/tcsh-6.24.14-x86_64-1.txz:  Upgraded.
ap/sudo-1.9.16p2-x86_64-1.txz:  Upgraded.
n/netatalk-4.0.7-x86_64-2.txz:  Rebuilt.
  Fixed config file handling. Thanks to marav.
n/openldap-2.6.9-x86_64-1.txz:  Upgraded.
t/texlive-2024.240409-x86_64-3.txz:  Rebuilt.
  Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail.
x/dejavu-fonts-ttf-2.37-noarch-7.txz:  Rebuilt.
  Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail.
x/font-bh-ttf-1.0.4-noarch-2.txz:  Rebuilt.
  Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail.
x/fontconfig-2.15.0-x86_64-1.txz:  Upgraded.
  Thanks to Didier Spaier for the updated patches and meson build script!
x/liberation-fonts-ttf-2.1.5-noarch-2.txz:  Rebuilt.
  Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail.
x/noto-cjk-fonts-ttf-2.001-noarch-4.txz:  Rebuilt.
  Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail.
x/ttf-indic-fonts-0.5.14-noarch-6.txz:  Rebuilt.
  Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail.
x/ttf-tlwg-0.7.3-noarch-2.txz:  Rebuilt.
  Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail.
x/wqy-zenhei-font-ttf-0.8.38_1-noarch-10.txz:  Rebuilt.
  Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail.
xap/xlockmore-5.81-x86_64-1.txz:  Upgraded.
testing/packages/mesa-24.3.0-x86_64-1.txz:  Added.
2024-11-28 02:04:23 +01:00

94 lines
3.2 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2008, 2009, 2013 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=ttf-indic-fonts
VERSION=0.5.14
ARCH=noarch
BUILD=${BUILD:-6}
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-ttf-indic-fonts
rm -rf $PKG
mkdir -p $PKG
cd $TMP
rm -rf ttf-indic-fonts-$VERSION
tar xvf $CWD/ttf-indic-fonts_$VERSION.tar.xz || exit 1
cd ttf-indic-fonts-$VERSION || exit 1
# I'm very interested in making this a better package, but have a
# long way to go in understanding how all of this works. I know
# that at least some of the Wikipedia articles I read are filled
# in better now, but...
#
# For example, the hints files in the debian directory (where most
# of these fonts were found) -- what do they do? And where do they
# go? Also, some of the nicer looking fonts do not seem to be the
# defaults (perhaps also due to the lack of "hints").
#
# Hopefully this will at least provide a useful start for now.
#
# Have fun :-)
#
# -- Pat <volkerdi@slackware.com>
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
mkdir -p $PKG/usr/share/fonts/TTF/
cp -a */*.ttf $PKG/usr/share/fonts/TTF
mkdir -p $PKG/usr/share/fontconfig/conf.avail
find . -name "*.conf" -exec cp -a {} $PKG/usr/share/fontconfig/conf.avail \;
mkdir -p $PKG/etc/fonts/conf.d
( cd $PKG/etc/fonts/conf.d
for file in ../../../usr/share/fontconfig/conf.avail/*.conf ; do
ln -sf $file .
done
)
# Put copyright notices in the docs directory:
mkdir -p $PKG/usr/doc/ttf-indic-fonts-$VERSION
find . -name "*.copyright" -exec cp -a {} $PKG/usr/doc/ttf-indic-fonts-$VERSION \;
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n --prepend $TMP/ttf-indic-fonts-$VERSION-$ARCH-$BUILD.txz