slackware-current/source/x/noto-fonts-ttf/noto-fonts-ttf.SlackBuild
Patrick J Volkerding f0cab128f9 Mon Dec 23 23:43:54 UTC 2024
l/imagemagick-7.1.1_43-x86_64-1.txz:  Upgraded.
x/dejavu-fonts-ttf-2.37-noarch-8.txz:  Rebuilt.
  Added some optional fontconfig files to symlink into /etc/fonts/conf.d if you
  would like to make the DejaVu fonts preferred for their font families:
  58-dejavu-sans-mono-default-monospace.conf,
  59-dejavu-sans-default-sans.conf,
  and 59-dejavu-serif-default-serif.conf.
x/noto-fonts-ttf-2024.12.01-noarch-2.txz:  Rebuilt.
  Added some optional fontconfig files to symlink into /etc/fonts/conf.d if you
  would like to make the Noto fonts preferred for their font families:
  58-noto-mono-default-monospace.conf,
  59-noto-sans-default-sans.conf.
  and 59-noto-serif-default-serif.conf,
y/gnugo-3.8-x86_64-1.txz:  Added.
  Added the GNU Go game engine. Thanks to alienBOB.
2024-12-24 01:04:05 +01:00

69 lines
2.5 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2015, 2018, 2020 Eric Hameleers, Eindhoven, NL
# Copyright 2015, 2018, 2020, 2024 Patrick J. Volkerding, Sebeka, MN USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=noto-fonts-ttf
VERSION=${VERSION:-$(echo noto-fonts-subset-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-2}
ARCH=noarch
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
rm -rf $PKG
mkdir -p $TMP $PKG
# Install the fonts/docs:
( cd $PKG
tar xf $CWD/noto-fonts-subset-${VERSION}.tar.lz
chmod 755 .
mkdir -p usr/share/fonts/TTF
mv fonts/* usr/share/fonts/TTF
rmdir fonts
mkdir -p usr/doc/${PKGNAM}-${VERSION}
mv docs/* usr/doc/${PKGNAM}-${VERSION}
rmdir docs
chown root:root usr/doc/${PKGNAM}-${VERSION}/*
chmod 644 usr/doc/${PKGNAM}-${VERSION}/*
# Install the fontconfig files:
mkdir -p usr/share/fontconfig/conf.avail
cp -a $CWD/conf.avail/* usr/share/fontconfig/conf.avail
chown root:root usr/share/fontconfig/conf.avail/*
chmod 644 usr/share/fontconfig/conf.avail/*
)
mkdir -p $PKG/install
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz