mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
6e6f0c6efb
a/tcsh-6.24.14-x86_64-1.txz: Upgraded. ap/sudo-1.9.16p2-x86_64-1.txz: Upgraded. n/netatalk-4.0.7-x86_64-2.txz: Rebuilt. Fixed config file handling. Thanks to marav. n/openldap-2.6.9-x86_64-1.txz: Upgraded. t/texlive-2024.240409-x86_64-3.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/dejavu-fonts-ttf-2.37-noarch-7.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/font-bh-ttf-1.0.4-noarch-2.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/fontconfig-2.15.0-x86_64-1.txz: Upgraded. Thanks to Didier Spaier for the updated patches and meson build script! x/liberation-fonts-ttf-2.1.5-noarch-2.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/noto-cjk-fonts-ttf-2.001-noarch-4.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/ttf-indic-fonts-0.5.14-noarch-6.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/ttf-tlwg-0.7.3-noarch-2.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. x/wqy-zenhei-font-ttf-0.8.38_1-noarch-10.txz: Rebuilt. Move files from /etc/fonts/conf.avail to /usr/share/fontconfig/fonts.avail. xap/xlockmore-5.81-x86_64-1.txz: Upgraded. testing/packages/mesa-24.3.0-x86_64-1.txz: Added.
75 lines
2.6 KiB
Bash
Executable file
75 lines
2.6 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009, 2010, 2011, 2012, 2018, 2020 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=liberation-fonts-ttf
|
|
VERSION=2.1.5
|
|
ARCH=noarch
|
|
BUILD=${BUILD:-2}
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-liberation-fonts-ttf
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf liberation-fonts-ttf-$VERSION
|
|
tar xvf $CWD/liberation-fonts-ttf-${VERSION}.tar.* || exit 1
|
|
cd liberation-fonts-ttf-${VERSION} || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
mkdir -p $PKG/usr/share/fonts/TTF/
|
|
cp -a *.ttf $PKG/usr/share/fonts/TTF/
|
|
|
|
mkdir -p $PKG/usr/doc/liberation-fonts-ttf-$VERSION
|
|
cp -a \
|
|
$CWD/docs/* \
|
|
$PKG/usr/doc/liberation-fonts-ttf-$VERSION
|
|
|
|
mkdir -p $PKG/etc/fonts/conf.d $PKG/usr/share/fontconfig/conf.avail
|
|
cat $CWD/60-liberation.conf > $PKG/usr/share/fontconfig/conf.avail/60-liberation.conf
|
|
( cd $PKG/etc/fonts/conf.d && \
|
|
ln -sf ../../../usr/share/fontconfig/conf.avail/60-liberation.conf .
|
|
)
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/liberation-fonts-ttf-${VERSION}-$ARCH-$BUILD.txz
|
|
|