slackware-current/source/x/labwc/labwc.SlackBuild
Patrick J Volkerding da38cfca02 Wed Dec 18 00:32:07 UTC 2024
Thanks to UrbanDesimator for the help getting Xfce Wayland-ready! :-)
a/mkinitrd-1.4.11-x86_64-58.txz:  Rebuilt.
  remove-orphaned-initrds: reject unsupported command line options.
  Thanks to Mechanikx.
a/ndctl-80-x86_64-1.txz:  Upgraded.
  Added option -Dlibtracefs=enabled, compiled against libtracefs-1.8.1.
d/llvm-19.1.6-x86_64-1.txz:  Upgraded.
d/meson-1.6.1-x86_64-1.txz:  Upgraded.
l/libclc-19.1.6-x86_64-1.txz:  Upgraded.
l/libtraceevent-1.8.4-x86_64-1.txz:  Added.
  Needed by libtracefs-1.8.1.
l/libtracefs-1.8.1-x86_64-1.txz:  Added.
  Needed by ndctl-80.
l/qtkeychain-0.14.3-x86_64-3.txz:  Rebuilt.
  Fix 32-bit $ARCH.
l/seatd-0.9.1-x86_64-1.txz:  Added.
  Needed by wlroots-0.18.2.
n/ipset-7.23-x86_64-1.txz:  Upgraded.
x/labwc-0.8.2-x86_64-1.txz:  Added.
  A Wayland compositor that works with Xfce.
x/libsfdo-0.1.3-x86_64-1.txz:  Added.
  Needed by labwc-0.8.2.
x/wlroots-0.18.2-x86_64-1.txz:  Added.
  Needed by labwc-0.8.2.
xfce/Greybird-3.23.3-noarch-2.txz:  Rebuilt.
  [PATCH] Fix label styles for xfdesktop 4.19 (#338)
  Fixes Icon-label color not transparent when other window is focused.
  Thanks to Robby Workman.
xfce/exo-4.20.0-x86_64-2.txz:  Rebuilt.
  Added options --enable-x11 --enable-wayland.
xfce/libxfce4ui-4.20.0-x86_64-2.txz:  Rebuilt.
  Added options --enable-x11 --enable-wayland.
xfce/xfce4-clipman-plugin-1.6.6-x86_64-2.txz:  Rebuilt.
  Added options --enable-x11 --enable-wayland.
xfce/xfce4-notifyd-0.9.6-x86_64-2.txz:  Rebuilt.
  Added options --enable-x11 --enable-wayland.
  Recompiled against gtk-layer-shell-0.9.0.
xfce/xfce4-panel-4.20.0-x86_64-2.txz:  Rebuilt.
  Added options --enable-x11 --enable-wayland.
  Recompiled against gtk-layer-shell-0.9.0.
xfce/xfce4-power-manager-4.20.0-x86_64-2.txz:  Rebuilt.
  Added options --enable-x11 --enable-wayland.
xfce/xfce4-screenshooter-1.11.1-x86_64-2.txz:  Rebuilt.
  Added options --enable-x11 --enable-wayland.
xfce/xfce4-session-4.20.0-x86_64-2.txz:  Rebuilt.
  Added options --enable-x11 --enable-wayland.
  Recompiled against gtk-layer-shell-0.9.0.
xfce/xfce4-settings-4.20.0-x86_64-2.txz:  Rebuilt.
  Added options --enable-x11 --enable-wayland.
  Recompiled against gtk-layer-shell-0.9.0.
xfce/xfce4-terminal-1.1.3-x86_64-2.txz:  Rebuilt.
  Added options --enable-x11 --enable-wayland.
  Recompiled against gtk-layer-shell-0.9.0.
xfce/xfce4-whiskermenu-plugin-2.8.3-x86_64-2.txz:  Rebuilt.
  Added options --enable-x11 --enable-wayland.
  Recompiled against gtk-layer-shell-0.9.0.
xfce/xfdesktop-4.20.0-x86_64-2.txz:  Rebuilt.
  Added options --enable-x11 --enable-wayland.
  Recompiled against gtk-layer-shell-0.9.0.
2024-12-18 02:07:06 +01:00

121 lines
3.7 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2024 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=labwc
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
i?86) ARCH=i686 ;;
arm*) readelf /usr/bin/file -A | egrep -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$(uname -m) ;;
esac
export ARCH
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j $(expr $(nproc) + 1) "}
if [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf $PKGNAM-$VERSION
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
cd $PKGNAM-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
# Configure, build, and install:
export CFLAGS="$SLKCFLAGS"
export CXXFLAGS="$SLKCFLAGS"
mkdir meson-build
cd meson-build
meson setup \
--prefix=/usr \
--libdir=lib${LIBDIRSUFFIX} \
--libexecdir=/usr/libexec \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
--includedir=/usr/include \
--datadir=/usr/share \
--mandir=/usr/man \
--sysconfdir=/etc \
--localstatedir=/var \
--buildtype=release \
.. || exit 1
"${NINJA:=ninja}" $NUMJOBS || exit 1
DESTDIR=$PKG $NINJA install || exit 1
cd ..
# Strip binaries:
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Compress manual pages:
find $PKG/usr/man -type f -exec gzip -9 {} \+
for i in $( find $PKG/usr/man -type l ) ; do
ln -s $( readlink $i ).gz $i.gz
rm $i
done
# Add a documentation directory:
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
cp -a \
CONTRIBUTING* LICENSE* NEWS* README* \
$PKG/usr/doc/${PKGNAM}-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz