mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
cb18a69a27
a/mkinitrd-1.4.11-x86_64-60.txz: Rebuilt. init: support having the cryptkey.bin keyfile in the initrd itself. Thanks to kursu. I took this as the simplest patch, written in the closest to the existing style. Honorable mention to Didier Spaier, opty, and RyNo (this actually might be based on RyNo's patch) for providing alternative approaches for consideration. a/pkgtools-15.1-noarch-23.txz: Rebuilt. Clean up after --dry-run better (although this matters less now that we'll be mounting a tmpfs on /var/lib/pkgtools/setup/tmp). Thanks to Mechanikx. While we're here, change tabs to spaces (only found in installpkg). a/sysvinit-3.12-x86_64-1.txz: Upgraded. a/sysvinit-scripts-15.1-noarch-24.txz: Rebuilt. rc.M: mount a tmpfs on /var/lib/pkgtools/setup/tmp. ap/man-db-2.13.0-x86_64-3.txz: Rebuilt. man-db.{csh,sh}: export MANROFFOPT=-c to fix colors with most pager. Thanks to eduardr. l/imagemagick-7.1.1_42-x86_64-1.txz: Upgraded. l/libvncserver-0.9.15-x86_64-1.txz: Upgraded. l/python-Jinja2-3.1.5-x86_64-1.txz: Upgraded. l/python-urllib3-2.3.0-x86_64-1.txz: Upgraded. x/fontconfig-2.15.0-x86_64-4.txz: Rebuilt. 60-latin.conf: Make Liberation Serif, Liberation Sans, and Liberation Mono the preferred fonts, as they were in Slackware 15.0. x/hack-fonts-ttf-3.003-noarch-4.txz: Rebuilt. I like the Hack font, but I'm not sure that it's the best default for an all- purpose monospace system font. So what we'll do is add a new file in conf.avail called 58-hack-default-monospace.conf that if symlinked into /etc/fonts/conf.d/ will make Hack the default monospace font. I'm considering adding similar override .conf files for DejaVu and Noto.
168 lines
5.9 KiB
Bash
Executable file
168 lines
5.9 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2024 Patrick J. Volkerding, Sebeka, Minnesota, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=fontconfig
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-4}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$(uname -m)" in
|
|
i?86) ARCH=i686 ;;
|
|
arm*) readelf /usr/bin/file -A | egrep -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) ARCH=$(uname -m) ;;
|
|
esac
|
|
export ARCH
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j $(expr $(nproc) + 1) "}
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-$PKGNAM
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
cd $TMP
|
|
rm -rf $PKGNAM-$VERSION
|
|
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
|
|
cd $PKGNAM-$VERSION || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# Patches from Fedora and Debian:
|
|
cat $CWD/patches/02_indic_names.patch | patch -p1 --verbose || exit 1
|
|
cat $CWD/patches/04_mgopen_fonts.patch | patch -p1 --verbose || exit 1
|
|
cat $CWD/patches/disable-crbug1004354.patch | patch -p1 --verbose || exit 1
|
|
cat $CWD/patches/fontconfig-sleep-less.patch | patch -p1 --verbose || exit 1
|
|
cat $CWD/patches/fontconfig-remove-uuid.patch | patch -p1 --verbose || exit 1
|
|
cat $CWD/patches/fontconfig-drop-lang-from-pkgkit-format.patch | patch -p1 --verbose || exit 1
|
|
cat $CWD/patches/fontconfig-fix-SAST.patch | patch -p1 --verbose || exit 1
|
|
|
|
# Hardcode the default font search path rather than having fontconfig figure
|
|
# it out (and possibly follow symlinks, or index ugly bitmapped fonts):
|
|
cat $CWD/fontconfig.font.dir.list.diff | patch -p1 --verbose || exit 1
|
|
|
|
# Some "no bitmap" conf files from Fedora. We'll include them but won't be
|
|
# enabling them.
|
|
cat $CWD/fontconfig.70.no.bitmaps.conf.diff | patch -p1 --verbose || exit 1
|
|
|
|
# Prefer Liberation for sans, serif, and monospace, as we have for many years:
|
|
cat $CWD/fontconfig.liberation.diff | patch -p1 --verbose || exit 1
|
|
|
|
export CFLAGS="$SLKCFLAGS"
|
|
export CXXFLAGS="$SLKCFLAGS"
|
|
mkdir meson-build
|
|
cd meson-build
|
|
meson setup \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--mandir=/usr/man \
|
|
--datadir=/usr/share \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--buildtype=release \
|
|
-D cache-build=disabled \
|
|
-D default-hinting=medium \
|
|
-D default-sub-pixel-rendering=none \
|
|
-D doc-html=disabled \
|
|
-D doc-pdf=disabled \
|
|
-D doc-txt=disabled \
|
|
.. || exit 1
|
|
"${NINJA:=ninja}" $NUMJOBS || exit 1
|
|
DESTDIR=$PKG $NINJA install || exit 1
|
|
cd ..
|
|
|
|
# Strip binaries:
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
mkdir -p $PKG/var/log/setup
|
|
cat $CWD/setup.05.fontconfig > $PKG/var/log/setup/setup.05.fontconfig
|
|
chmod 755 $PKG/var/log/setup/setup.05.fontconfig
|
|
|
|
# Compress manual pages:
|
|
find $PKG/usr/man -type f -exec gzip -9 {} \+
|
|
for i in $( find $PKG/usr/man -type l ) ; do
|
|
ln -s $( readlink $i ).gz $i.gz
|
|
rm $i
|
|
done
|
|
|
|
# Not convinced.
|
|
#( cd $PKG/etc/fonts/conf.d ; ln -sf ../../../usr/share/fontconfig/conf.avail/70-no-bitmaps-except-emoji.conf . )
|
|
|
|
# We did not previously link a hinting, subpixel, or lcdfilter conf file.
|
|
# Let's not do that here, either. Let the user choose to link that themselves
|
|
# without every fontconfig update stomping on it:
|
|
rm -f $PKG/etc/fonts/conf.d/10-hinting-*
|
|
rm -f $PKG/etc/fonts/conf.d/10-sub-pixel-*
|
|
rm -f $PKG/etc/fonts/conf.d/11-lcdfilter-*
|
|
|
|
# You can shop for this kind of stuff in the source tarball.
|
|
rm -rf $PKG/usr/share/doc
|
|
|
|
# Add a documentation directory:
|
|
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
|
|
cp -a \
|
|
ABOUT-NLS* AUTHORS* COPYING* ChangeLog INSTALL* NEWS* README* \
|
|
$PKG/usr/doc/${PKGNAM}-$VERSION
|
|
|
|
# If there's a ChangeLog, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r ChangeLog ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
|
|
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
|
|
touch -r ChangeLog $DOCSDIR/ChangeLog
|
|
fi
|
|
|
|
mkdir -p $PKG/install
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
|