mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
388220eab9
a/ed-1.20.2-x86_64-1.txz: Upgraded. d/parallel-20240422-noarch-1.txz: Upgraded. kde/krusader-2.8.1-x86_64-1.txz: Upgraded. kde/ktextaddons-1.5.4-x86_64-1.txz: Upgraded. l/libgusb-0.4.9-x86_64-1.txz: Upgraded. n/nmap-7.95-x86_64-1.txz: Upgraded. x/fcitx5-5.1.9-x86_64-1.txz: Upgraded. x/fcitx5-anthy-5.1.4-x86_64-1.txz: Upgraded. x/fcitx5-chinese-addons-5.1.5-x86_64-1.txz: Upgraded. x/fcitx5-gtk-5.1.3-x86_64-1.txz: Upgraded. x/fcitx5-hangul-5.1.3-x86_64-1.txz: Upgraded. x/fcitx5-kkc-5.1.3-x86_64-1.txz: Upgraded. x/fcitx5-m17n-5.1.1-x86_64-1.txz: Upgraded. x/fcitx5-qt-5.1.6-x86_64-1.txz: Upgraded. x/fcitx5-sayura-5.1.2-x86_64-1.txz: Upgraded. x/fcitx5-table-extra-5.1.5-x86_64-1.txz: Upgraded. x/fcitx5-table-other-5.1.2-x86_64-1.txz: Upgraded. x/fcitx5-unikey-5.1.4-x86_64-1.txz: Upgraded. x/libime-1.1.7-x86_64-1.txz: Upgraded. extra/emacs-regular-build/emacs-29.3-x86_64-2_regular.txz: Rebuilt. This is a bugfix release. Only build the X11/GTK+3 version. Use "emacs -nw" if you want to start it in a terminal emulator in text mode, or rebuild if you really need to get rid of the X11 dependency for some reason. Build using --with-pdumper=auto. It seems that --with-dumping=unexec produces a buggy Emacs here in the modern era, with symptoms such as "child signal FD: Invalid argument". It's possible this had something to do with the reported memory leaks as well. Thanks to 3Tom for the bug report.
106 lines
3.3 KiB
Bash
Executable file
106 lines
3.3 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2016 Heinz Wiesinger, Amsterdam, The Netherlands
|
|
# Copyright 2016, 2020, 2024 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=fcitx5-sayura
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.zst | rev | cut -f 3- -d . | cut -f 1 -d- | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
MARCH=$( uname -m )
|
|
if [ -z "$ARCH" ]; then
|
|
case "$MARCH" in
|
|
i?86) export ARCH=i586 ;;
|
|
armv7hl) export ARCH=$MARCH ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$MARCH ;;
|
|
esac
|
|
fi
|
|
|
|
if [ "$ARCH" = "i586" ]; then
|
|
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "s390" ]; then
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
elif [ "$ARCH" = "armv7hl" ]; then
|
|
SLKCFLAGS="-O2 -march=armv7-a -mfpu=vfpv3-d16"
|
|
LIBDIRSUFFIX=""
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-fcitx5-sayura
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf fcitx5-sayura-$VERSION
|
|
tar xvf $CWD/fcitx5-sayura-$VERSION.tar.zst || exit 1
|
|
cd fcitx5-sayura-$VERSION || exit 1
|
|
chown -R root:root .
|
|
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
mkdir build
|
|
cd build
|
|
cmake \
|
|
-DCMAKE_CXX_FLAGS="${SLKCFLAGS}" \
|
|
-DCMAKE_C_FLAGS="${SLKCFLAGS}" \
|
|
-DCMAKE_INSTALL_PREFIX="/usr" \
|
|
-DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX} \
|
|
..
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make install/strip DESTDIR=$PKG || exit 1
|
|
cd ..
|
|
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
|
|
cp -a LICENSES/* README* $PKG/usr/doc/$PKGNAM-$VERSION
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
|