slackware-current/source/x/fcitx5-qt/fcitx5-qt.SlackBuild
Patrick J Volkerding 767006b5b5 Fri Oct 18 22:51:09 UTC 2024
a/elilo-3.16-x86_64-17.txz:  Rebuilt.
  eliloconfig: adapt to new naming and lack of huge kernel. Thanks to gildbg.
ap/cups-browsed-2.1.0-x86_64-1.txz:  Upgraded.
  Removed support for legacy CUPS browsing and for LDAP
  Legacy CUPS browsing is not needed any more and, our implementation
  accepting any UDP packet on port 631, causes vulnerabilities, and
  our LDAP support is does not comly with RFC 7612 and is therefore
  limited. Fixes CVE-2024-47176 and CVE-2024-47850
  Default `BrowseRemoteProtocols` should not include `cups` protocol
  Works around CVE-2024-47176, the fix is the complete removal of
  legacy CUPS Browsing functionality.
  For more information, see:
    https://www.cve.org/CVERecord?id=CVE-2024-47176
    https://www.cve.org/CVERecord?id=CVE-2024-47850
  (* Security fix *)
l/dav1d-1.5.0-x86_64-1.txz:  Upgraded.
l/gvfs-1.56.1-x86_64-1.txz:  Upgraded.
l/libcupsfilters-2.1.0-x86_64-1.txz:  Upgraded.
  `cfGetPrinterAttributes5()`: Validate response attributes before return
  The IPP print destination which we are querying can be corrupted or
  forged, so validate the response to strenghten security. Fixes
  CVE-2024-47076.
  For more information, see:
    https://www.cve.org/CVERecord?id=CVE-2024-47076
  (* Security fix *)
l/libppd-2.1.0-x86_64-1.txz:  Upgraded.
  Prevent PPD generation based on invalid IPP response
  Overtaken from CUPS 2.x: Validate IPP attributes in PPD generator,
  refactor make-and-model code, PPDize preset and template names,
  quote PPD localized strings. Fixes CVE-2024-47175.
  For more information, see:
    https://www.cve.org/CVERecord?id=CVE-2024-47175
  (* Security fix *)
l/python-MarkupSafe-3.0.2-x86_64-1.txz:  Upgraded.
l/python-psutil-6.1.0-x86_64-1.txz:  Upgraded.
x/fcitx5-qt-5.1.8-x86_64-1.txz:  Upgraded.
2024-10-19 01:29:44 +02:00

100 lines
3.1 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2016 Heinz Wiesinger, Amsterdam, The Netherlands
# Copyright 2016, 2020, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=fcitx5-qt
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.zst | rev | cut -f 3- -d . | cut -f 1 -d- | rev)}
BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
# Automatically determine the architecture we're building on:
MARCH=$( uname -m )
if [ -z "$ARCH" ]; then
case "$MARCH" in
i?86) export ARCH=i686 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$MARCH ;;
esac
fi
if [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-fcitx5-qt
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf fcitx5-qt-$VERSION
tar xvf $CWD/fcitx5-qt-$VERSION.tar.zst || exit 1
cd fcitx5-qt-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
mkdir build
cd build
cmake \
-DCMAKE_CXX_FLAGS="${SLKCFLAGS}" \
-DCMAKE_C_FLAGS="${SLKCFLAGS}" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX} \
-DENABLE_QT4="Off" \
..
make $NUMJOBS || make || exit 1
make install/strip DESTDIR=$PKG || exit 1
cd ..
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a LICENSES/* README* $PKG/usr/doc/$PKGNAM-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz