mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
194d2d2fc5
a/dracut-104-x86_64-1.txz: Upgraded. d/cmake-3.30.5-x86_64-1.txz: Upgraded. d/subversion-1.14.4-x86_64-1.txz: Upgraded. l/mozjs128-128.3.1esr-x86_64-1.txz: Upgraded. l/openexr-3.3.1-x86_64-1.txz: Upgraded. l/python-charset-normalizer-3.4.0-x86_64-1.txz: Upgraded. x/fcitx5-5.1.11-x86_64-1.txz: Upgraded. x/fcitx5-anthy-5.1.5-x86_64-1.txz: Upgraded. x/fcitx5-chinese-addons-5.1.7-x86_64-1.txz: Upgraded. x/fcitx5-hangul-5.1.5-x86_64-1.txz: Upgraded. x/fcitx5-kkc-5.1.5-x86_64-1.txz: Upgraded. x/fcitx5-m17n-5.1.2-x86_64-1.txz: Upgraded. x/fcitx5-qt-5.1.7-x86_64-1.txz: Upgraded. x/fcitx5-unikey-5.1.5-x86_64-1.txz: Upgraded. x/libime-1.1.9-x86_64-1.txz: Upgraded. xap/mozilla-firefox-128.3.1esr-x86_64-1.txz: Upgraded. This update contains a critical security fix: Use-after-free in Animation timeline. "An attacker was able to achieve code execution in the content process by exploiting a use-after-free in Animation timelines. We have had reports of this vulnerability being exploited in the wild." For more information, see: https://www.mozilla.org/en-US/firefox/128.3.1/releasenotes/ https://www.mozilla.org/security/advisories/mfsa2024-51/ https://www.cve.org/CVERecord?id=CVE-2024-9680 (* Security fix *)
99 lines
3.1 KiB
Bash
Executable file
99 lines
3.1 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2016 Heinz Wiesinger, Amsterdam, The Netherlands
|
|
# Copyright 2016, 2020, 2024 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=fcitx5-m17n
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.zst | rev | cut -f 3- -d . | cut -f 1 -d- | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
MARCH=$( uname -m )
|
|
if [ -z "$ARCH" ]; then
|
|
case "$MARCH" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$MARCH ;;
|
|
esac
|
|
fi
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-fcitx5-m17n
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf fcitx5-m17n-$VERSION
|
|
tar xvf $CWD/fcitx5-m17n-$VERSION.tar.zst || exit 1
|
|
cd fcitx5-m17n-$VERSION || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
mkdir build
|
|
cd build
|
|
cmake \
|
|
-DCMAKE_CXX_FLAGS="${SLKCFLAGS}" \
|
|
-DCMAKE_C_FLAGS="${SLKCFLAGS}" \
|
|
-DCMAKE_INSTALL_PREFIX="/usr" \
|
|
-DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX} \
|
|
..
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make install/strip DESTDIR=$PKG || exit 1
|
|
cd ..
|
|
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
|
|
cp -a LICENSES/* README* $PKG/usr/doc/$PKGNAM-$VERSION
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
|