mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
3e4363cb32
ap/moc-2.6_alpha3-x86_64-4.txz: Rebuilt. The ffmpeg7 patch isn't 100% there, so rebuild without the ffmpeg plugin. ap/sqlite-3.46.1-x86_64-1.txz: Upgraded. kde/digikam-8.4.0-x86_64-2.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. kde/ffmpegthumbs-23.08.5-x86_64-2.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. kde/k3b-23.08.5-x86_64-2.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. kde/kfilemetadata-5.116.0-x86_64-6.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. kde/kpipewire-5.27.11-x86_64-2.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. l/alsa-plugins-1.2.12-x86_64-2.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. l/ffmpeg-7.0.2-x86_64-1.txz: Upgraded. Shared library .so-version bump. Compiled against vulkan-sdk-1.3.290.0. l/freetype-2.13.3-x86_64-1.txz: Upgraded. l/gegl-0.4.48-x86_64-2.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. l/gst-plugins-bad-free-1.24.6-x86_64-2.txz: Rebuilt. Recompiled against vulkan-sdk-1.3.290.0. l/gst-plugins-libav-1.24.6-x86_64-2.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. l/gtk4-4.14.4-x86_64-2.txz: Rebuilt. Recompiled against vulkan-sdk-1.3.290.0. l/libplacebo-7.349.0-x86_64-2.txz: Rebuilt. Recompiled against vulkan-sdk-1.3.290.0. l/mlt-7.24.0-x86_64-3.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. l/opencv-4.10.0-x86_64-2.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. l/pipewire-1.2.2-x86_64-2.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. Recompiled against vulkan-sdk-1.3.290.0. l/qt5-5.15.14_20240716_ae0c8451-x86_64-2.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. l/qt6-6.7.2_20240610_3f005f1e-x86_64-5.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. l/spirv-llvm-translator-18.1.3-x86_64-2.txz: Rebuilt. Recompiled against vulkan-sdk-1.3.290.0. x/fcitx5-gtk-5.1.3-x86_64-2.txz: Rebuilt. Recompiled against vulkan-sdk-1.3.290.0. x/ibus-1.5.30-x86_64-2.txz: Rebuilt. Recompiled against vulkan-sdk-1.3.290.0. x/mesa-24.1.5-x86_64-2.txz: Rebuilt. Recompiled against vulkan-sdk-1.3.290.0. x/vulkan-sdk-1.3.290.0-x86_64-1.txz: Upgraded. xap/MPlayer-20240812-x86_64-1.txz: Upgraded. Recompiled against ffmpeg-7.0.2. xap/audacious-plugins-4.4-x86_64-3.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. xap/ffmpegthumbnailer-2.2.2-x86_64-6.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. xap/freerdp-2.11.7-x86_64-2.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. xap/mpv-0.38.0-x86_64-5.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. Recompiled against vulkan-sdk-1.3.290.0. xap/ssr-0.4.4-x86_64-3.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. xap/xine-lib-1.2.13-x86_64-8.txz: Rebuilt. Recompiled against ffmpeg-7.0.2. xap/xscreensaver-6.09-x86_64-2.txz: Rebuilt. Recompiled against ffmpeg-7.0.2.
100 lines
3.1 KiB
Bash
Executable file
100 lines
3.1 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2022 Heinz Wiesinger, Amsterdam, The Netherlands
|
|
# Copyright 2022, 2024 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=fcitx5-gtk
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.zst | rev | cut -f 3- -d . | cut -f 1 -d- | rev)}
|
|
BUILD=${BUILD:-2}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
MARCH=$( uname -m )
|
|
if [ -z "$ARCH" ]; then
|
|
case "$MARCH" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$MARCH ;;
|
|
esac
|
|
fi
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-fcitx5-gtk
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf fcitx5-gtk-$VERSION
|
|
tar xvf $CWD/fcitx5-gtk-$VERSION.tar.zst || exit 1
|
|
cd fcitx5-gtk-$VERSION || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
mkdir build
|
|
cd build
|
|
cmake \
|
|
-DCMAKE_CXX_FLAGS="${SLKCFLAGS}" \
|
|
-DCMAKE_C_FLAGS="${SLKCFLAGS}" \
|
|
-DCMAKE_INSTALL_PREFIX="/usr" \
|
|
-DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX} \
|
|
..
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make install/strip DESTDIR=$PKG || exit 1
|
|
cd ..
|
|
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
|
|
cp -a LICENSES/* README* $PKG/usr/doc/$PKGNAM-$VERSION
|
|
|
|
mkdir -p $PKG/install
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
|