mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
c8de49b25a
a/util-linux-2.37.2-x86_64-3.txz: Rebuilt. Removed broken /usr/bin/raw symlink. Thanks to marav. d/gdb-11.1-x86_64-2.txz: Rebuilt. Don't ship .la files. d/vala-0.54.2-x86_64-1.txz: Upgraded. kde/artikulate-21.08.1-x86_64-3.txz: Rebuilt. Fixed broken COPYING{,.DOC} symlinks. Thanks to marav. kde/kservice-5.86.0-x86_64-4.txz: Rebuilt. In /etc/profile.d/kde.{csh,sh}: Fixed test for kf5 directory. Thanks to LuckyCyborg. Make adding /etc/kde/xdg to $XDG_CONFIG_DIRS conditional on the existence of that directory. l/imagemagick-7.1.0_9-x86_64-1.txz: Upgraded. n/bind-9.16.21-x86_64-4.txz: Rebuilt. Removed broken symlink. Thanks to marav. n/httpd-2.4.50-x86_64-1.txz: Upgraded. x/cldr-emoji-annotation-37.0_13.0_0_2-noarch-4.txz: Rebuilt. Fixed broken COPYING symlink. Thanks to marav. xap/x3270-4.0ga14-x86_64-2.txz: Rebuilt. Fixed symlinks in html directory. Thanks to marav.
96 lines
3.1 KiB
Bash
Executable file
96 lines
3.1 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Slackware build script for cldr-emoji-annotation
|
|
|
|
# Copyright 2017-2018 Heinz Wiesinger, Amsterdam, The Netherlands
|
|
# Copyright 2017-2020 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=cldr-emoji-annotation
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-4}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
MARCH=$( uname -m )
|
|
if [ -z "$ARCH" ]; then
|
|
case "$MARCH" in
|
|
i?86) export ARCH=i586 ;;
|
|
armv7hl) export ARCH=$MARCH ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$MARCH ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-noarch-${BUILD}.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-cldr-emoji-annotation
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf cldr-emoji-annotation-$VERSION
|
|
tar xvf $CWD/cldr-emoji-annotation-$VERSION.tar.?z || exit 1
|
|
cd cldr-emoji-annotation-$VERSION || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
if [ ! -r configure ]; then
|
|
if [ -x ./autogen.sh ]; then
|
|
NOCONFIGURE=1 ./autogen.sh
|
|
else
|
|
autoreconf -vif
|
|
fi
|
|
fi
|
|
|
|
CFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--build=$ARCH-slackware-linux || exit 1
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
|
|
cp -a AUTHORS* ChangeLog INSTALL* NEWS* README* \
|
|
$PKG/usr/doc/$PKGNAM-$VERSION
|
|
cp -a $(readlink -f COPYING) $PKG/usr/doc/$PKGNAM-$VERSION/COPYING
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-noarch-$BUILD.txz
|