slackware-current/source/tcl/tk/tk.SlackBuild
Patrick J Volkerding 40f1ab9f2a Tue Sep 17 23:29:04 UTC 2024
a/sysklogd-2.6.2-x86_64-1.txz:  Upgraded.
ap/lxc-6.0.2-x86_64-1.txz:  Upgraded.
ap/vim-9.1.0736-x86_64-1.txz:  Upgraded.
l/gjs-1.82.0-x86_64-1.txz:  Upgraded.
  Compiled against mozjs128-128.2.0esr.
l/mozjs115-115.15.0esr-x86_64-1.txz:  Removed.
l/mozjs128-128.2.0esr-x86_64-1.txz:  Added.
tcl/tcl-8.6.15-x86_64-1.txz:  Upgraded.
tcl/tk-8.6.15-x86_64-1.txz:  Upgraded.
xap/vim-gvim-9.1.0736-x86_64-1.txz:  Upgraded.
2024-09-18 02:05:31 +02:00

141 lines
4.2 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2008, 2009, 2012, 2013, 2016, 2017, 2018, 2019, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=tk
VERSION=${VERSION:-8.6.15}
# See also version number 8.6 in the symlinks below...)
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i686 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
if [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-tk
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf tk8.6.11 tk$VERSION
tar xvf $CWD/tk$VERSION-src.tar.?z || exit 1
cd tk$VERSION || cd tk8.6.11 || exit 1
sed -i -e "s#TK_LIBRARY='\$(prefix)/lib/#TK_LIBRARY='\$(libdir)/#" \
unix/configure
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
mkdir -p $PKG/usr/doc/tk$VERSION
cp -a README* license.terms $PKG/usr/doc/tk$VERSION
cd unix
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--enable-shared \
--enable-threads \
--enable-64bit \
--mandir=/usr/man \
--enable-man-symlinks \
--build=$ARCH-slackware-linux || exit 1
make $NUMJOBS || make || exit 1
# Fix paths in tkConfig.sh:
sed -e "s@^\(TK_SRC_DIR='\).*@\1/usr/include'@" \
-e "/TK_B/s@='\(-L\)\?.*unix@='\1/usr/lib${LIBDIRSUFFIX}@" \
-i tkConfig.sh
make install DESTDIR=$PKG || exit 1
# Some sources require Tk's private headers, which might not be the
# best thing but we'll include them where we've seen other teams
# doing the same thing:
make install-private-headers DESTDIR=$PKG || exit 1
( cd $PKG/usr/bin
rm -f wish
ln -sf wish8.6 wish
)
( cd $PKG/usr/lib${LIBDIRSUFFIX}
rm -f libtk.so
ln -sf libtk8.6.so libtk.so
)
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Compress and link manpages, if any:
if [ -d $PKG/usr/man ]; then
( cd $PKG/usr/man
for manpagedir in $(find . -type d -name "man*") ; do
( cd $manpagedir
for eachpage in $( find . -type l -maxdepth 1 | grep -v '\.gz$') ; do
ln -s $( readlink $eachpage ).gz $eachpage.gz
rm $eachpage
done
gzip -9 *.?
)
done
)
fi
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/tk-$VERSION-$ARCH-$BUILD.txz