slackware-current/source/n/wireless_tools/wireless_tools.SlackBuild
Patrick J Volkerding da4119a5e0 Thu Mar 18 23:54:14 UTC 2021
ap/slackpkg-15.0.1-noarch-1.txz:  Upgraded.
  Tweak default blacklist file's help text (thanks, dive).
  Fix display of blacklisted packages.
  Tweaks to slack-desc.
  Note that kernel-headers should not be blacklisted.
  Added Lithuania mirrors (Totoro-kun on LQ).
  Fix exit code for pending updates (dive).
  Avoid matching txz/tgz etc extension when blacklisting (dive).
  Use https for all slackpkg homepage links.
  Update mirror files (14.2 -> 15.0).
  Add blacklist to search option.
  Move applyblacklist to end of makelist().
  Clarify how to blacklist duplicate packages.
  Fix new-config dialog.
  Reduce false positives in DOUBLEFILES detection.
  Remove spaces in awk..
  More blacklisting fixups (see full commit msg).
  Escape plus signs in blacklist regex.
  Convert ${ROOT}/${WORKDIR} > ${WORKDIR} (dive).
  Convert ${ROOT}/${CONF} -> ${CONF} and tweak blacklists (dive).
  Further fixup/enhancement to blacklisting issues.
  Fix "slackpkg blacklist" so that it shows blacklist again.
  Fixup internal blacklist handling.
  Use ERE for sanity_check() function (David Woodfall).
  Remove "slackpkg blacklist" from manual pages.
  Fix aaa_elflibs --> aaa_libraries in sample blacklist file (mozes).
  Split aarch64 and arm mirrors into separate files (mozes).
  Allow new-config after slackpkg upgrade itself (PiterPUNK).
  Modify blacklist regex line ending.
  Thanks to Robby Workman.
ap/sqlite-3.35.2-x86_64-1.txz:  Upgraded.
kde/kid3-3.8.6-x86_64-1.txz:  Upgraded.
l/glib2-2.66.8-x86_64-1.txz:  Upgraded.
l/pango-1.48.3-x86_64-2.txz:  Rebuilt.
  Eliminate dangling symlink. Thanks to upnort.
n/bind-9.16.13-x86_64-1.txz:  Upgraded.
n/links-2.22-x86_64-1.txz:  Upgraded.
n/network-scripts-15.0-noarch-14.txz:  Rebuilt.
  Fix discrepancies between rc.inet1.conf versions.
  Move configuration of SLACC before DHCP.
  Don't bring up a bridge interface if it will be brought up later by IP config.
  Fix a typo in br_open when configuring IFOPTS: i->1.
  Add SLAAC security and privacy options.
  Fix typo of 'default'.
  Added debugging output around new SLAAC enhancements.
  Move enabling RA before SLAAC security section.  Thanks to davjohn on LQ.
  Fix domain name validation checks.  Thanks to xbeastx74 on LQ for the report.
  Thanks to Darren "Tadgy" Austin and Robby Workman.
n/wireless_tools-30.pre9-x86_64-5.txz:  Rebuilt.
  rc.wireless: don't leave interfaces in up state as it prevents SLAAC.
  Take interface down at exit from rc.wireless.  Thanks to davjohn.
x/libgee-0.20.4-x86_64-1.txz:  Upgraded.
2021-03-19 08:59:51 +01:00

116 lines
4 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2008, 2009, 2010, 2012, 2018 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=wireless_tools
VERSION=30.pre9
BUILD=${BUILD:-5}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
if [ "$ARCH" = "x86_64" ]; then
LIBDIRSUFFIX="64"
else
LIBDIRSUFFIX=""
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-wireless_tools
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf wireless_tools.$VERSION
tar xvf $CWD/wireless_tools.$VERSION.tar.?z || exit 1
cd wireless_tools.$(echo $VERSION | cut -f 1 -d .) || cd wireless_tools.$VERSION
zcat $CWD/wireless_tools.nowhine.diff.gz | patch -p1 --verbose --suffix=.orig --backup || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
make || exit 1
mkdir -p $PKG/sbin
cp -a ifrename iwconfig iwevent iwgetid iwlist iwpriv iwspy $PKG/sbin
chmod 755 $PKG/sbin/*
# The library seems to be used by kdenetwork, but since the .soname in the shared library
# doesn't seem to be forward-thinking we'll leave that out still:
mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}
cp -a libiw.a $PKG/usr/lib${LIBDIRSUFFIX}
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
mkdir -p $PKG/usr/include
cp -a iwlib.h wireless.h $PKG/usr/include
chmod 644 $PKG/usr/include/*.h
mkdir -p $PKG/usr/man/man5
cat iftab.5 | gzip -9c > $PKG/usr/man/man5/iftab.5.gz
mkdir -p $PKG/usr/man/man7
cat wireless.7 | gzip -9c > $PKG/usr/man/man7/wireless.7.gz
mkdir -p $PKG/usr/man/man8
for file in *.8 ; do
cat $file | gzip -9c > $PKG/usr/man/man8/$file.gz
done
mkdir -p $PKG/usr/doc/wireless_tools-$VERSION
cp -a \
COPYING INSTALL *.txt README* \
$PKG/usr/doc/wireless_tools-$VERSION
chmod 644 $PKG/usr/doc/wireless_tools-$VERSION/*
# Add init scripts from Eric Hameleers:
mkdir -p $PKG/etc/rc.d
cat $CWD/scripts/rc.wireless > $PKG/etc/rc.d/rc.wireless.new
chmod 755 $PKG/etc/rc.d/rc.wireless.new
# This might contain a secret key, so we'll use chmod 600:
cat $CWD/scripts/rc.wireless.conf > $PKG/etc/rc.d/rc.wireless.conf.new
chmod 600 $PKG/etc/rc.d/rc.wireless.conf.new
mkdir $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz