slackware-current/source/n/wireless-regdb/wireless-regdb.SlackBuild
Patrick J Volkerding 6ffaeb24f7 Mon Oct 7 22:37:51 UTC 2024
d/tree-sitter-0.24.2-x86_64-1.txz:  Upgraded.
l/imagemagick-7.1.1_39-x86_64-1.txz:  Upgraded.
l/libdeflate-1.22-x86_64-1.txz:  Upgraded.
l/libqalculate-5.3.0-x86_64-1.txz:  Upgraded.
l/python-build-1.2.2.post1-x86_64-1.txz:  Upgraded.
l/python-dnspython-2.7.0-x86_64-1.txz:  Upgraded.
l/python-sphinx_rtd_theme-3.0.0-x86_64-1.txz:  Upgraded.
n/wireless-regdb-2024.10.07-x86_64-1.txz:  Upgraded.
2024-10-08 01:02:23 +02:00

87 lines
3 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2009 Robby Workman, Northport, AL, USA
# Copyright 2009, 2010, 2016, 2018, 2023, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=wireless-regdb
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i686 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-wireless-regdb
if [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
rm -rf $PKG
mkdir -p $TMP $PKG
# First, we need to install the wireless regulatory bin
cd $TMP
tar xvf $CWD/wireless-regdb-$VERSION.tar.xz || exit 1
cd wireless-regdb-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
make install DESTDIR=$PKG MANDIR=/usr/man FIRMWARE_PATH=/lib/firmware || exit 1
mkdir -p $PKG/usr/doc/wireless-regdb-$VERSION/regdb
cp -a LICENSE README db.txt $PKG/usr/doc/wireless-regdb-$VERSION/regdb
# Manpages are already compressed
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/wireless-regdb-$VERSION-$ARCH-$BUILD.txz