mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
2e588b58d9
a/kernel-firmware-20241101_376de1f-noarch-1.txz: Upgraded. a/kernel-generic-6.11.6-x86_64-1.txz: Upgraded. a/mkinitrd-1.4.11-x86_64-42.txz: Rebuilt. geninitrd: you can still point this at a kernel symlink, but by default it will make initrd-${KERNEL_VERSION}.img for the newest kernel it finds in the /boot directory. a/pkgtools-15.1-noarch-16.txz: Rebuilt. make-kernel-backup: don't make copies of any of the files, nor include an initrd in the package. The only added "files" will be two symlinks, vmlinuz-backup, and initrd-backup.img (if symlinks are enabled). d/kernel-headers-6.11.6-x86-1.txz: Upgraded. d/valgrind-3.24.0-x86_64-1.txz: Upgraded. k/kernel-source-6.11.6-noarch-1.txz: Upgraded. l/fluidsynth-2.4.0-x86_64-1.txz: Upgraded. l/gtk4-4.16.4-x86_64-1.txz: Upgraded. l/libzip-1.11.2-x86_64-1.txz: Upgraded. Fix performance regression in zip_stat introduced in 1.11. l/spirv-llvm-translator-19.1.1-x86_64-1.txz: Upgraded. n/uucp-1.07-x86_64-7.txz: Rebuilt. Add some documentation. Thanks to jayjwa. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
120 lines
3.5 KiB
Bash
Executable file
120 lines
3.5 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009, 2010, 2018 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=uucp
|
|
VERSION=1.07
|
|
BUILD=${BUILD:-7}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
fi
|
|
|
|
# GCC 14 "fix":
|
|
SLKCFLAGS="$SLKCFLAGS -Wno-error=implicit-int -Wno-error=incompatible-pointer-types"
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-uucp
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
# Explode the package framework:
|
|
cd $PKG
|
|
explodepkg $CWD/_uucp.tar.gz
|
|
|
|
cd $TMP
|
|
rm -rf uucp-$VERSION
|
|
tar xvf $CWD/uucp-$VERSION.tar.gz || exit 1
|
|
cd uucp-$VERSION || exit 1
|
|
|
|
cat $CWD/uucp-configure-c99.patch | patch -p1 --verbose || exit 1
|
|
|
|
zcat $CWD/policy.h.diff.gz | patch -p1 --verbose || exit 1
|
|
CFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--with-oldconfigdir=/etc/uucp/oldconfig \
|
|
--with-newconfigdir=/etc/uucp
|
|
|
|
make || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
strip --strip-unneeded $PKG/usr/bin/* $PKG/usr/sbin/*
|
|
|
|
gzip -9 $PKG/usr/man/man?/*
|
|
gzip -9 $PKG/usr/info/*
|
|
rm -f $PKG/usr/info/dir.gz
|
|
|
|
# Setuid uucp binaries may only be run by members of the uucp group:
|
|
( cd $PKG/usr/bin
|
|
chgrp uucp cu uucp uuname uustat uux
|
|
chmod 4554 cu uucp uuname uustat uux
|
|
cd ../sbin
|
|
chgrp uucp uucico uuxqt
|
|
chmod 4554 uucico uuxqt
|
|
)
|
|
|
|
# Add a documentation directory:
|
|
mkdir -p $PKG/usr/doc/uucp-$VERSION
|
|
cp -a \
|
|
AUTHORS* ChangeLog COPYING* NEWS* README* TODO* \
|
|
$PKG/usr/doc/uucp-$VERSION
|
|
|
|
# If there's a ChangeLog, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r ChangeLog ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
|
|
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
|
|
touch -r ChangeLog $DOCSDIR/ChangeLog
|
|
fi
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
# Build the package:
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/uucp-$VERSION-$ARCH-$BUILD.txz
|
|
|