mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
88948ca365
a/sysvinit-scripts-15.1-noarch-20.txz: Rebuilt. rc.M: fix typo when starting local LDAP name service daemon. Thanks to tcanich. ap/lxc-6.0.1-x86_64-2.txz: Rebuilt. Update the ca-certificates as part of lxc-create. l/gvfs-1.54.2-x86_64-1.txz: Upgraded. l/wireplumber-0.5.5-x86_64-1.txz: Upgraded. n/s-nail-14.9.25-x86_64-1.txz: Upgraded. x/ibus-table-1.17.6-x86_64-1.txz: Upgraded.
146 lines
4.2 KiB
Bash
Executable file
146 lines
4.2 KiB
Bash
Executable file
#!/bin/sh
|
|
|
|
# Slackware build script for S-nail
|
|
|
|
# Copyright 2008, 2009, 2010, 2016, 2018 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# Copyright 2018 Johannes Schoepfer, Germany
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=s-nail
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) ARCH=i586 ;;
|
|
arm*) ARCH=arm ;;
|
|
*) ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
# Don't use parallel build:
|
|
#NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
if [ "$ARCH" = "i586" ]; then
|
|
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-$PKGNAM
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf $PKGNAM-$VERSION
|
|
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
|
|
cd $PKGNAM-$VERSION || exit 1
|
|
chown -R root:root .
|
|
find -L . \
|
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
|
-o -perm 511 \) -exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
|
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
|
|
|
|
# If there's no mail, exit:
|
|
zcat $CWD/s-nail.no.emptystart.diff.gz | patch -p1 --verbose || exit 1
|
|
|
|
CFLAGS="$SLKCFLAGS" \
|
|
make \
|
|
VAL_PREFIX=/usr \
|
|
VAL_SYSCONFDIR=/etc \
|
|
VAL_MANDIR=/usr/man \
|
|
VAL_MAIL=/var/spool/mail \
|
|
VAL_MTA=/usr/sbin/sendmail \
|
|
OPT_AUTOCC=no \
|
|
OPT_DOTLOCK=no \
|
|
VAL_SID= \
|
|
VAL_MAILX=mailx \
|
|
VAL_SYSCONFRC=nail.rc \
|
|
VAL_RANDOM="libgetrandom,sysgetrandom,urandom" \
|
|
config || exit 1
|
|
|
|
make $NUMJOBS build || exit 1
|
|
make $NUMJOBS test || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
# Tighten up the perms a bit:
|
|
chmod 4711 $PKG/usr/libexec/mailx-dotlock
|
|
|
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
|
|
|
# We put symlinks in /bin since some things still expect '/bin/mail' or '/bin/Mail':
|
|
mkdir -p $PKG/bin
|
|
( cd $PKG/bin
|
|
ln -sf /usr/bin/mailx Mail
|
|
ln -sf /usr/bin/mailx mail
|
|
ln -sf /usr/bin/mailx nail
|
|
)
|
|
|
|
# Likewise, we make some compat symlinks in /usr/bin:
|
|
( cd $PKG/usr/bin
|
|
ln -sf mailx Mail
|
|
ln -sf mailx mail
|
|
ln -sf mailx nail
|
|
)
|
|
|
|
mv $PKG/etc/nail.rc $PKG/etc/nail.rc.new
|
|
|
|
find $PKG/usr/man -type f -exec gzip -9 {} \+
|
|
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
|
|
|
# Manpage links:
|
|
( cd $PKG/usr/man/man1
|
|
ln -sf mailx.1.gz mail.1.gz
|
|
ln -sf mailx.1.gz nail.1.gz
|
|
ln -sf mailx.1.gz Mail.1.gz
|
|
)
|
|
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
|
|
cp -a \
|
|
COPYING* INSTALL* NEWS* README* THANKS* \
|
|
$PKG/usr/doc/$PKGNAM-$VERSION
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
|