mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
3a02a31f29
a/aaa_libraries-15.1-x86_64-35.txz: Rebuilt. Upgraded: libcap.so.2.73, libgpg-error.so.0.38.0, libcares.so.2.19.2, libexpat.so.1.10.0, libglib-2.0.so.0.8200.4, libgmodule-2.0.so.0.8200.4, libgobject-2.0.so.0.8200.4, libgthread-2.0.so.0.8200.4, libltdl.so.7.3.3. Added (temporarily): libboost_*.so.1.86.0 a/mkinitrd-1.4.11-x86_64-56.txz: Rebuilt. setup.01.mkinitrd: if there's no KERNEL variable or $1 from the command line, then fall back to the newest kernel like the documentation states. Thanks to Mechanikx. d/re2c-4.0.2-x86_64-1.txz: Upgraded. kde/kig-23.08.5-x86_64-7.txz: Rebuilt. Recompiled against boost-1.87.0. kde/kopeninghours-23.08.5-x86_64-7.txz: Rebuilt. Recompiled against boost-1.87.0. l/PyQt5_sip-12.16.1-x86_64-1.txz: Upgraded. l/boost-1.87.0-x86_64-1.txz: Upgraded. Shared library .so-version bump. l/cryfs-0.10.3-x86_64-14.txz: Rebuilt. Patched bundled versioneer.py for Python 3.12. Thanks to shipujin. Recompiled against boost-1.87.0. l/espeak-ng-1.52.0-x86_64-1.txz: Upgraded. l/glib2-2.82.4-x86_64-1.txz: Upgraded. l/sip-6.9.1-x86_64-1.txz: Upgraded. n/bind-9.20.4-x86_64-1.txz: Upgraded. n/proftpd-1.3.8c-x86_64-1.txz: Upgraded. x/fcitx5-chinese-addons-5.1.7-x86_64-2.txz: Rebuilt. Recompiled against boost-1.87.0. x/libime-1.1.9-x86_64-2.txz: Rebuilt. Recompiled against boost-1.87.0.
149 lines
4.7 KiB
Bash
Executable file
149 lines
4.7 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009, 2010, 2011, 2012, 2013, 2016, 2017, 2018, 2020, 2024 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=proftpd
|
|
VERSION=1.3.8c
|
|
DIRVER=1.3.8c
|
|
BUILD=${BUILD:-1}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
PROFTPD_MODS="mod_radius:mod_ban:mod_readme:mod_ratio:mod_tls:mod_wrap2:mod_wrap2_file:mod_ctrls_admin:mod_quotatab:mod_quotatab_file:mod_sftp:mod_facl:mod_ldap"
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-proftpd
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
cd $TMP
|
|
rm -rf proftpd-$VERSION
|
|
tar xvf $CWD/proftpd-$VERSION.tar.?z* || exit 1
|
|
cd proftpd-$DIRVER || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
CFLAGS="$SLKCFLAGS" \
|
|
CXXFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--mandir=/usr/man \
|
|
--sysconfdir=/etc \
|
|
--enable-autoshadow \
|
|
--enable-ctrls \
|
|
--enable-dso \
|
|
--enable-ipv6 \
|
|
--enable-nls \
|
|
--localstatedir=/var/run \
|
|
--with-modules="${PROFTPD_MODS}" \
|
|
--build=$ARCH-slackware-linux || exit 1
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
# With no library to link against, these are useless:
|
|
rm -rf $PKG/usr/include
|
|
rm -f $PKG/etc/*
|
|
rmdir $PKG/usr/libexec 2> /dev/null
|
|
|
|
cat $CWD/etc/proftpd.conf > $PKG/etc/proftpd.conf.new
|
|
cat $CWD/etc/ftpusers > $PKG/etc/ftpusers.new
|
|
mkdir -p $PKG/home/ftp
|
|
|
|
# Directory used by mod_ban:
|
|
mkdir -p $PKG/var/db/proftpd
|
|
chown proftpd:proftpd $PKG/var/db/proftpd
|
|
|
|
# Compress manual pages:
|
|
find $PKG/usr/man -type f -exec gzip -9 {} \+
|
|
for i in $( find $PKG/usr/man -type l ) ; do
|
|
ln -s $( readlink $i ).gz $i.gz
|
|
rm $i
|
|
done
|
|
|
|
mkdir -p $PKG/usr/doc/proftpd-$VERSION
|
|
cp -a COPYING* CREDITS INSTALL NEWS README* \
|
|
contrib/README.mod_wrap contrib/README.ratio \
|
|
$PKG/usr/doc/proftpd-$VERSION
|
|
# If there's a ChangeLog, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r ChangeLog ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/proftpd-$VERSION)
|
|
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
|
|
touch -r ChangeLog $DOCSDIR/ChangeLog
|
|
fi
|
|
cp -a contrib/README $PKG/usr/doc/proftpd-$VERSION/README.contrib
|
|
cp -a doc sample-configurations $PKG/usr/doc/proftpd-$VERSION
|
|
# Bloat removal:
|
|
( cd $PKG/usr/doc
|
|
find . -name "*.sgml" -exec rm {} \+
|
|
find . -name "*.pdf" -exec rm {} \+
|
|
)
|
|
rmdir $PKG/usr/share/locale
|
|
rmdir $PKG/usr/share
|
|
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" \
|
|
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
mkdir -p $PKG/install
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/proftpd-$VERSION-$ARCH-$BUILD.txz
|