mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
4263c2cc33
a/kbd-2.7-x86_64-1.txz: Upgraded. l/glib2-2.82.3-x86_64-2.txz: Rebuilt. [PATCH 1/3] Revert "gdbus: Fix leak of method invocation when registering an object with closures" [PATCH 2/3] Add comment explaining why an invocation is leaked [PATCH 3/3] gdbusconnection: Document existing refcount semantics of closures Thanks to H1p8r10n. n/curl-8.11.1-x86_64-1.txz: Upgraded. n/netatalk-4.0.8-x86_64-1.txz: Upgraded. n/nfs-utils-2.8.2-x86_64-1.txz: Upgraded. n/socat-1.8.0.2-x86_64-1.txz: Upgraded. x/ibus-table-1.17.9-x86_64-1.txz: Upgraded. xap/mozilla-thunderbird-128.5.2esr-x86_64-1.txz: Upgraded. This release contains security fixes and improvements. For more information, see: https://www.mozilla.org/en-US/thunderbird/128.5.2esr/releasenotes/ https://www.mozilla.org/en-US/security/advisories/mfsa2024-69/ https://www.cve.org/CVERecord?id=CVE-2024-50336 (* Security fix *)
208 lines
6.3 KiB
Bash
Executable file
208 lines
6.3 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009, 2010, 2011, 2013, 2016, 2018, 2020, 2023 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=nfs-utils
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-nfs-utils
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG/etc/exports.d
|
|
|
|
# Add defaults file:
|
|
mkdir -p $PKG/etc/default
|
|
cat $CWD/nfs.default > $PKG/etc/default/nfs.new
|
|
|
|
# Add startup script:
|
|
mkdir -p $PKG/etc/rc.d
|
|
cat $CWD/rc.nfsd > $PKG/etc/rc.d/rc.nfsd.new
|
|
# Off by default, unless there's a previous version that's turned on:
|
|
chmod 644 $PKG/etc/rc.d/rc.nfsd.new
|
|
|
|
# Add /etc/exports:
|
|
cp -a $CWD/exports $PKG/etc/exports.new
|
|
chown root:root $PKG/etc/exports.new
|
|
chmod 644 $PKG/etc/exports.new
|
|
|
|
cd $TMP
|
|
rm -rf nfs-utils-$VERSION
|
|
tar xvf $CWD/nfs-utils-$VERSION.tar.?z || exit 1
|
|
cd nfs-utils-$VERSION || exit 1
|
|
|
|
zcat $CWD/nfs-utils.lwrap.needs.lnsl.diff.gz | patch -p1 --verbose || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# Configure, build, and install:
|
|
CFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--mandir=/usr/man \
|
|
--with-statedir=/var/lib/nfs \
|
|
--with-pluginpath=/usr/lib${LIBDIRSUFFIX}/libnfsidmap \
|
|
--disable-static \
|
|
--enable-mountconfig \
|
|
--enable-nfsdcltrack=yes \
|
|
--enable-nfsv4=yes \
|
|
--enable-gss=yes \
|
|
--enable-svcgss=yes \
|
|
--enable-tirpc=yes \
|
|
--program-prefix= \
|
|
--program-suffix= \
|
|
--build=$ARCH-slackware-linux || exit 1
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
# Don't ship .la files:
|
|
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
|
|
|
|
# Move udev rule:
|
|
mkdir -p $PKG/lib
|
|
mv $PKG/usr/lib/udev $PKG/lib
|
|
rmdir $PKG/usr/lib 2> /dev/null
|
|
|
|
# Add nfsmount.conf and man page:
|
|
cat ./utils/mount/nfsmount.conf > $PKG/etc/nfsmount.conf.new
|
|
mkdir -p $PKG/usr/man/man5
|
|
cat ./utils/mount/nfsmount.conf.man > $PKG/usr/man/man5/nfsmount.conf.5
|
|
|
|
# Set default protocol version 3:
|
|
sed -i "s/# Defaultvers=4/Defaultvers=3/g" $PKG/etc/nfsmount.conf.new
|
|
|
|
# These might be in use:
|
|
( cd $PKG/var/lib/nfs
|
|
for config_file in etab rmtab state ; do
|
|
mv ${config_file} ${config_file}.new
|
|
done
|
|
)
|
|
|
|
# This should move to support /usr on NFS:
|
|
mkdir -p $PKG/sbin
|
|
mv $PKG/usr/sbin/rpc.statd $PKG/sbin
|
|
( cd $PKG/usr/sbin ; ln -sf ../../sbin/rpc.statd . )
|
|
|
|
# Make recovery directory. The location expected may be found in
|
|
# /proc/fs/nfsd/nfsv4recoverydir, so if that file exists we will get the
|
|
# location from there. If not, we'll use the usual directory path.
|
|
if [ -r /proc/fs/nfsd/nfsv4recoverydir ]; then
|
|
NFSV4RECOVERYDIR="$(cat /proc/fs/nfsd/nfsv4recoverydir)"
|
|
else
|
|
NFSV4RECOVERYDIR="/var/lib/nfs/v4recovery"
|
|
fi
|
|
mkdir -p ${PKG}${NFSV4RECOVERYDIR}
|
|
|
|
# Chown /var/lib/nfs so that rpc.statd runs as rpc:rpc:
|
|
chown -R rpc:rpc $PKG/var/lib/nfs
|
|
|
|
# Add database directory for nfsdcltrack:
|
|
mkdir -p $PKG/var/lib/nfs/nfsdcltrack
|
|
chown root:rpc $PKG/var/lib/nfs/nfsdcltrack
|
|
chmod 775 $PKG/var/lib/nfs/nfsdcltrack
|
|
|
|
# Create log directory:
|
|
mkdir -p $PKG/var/log/nfsd
|
|
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" \
|
|
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
mkdir -p $PKG/usr/doc/nfs-utils-$VERSION
|
|
cp -a \
|
|
AUTHORS COPYING* INSTALL NEWS README* \
|
|
$PKG/usr/doc/nfs-utils-$VERSION
|
|
mkdir -p $PKG/usr/doc/nfs-utils-$VERSION/statd
|
|
cp -a \
|
|
utils/statd/COPYING utils/statd/COPYRIGHT utils/statd/TODO \
|
|
$PKG/usr/doc/nfs-utils-$VERSION/statd
|
|
|
|
# If there's a ChangeLog, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r ChangeLog ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
|
|
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
|
|
touch -r ChangeLog $DOCSDIR/ChangeLog
|
|
fi
|
|
|
|
# Compress and if needed symlink the man pages:
|
|
if [ -d $PKG/usr/man ]; then
|
|
( cd $PKG/usr/man
|
|
for manpagedir in $(find . -type d -name "man*") ; do
|
|
( cd $manpagedir
|
|
for eachpage in $( find . -type l -maxdepth 1) ; do
|
|
ln -s $( readlink $eachpage ).gz $eachpage.gz
|
|
rm $eachpage
|
|
done
|
|
gzip -9 *.?
|
|
)
|
|
done
|
|
)
|
|
fi
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
|
|
# Build the package:
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/nfs-utils-$VERSION-$ARCH-$BUILD.txz
|
|
|