mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
84730d7aba
ap/tmux-3.3a-x86_64-2.txz: Rebuilt. Patched to fix a crash when copying text. Thanks to nullptr, gnw, and Daedra. d/parallel-20230722-noarch-1.txz: Upgraded. l/libarchive-3.7.0-x86_64-1.txz: Upgraded. l/pipewire-0.3.75-x86_64-2.txz: Rebuilt. [PATCH] pipewire: add missing stdbool.h include to version.h.in. Thanks to marav. n/network-scripts-15.1-noarch-1.txz: Upgraded. Added netconfig.8 manpage. Thanks to metaed. extra/brltty/brltty-6.6-x86_64-1.txz: Upgraded.
135 lines
5 KiB
Bash
Executable file
135 lines
5 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2006, 2007, 2008, 2009, 2010, 2012, 2013, 2015, 2017, 2018, 2021, 2022, 2023 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=network-scripts
|
|
VERSION=${VERSION:-15.1}
|
|
ARCH=noarch
|
|
BUILD=${BUILD:-1}
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-${PKGNAM}
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG/etc/rc.d
|
|
( cd $PKG/etc/rc.d
|
|
for file in rc.inet1.conf rc.inet1 rc.inet2 rc.ip_forward ; do
|
|
cp -a $CWD/scripts/$file ${file}.new
|
|
done
|
|
chown root:root *
|
|
chmod 755 rc.inet1.new rc.inet2.new
|
|
chmod 600 rc.inet1.conf.new
|
|
)
|
|
( cd $PKG/etc
|
|
for file in HOSTNAME host.conf hosts.allow hosts.deny hosts.equiv hosts networks nntpserver protocols resolv.conf ; do
|
|
cp -a $CWD/scripts/$file ${file}.new
|
|
chmod 644 ${file}.new
|
|
done
|
|
chown root:root *
|
|
)
|
|
mkdir -p $PKG/sbin
|
|
cp -a $CWD/scripts/netconfig $PKG/sbin/netconfig
|
|
chown root:root $PKG/sbin/netconfig
|
|
chmod 755 $PKG/sbin/netconfig
|
|
mkdir -p $PKG/var/log/setup
|
|
cp -a $CWD/scripts/setup.netconfig $PKG/var/log/setup
|
|
chown root:root $PKG/var/log/setup/setup.netconfig
|
|
chmod 755 $PKG/var/log/setup/setup.netconfig
|
|
|
|
# Add manpages:
|
|
mkdir -p $PKG/usr/man/man{5,8}
|
|
cat $CWD/manpages/rc.inet1.conf.5 | gzip -9c > $PKG/usr/man/man5/rc.inet1.conf.5.gz
|
|
cat $CWD/manpages/rc.inet1.8 | gzip -9c > $PKG/usr/man/man8/rc.inet1.8.gz
|
|
cat $CWD/manpages/netconfig.8 | gzip -9c > $PKG/usr/man/man8/netconfig.8.gz
|
|
|
|
# Add default module configs for bonding and ipv6
|
|
mkdir -p $PKG/lib/modprobe.d/
|
|
cat $CWD/modprobe.d/bonding.conf > $PKG/lib/modprobe.d/bonding.conf
|
|
cat $CWD/modprobe.d/ipv6.conf > $PKG/lib/modprobe.d/ipv6.conf
|
|
|
|
# Drop the documentation in /usr/doc/network-scripts-$VERSION:
|
|
mkdir -p $PKG/usr/doc/network-scripts-$VERSION
|
|
cp -a $CWD/README* $PKG/usr/doc/network-scripts-$VERSION
|
|
chown -R root:root $PKG/usr/doc/network-scripts-$VERSION
|
|
chmod 644 $PKG/usr/doc/network-scripts-$VERSION/*
|
|
|
|
mkdir -p $PKG/install
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
# Patch to fix rc.inet1.new for LXC:
|
|
( cd $PKG
|
|
cat $CWD/0000-rc.inet1.new-lxc-additions.patch | patch -p1 --verbose || exit 1
|
|
rm -f etc/rc.d/rc.inet1.new.orig
|
|
) || exit 1
|
|
|
|
# Patch netconfig to fix leaving a previously enabled rc.networkmanager
|
|
# executable even if networkmanager is no longer selected:
|
|
( cd $PKG
|
|
cat $CWD/0001-netconfig-turn-off-rc.networkmanager-if-networkmanager-is-not-selected.patch | patch -p1 --verbose || exit 1
|
|
rm -f sbin/netconfig.orig
|
|
) || exit 1
|
|
|
|
# Patch netconfig to add hostname-labeled loopback entries when DHCP
|
|
# is selected:
|
|
( cd $PKG
|
|
cat $CWD/0002-add-hostname-loopback-entries-in-etc-hosts-for-dhcp.patch | patch -p1 --verbose || exit 1
|
|
rm -f sbin/netconfig.orig
|
|
) || exit 1
|
|
|
|
# Temporarily rename these files so that we can patch them:
|
|
mv $PKG/etc/rc.d/rc.inet1.new $PKG/etc/rc.d/rc.inet1
|
|
mv $PKG/etc/rc.d/rc.inet1.conf.new $PKG/etc/rc.d/rc.inet1.conf
|
|
|
|
# Re-add support for the DHCP_IPADDR parameter from rc.inet1.conf:
|
|
( cd $PKG/etc/rc.d
|
|
cat $CWD/0003-76218fa6e7c097c875af2a29cc7670995bef2ae4.patch | patch -p1 --verbose || exit 1
|
|
rm -f etc/rc.d/rc.inet1.orig
|
|
) || exit 1
|
|
|
|
# Expand the help text for DHCP_IPADDR in rc.inet1.conf:
|
|
( cd $PKG/etc/rc.d
|
|
cat $CWD/0004-8f43a741a36e59b8a9560ff2c4f3e5da2b8dd72b.patch | patch -p1 --verbose || exit 1
|
|
rm -f etc/rc.d/rc.inet1.conf.orig
|
|
) || exit 1
|
|
|
|
# Add support for a DHCP_OPTS parameter:
|
|
( cd $PKG/etc/rc.d
|
|
cat $CWD/0005-5925f2bcc500f5198b5c00ab4e635a59bef7a413.patch | patch -p1 --verbose || exit 1
|
|
rm -f etc/rc.d/rc.inet1.orig
|
|
) || exit 1
|
|
|
|
# Rename the files back to .new:
|
|
mv $PKG/etc/rc.d/rc.inet1 $PKG/etc/rc.d/rc.inet1.new
|
|
mv $PKG/etc/rc.d/rc.inet1.conf $PKG/etc/rc.d/rc.inet1.conf.new
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/${PKGNAM}-$VERSION-$ARCH-$BUILD.txz
|