mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
abc3e67678
a/less-654-x86_64-1.txz: Upgraded. d/ninja-1.12.1-x86_64-1.txz: Upgraded. n/whois-5.5.23-x86_64-1.txz: Upgraded. Updated the .sc, .********* (.xn--yfro4i67o, Singapore) and .********************************* (.xn--clchc0ea0b2g2a9gcd, Singapore) TLD servers. extra/bittornado/bittornado-0.3.18-noarch-3.txz: Removed. Obsolete and based on python2.
124 lines
3.9 KiB
Bash
Executable file
124 lines
3.9 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009, 2010, 2016, 2018, 2021 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=netwatch
|
|
VERSION=1.3.1
|
|
EXTRAVERSION=${EXTRAVERSION:-2}
|
|
BUILD=${BUILD:-6}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i586 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-${VERSION}_${EXTRAVERSION}-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
if [ "$ARCH" = "i586" ]; then
|
|
SLKCFLAGS="-O2 -march=i586 -mtune=i686 -fcommon"
|
|
elif [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=i686 -mtune=i686 -fcommon"
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -fPIC -fcommon"
|
|
else
|
|
SLKCFLAGS="-O2 -fcommon"
|
|
fi
|
|
|
|
# GCC 14 "fix":
|
|
SLKCFLAGS="$SLKCFLAGS -Wno-error=implicit-int -Wno-error=implicit-function-declaration"
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-netwatch
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG/usr
|
|
|
|
cd $TMP
|
|
rm -rf netwatch-$VERSION-$EXTRAVERSION
|
|
tar xvf $CWD/netwatch-$VERSION-$EXTRAVERSION.tar.xz || exit 1
|
|
cd netwatch-$VERSION-$EXTRAVERSION || exit 1
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# Remove the call home "feature"
|
|
zcat $CWD/netwatch.phonemyself.diff.gz | patch -p0 --verbose || exit 1
|
|
|
|
# Configure
|
|
CFLAGS="$SLKCFLAGS" \
|
|
CXXFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--mandir=/usr/man \
|
|
--infodir=/usr/info \
|
|
--build=$ARCH-slackware-linux || exit 1
|
|
|
|
# Fix "make install" problem
|
|
zcat $CWD/netwatch.makefile.diff.gz | patch -p0 --verbose || exit 1
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
# Strip binaries and libraries
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" \
|
|
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
# Compress man pages
|
|
( cd $PKG/usr/man
|
|
find . -type f -exec gzip -9 {} \+
|
|
for i in $( find . -type l ) ; do
|
|
ln -s $( readlink $i ).gz $i.gz ; rm $i
|
|
done
|
|
)
|
|
|
|
# Copy program documentation into the package
|
|
mkdir -p $PKG/usr/doc/netwatch-${VERSION}_${EXTRAVERSION}
|
|
cp -a \
|
|
BUGS CHANGES COPYING README README.performance TODO \
|
|
netwatch-$VERSION.lsm NetwatchKeyCommands.html \
|
|
$PKG/usr/doc/netwatch-${VERSION}_${EXTRAVERSION}
|
|
|
|
# Copy the slack-desc
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/netwatch-${VERSION}_${EXTRAVERSION}-$ARCH-$BUILD.txz
|
|
|