mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
abc3e67678
a/less-654-x86_64-1.txz: Upgraded. d/ninja-1.12.1-x86_64-1.txz: Upgraded. n/whois-5.5.23-x86_64-1.txz: Upgraded. Updated the .sc, .********* (.xn--yfro4i67o, Singapore) and .********************************* (.xn--clchc0ea0b2g2a9gcd, Singapore) TLD servers. extra/bittornado/bittornado-0.3.18-noarch-3.txz: Removed. Obsolete and based on python2.
85 lines
2.8 KiB
Bash
Executable file
85 lines
2.8 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2007-2018 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=netkit-timed
|
|
VERSION=0.17
|
|
BUILD=${BUILD:-4}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i586 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-netkit-timed
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
cd $TMP
|
|
tar xzvf $CWD/netkit-timed-$VERSION.tar.gz || exit 1
|
|
cd netkit-timed-$VERSION
|
|
chown -R root:root .
|
|
zcat $CWD/netkit-timed-0.17.diff.gz | patch -p1 --backup --verbose --suffix=.orig -E || exit
|
|
CFLAGS="-DCLK_TCK=CLOCKS_PER_SEC -Wno-error=incompatible-pointer-types" ./configure --prefix=/usr
|
|
make || exit 1
|
|
cd timed/timed
|
|
strip timed
|
|
mkdir -p $PKG/usr/sbin
|
|
cat timed > $PKG/usr/sbin/in.timed
|
|
chmod 755 $PKG/usr/sbin/in.timed
|
|
mkdir -p $PKG/usr/man/man8
|
|
cat timed.8 | gzip -9c > $PKG/usr/man/man8/timed.8.gz
|
|
cd ../timedc
|
|
strip timedc
|
|
cat timedc > $PKG/usr/sbin/timedc
|
|
chmod 755 $PKG/usr/sbin/timedc
|
|
cat timedc.8 | gzip -9c > $PKG/usr/man/man8/timedc.8.gz
|
|
cd ../..
|
|
mkdir -p $PKG/usr/doc/netkit-timed-$VERSION
|
|
cp -a README $PKG/usr/doc/netkit-timed-$VERSION
|
|
chown root:root $PKG/usr/doc/netkit-timed-$VERSION/*
|
|
chmod 644 $PKG/usr/doc/netkit-timed-$VERSION/*
|
|
|
|
# Finish up the package:
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
# Build the package:
|
|
cd $PKG
|
|
makepkg -l y -c n $TMP/netkit-timed-$VERSION-$ARCH-$BUILD.txz
|
|
|