slackware-current/source/n/netatalk/netatalk.SlackBuild
Patrick J Volkerding 4263c2cc33 Wed Dec 11 23:35:28 UTC 2024
a/kbd-2.7-x86_64-1.txz:  Upgraded.
l/glib2-2.82.3-x86_64-2.txz:  Rebuilt.
  [PATCH 1/3] Revert "gdbus: Fix leak of method invocation when registering an
  object with closures"
  [PATCH 2/3] Add comment explaining why an invocation is leaked
  [PATCH 3/3] gdbusconnection: Document existing refcount semantics of closures
  Thanks to H1p8r10n.
n/curl-8.11.1-x86_64-1.txz:  Upgraded.
n/netatalk-4.0.8-x86_64-1.txz:  Upgraded.
n/nfs-utils-2.8.2-x86_64-1.txz:  Upgraded.
n/socat-1.8.0.2-x86_64-1.txz:  Upgraded.
x/ibus-table-1.17.9-x86_64-1.txz:  Upgraded.
xap/mozilla-thunderbird-128.5.2esr-x86_64-1.txz:  Upgraded.
  This release contains security fixes and improvements.
  For more information, see:
    https://www.mozilla.org/en-US/thunderbird/128.5.2esr/releasenotes/
    https://www.mozilla.org/en-US/security/advisories/mfsa2024-69/
    https://www.cve.org/CVERecord?id=CVE-2024-50336
  (* Security fix *)
2024-12-12 01:08:19 +01:00

154 lines
4.7 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2008, 2009, 2012, 2015, 2018, 2019, 2020, 2022, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
# Script updated to package netatalk 3.1.11 by Matthew Schumacher
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=netatalk
VERSION=${VERSION:-$(echo netatalk-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i686 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
if [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-netatalk
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf netatalk-$VERSION
tar xvf $CWD/netatalk-$VERSION.tar.?z* || exit 1
cd netatalk-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
# Configure, build, and install:
export CFLAGS="$SLKCFLAGS"
export CXXFLAGS="$SLKCFLAGS"
mkdir meson-build
cd meson-build
meson setup \
--prefix=/usr \
--libdir=lib${LIBDIRSUFFIX} \
--libexecdir=/usr/libexec \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
--includedir=/usr/include \
--datadir=/usr/share \
--mandir=/usr/man \
--sysconfdir=/etc/netatalk \
--localstatedir=/var \
--buildtype=release \
-Dwith-pam=true \
-Dwith-pam-config-path=/etc/pam.d \
-Dwith-dbus-sysconf-path=/usr/share/dbus-1/system.d/ \
-Dwith-dbus-daemon-path=/usr/bin/dbus-daemon \
-Dwith-overwrite=true \
.. || exit 1
"${NINJA:=ninja}" $NUMJOBS || exit 1
DESTDIR=$PKG $NINJA install || exit 1
cd ..
# At least make this unreadable to non-root users:
if [ -u $PKG/usr/bin/afppasswd ]; then
chmod 4711 $PKG/usr/bin/afppasswd
fi
# Don't ship static libraries:
rm -f $PKG/usr/lib${LIBDIRSUFFIX}/{*.a,netatalk/*.a}
# Move documentation:
mkdir -p $PKG/usr/doc
mv $PKG/usr/share/doc/netatalk $PKG/usr/doc/netatalk-$VERSION
rmdir $PKG/usr/share/doc $PKG/usr/share 2> /dev/null
find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Compress manual pages:
find $PKG/usr/man -type f -exec gzip -9 {} \+
for i in $( find $PKG/usr/man -type l ) ; do
ln -s $( readlink $i ).gz $i.gz
rm $i
done
# Install an init script
mkdir -p $PKG/etc/rc.d
cat $CWD/rc.atalk.new > $PKG/etc/rc.d/rc.atalk.new
chmod 644 $PKG/etc/rc.d/rc.atalk.new
mkdir -p $PKG/install
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
cat $CWD/slack-desc > $PKG/install/slack-desc
( cd $PKG/etc/netatalk
for file in *.conf ; do
mv $file ${file}.new
done
)
mv $PKG/etc/pam.d/netatalk $PKG/etc/pam.d/netatalk.new
mkdir -p $PKG/usr/doc/netatalk-$VERSION
cp -a \
CONTRIBUTORS* COPYING* COPYRIGHT* DOCKER* INSTALL* NEWS* README* SECURITY* \
$PKG/usr/doc/netatalk-$VERSION
cp -a $CWD/examples $PKG/usr/doc/netatalk-$VERSION
chown -R root:root $PKG/usr/doc/netatalk-$VERSION/examples
# Build the package:
cd $PKG
/sbin/makepkg -l y -c n $TMP/netatalk-$VERSION-$ARCH-$BUILD.txz