mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
345b47e072
a/exfatprogs-1.1.2-x86_64-1.txz: Upgraded. a/kmod-29-x86_64-1.txz: Upgraded. a/logrotate-3.18.1-x86_64-1.txz: Upgraded. a/pkgtools-15.0-noarch-41.txz: Rebuilt. installpkg, upgradepkg: skip the install script when doing upgradepkg's pre-install. In cases where the script operations are expensive this can nearly double the speed of upgrading a package. Thanks to Stuart Winter. ap/texinfo-6.7-x86_64-5.txz: Rebuilt. Recompiled against perl-5.34.0. ap/vim-8.2.2876-x86_64-1.txz: Upgraded. Compiled against perl-5.34.0. d/perl-5.34.0-x86_64-1.txz: Upgraded. d/sassc-3.6.2-x86_64-1.txz: Upgraded. d/subversion-1.14.1-x86_64-3.txz: Rebuilt. Recompiled against perl-5.34.0. l/libsass-3.6.5-x86_64-1.txz: Upgraded. l/libsigc++3-3.0.7-x86_64-1.txz: Upgraded. n/bind-9.16.16-x86_64-1.txz: Upgraded. n/epic5-2.1.4-x86_64-2.txz: Rebuilt. Recompiled against perl-5.34.0. n/irssi-1.2.3-x86_64-2.txz: Rebuilt. Recompiled against perl-5.34.0. n/libndp-1.8-x86_64-1.txz: Upgraded. n/net-snmp-5.9-x86_64-6.txz: Rebuilt. Recompiled against perl-5.34.0. n/ntp-4.2.8p15-x86_64-8.txz: Rebuilt. Recompiled against perl-5.34.0. n/openldap-2.4.58-x86_64-2.txz: Rebuilt. Recompiled against perl-5.34.0. x/mesa-21.1.1-x86_64-1.txz: Upgraded. xap/hexchat-2.14.3-x86_64-8.txz: Rebuilt. Recompiled against perl-5.34.0. xap/rxvt-unicode-9.26-x86_64-2.txz: Rebuilt. Recompiled against perl-5.34.0. xap/vim-gvim-8.2.2876-x86_64-1.txz: Upgraded. Compiled against perl-5.34.0.
119 lines
3.6 KiB
Bash
Executable file
119 lines
3.6 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Slackware build script for libndp
|
|
|
|
# Copyright 2014 Robby Workman, Northport, Alabama, USA
|
|
# Copyright 2015, 2016, 2018, 2021 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=libndp
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) ARCH=i586 ;;
|
|
arm*) ARCH=arm ;;
|
|
*) ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-$PKGNAM
|
|
|
|
if [ "$ARCH" = "i586" ]; then
|
|
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf $PKGNAM-$VERSION
|
|
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
|
|
cd $PKGNAM-$VERSION || exit 1
|
|
chown -R root:root .
|
|
find -L . \
|
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
|
-o -perm 511 \) -exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
|
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
|
|
|
|
if [ ! -r configure ]; then
|
|
if [ -x ./autogen.sh ]; then
|
|
NOCONFIGURE=1 ./autogen.sh
|
|
else
|
|
autoreconf -vif
|
|
fi
|
|
fi
|
|
|
|
CFLAGS="$SLKCFLAGS" \
|
|
CXXFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--mandir=/usr/man \
|
|
--disable-static \
|
|
--docdir=/usr/doc/$PKGNAM-$VERSION \
|
|
--build=$ARCH-slackware-linux || exit 1
|
|
|
|
make $NUMJOBS || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
# Don't ship .la files:
|
|
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
|
|
|
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
|
|
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
|
|
|
find $PKG/usr/man -type f -exec gzip -9 {} \+
|
|
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
|
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
|
|
cp -a COPYING README $PKG/usr/doc/$PKGNAM-$VERSION
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
|