slackware-current/source/n/libmnl/libmnl.SlackBuild
Patrick J Volkerding bfece22130 Wed Apr 6 20:23:46 UTC 2022
a/haveged-1.9.17-x86_64-2.txz:  Rebuilt.
  Install /etc/rc.d/rc.haveged as non-executable. For existing installations
  running a recent kernel, it is safe to turn this off.
  Back when we added the haveged package we were using the 4.4 kernel, but
  since Linux 5.4 this same entropy generating algorithm has been built into
  the kernel, so there's no reason to also run it in userspace. We'll keep
  the package around (for now, anyway) in case someone might be running an
  old kernel. Thanks to Jason A. Donenfeld.
a/sysvinit-scripts-15.0-noarch-10.txz:  Rebuilt.
  rc.S, rc.6: use the seedrng utility to seed and initialize the kernel
  random number generator and generate a new seed.
  If seedrng is missing, we'll attempt to do these things with scripting.
  Thanks to Jason A. Donenfeld for hints about how to make a modest
  improvement in that regard (blame me for any problems with my own changes),
  but because you can't force the kernel RNG to initialize with a script
  (it needs an ioctl), you won't get the same guarantees that you do when
  using the new seedrng utility.
a/util-linux-2.38-x86_64-2.txz:  Rebuilt.
  Added seedrng utility, used to seed and initialize the kernel random number
  generator and to generate new seeds for carrying entropy across reboots.
  Thanks to Jason A. Donenfeld.
n/libmnl-1.0.5-x86_64-1.txz:  Upgraded.
n/libnfnetlink-1.0.2-x86_64-1.txz:  Upgraded.
xap/mozilla-thunderbird-91.8.0-x86_64-1.txz:  Upgraded.
  This release contains security fixes and improvements.
  For more information, see:
    https://www.mozilla.org/en-US/thunderbird/91.8.0/releasenotes/
    https://www.mozilla.org/en-US/security/advisories/mfsa2022-15/
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-1097
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28281
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-1197
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-1196
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28282
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28285
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28286
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-24713
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28289
  (* Security fix *)
2022-04-07 06:59:44 +02:00

136 lines
4 KiB
Bash
Executable file

#!/bin/bash
# Slackware build script for libmnl
# Copyright 2013, 2018 Patrick J. Volkerding, Sebeka, Minnesota, USA
# Copyright 2013 Robby Workman, Northport, Alabama, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=libmnl
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf $PKGNAM-$VERSION
tar xf $CWD/$PKGNAM-$VERSION.tar.xz || exit 1
cd $PKGNAM-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PKGNAM-$VERSION \
--disable-static \
--build=$ARCH-slackware-linux || exit 1
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
rm -f $PKG/usr/lib${LIBDIRSUFFIX}/*.la
# Move the shared library to $PKG/lib${LIBDIRSUFFIX}:
mkdir -p $PKG/lib${LIBDIRSUFFIX}
( cd $PKG/usr/lib${LIBDIRSUFFIX}
for file in lib*.so.?.* ; do
mv $file ../../lib${LIBDIRSUFFIX}
ln -sf ../../lib${LIBDIRSUFFIX}/$file .
done
cp -a lib*.so.? ../../lib${LIBDIRSUFFIX}
)
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# Compress and if needed symlink the man pages:
if [ -d $PKG/usr/man ]; then
( cd $PKG/usr/man
for manpagedir in $(find . -type d -name "man*") ; do
( cd $manpagedir
for eachpage in $( find . -type l -maxdepth 1) ; do
ln -s $( readlink $eachpage ).gz $eachpage.gz
rm $eachpage
done
gzip -9 *.?
)
done
)
fi
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a COPYING* README* $PKG/usr/doc/$PKGNAM-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz