mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
b75837013c
Well folks, we have some more interesting stuff in /testing now. Our good friend LuckyCyborg posted a while back about our trials with GRUB2, and that we were banging our heads against a wall for no reason trying to bend GRUB2 with our 09_slackware_linux grub.d script instead of changing our kernel/initrd naming scheme to vmlinux-6.10.1-generic and initrd-6.10.1-generic.img. And, as is often the case, our friend is exactly correct. Once we stopped trying to swim against the current, GRUB2 started behaving as it should. The updates in /testing change the kernel naming scheme thusly, and modify the geninitrd script in the mkinitrd package to also use this naming scheme. And, of course, 09_slackware_linux is removed from GRUB2, and the 10_linux script is only lightly modified. Because lilo and elilo work with the symlinks to the kernel and initrd, they shouldn't care anout this change. We've probably got 6.9.11 coming tomorrow. Unless I hear that I should stop the presses on this change, it's likely that those kernels will be updated using the new naming scheme and the mkinitrd and grub updates will be moved into the main tree from /testing. We'll stick with 6.9 in the main tree for now because I'm still encountering suspend failure with the 6.10 kernel here. Enjoy! :-) a/kernel-firmware-20240723_b37d247-noarch-1.txz: Upgraded. ap/mpg123-1.32.6-x86_64-2.txz: Rebuilt. l/libxml2-2.13.3-x86_64-1.txz: Upgraded. This update fixes a security issue: Fix XXE protection in downstream code. For more information, see: https://www.cve.org/CVERecord?id=CVE-2024-40896 (* Security fix *) l/mozilla-nss-3.102.1-x86_64-1.txz: Upgraded. l/nodejs-20.16.0-x86_64-1.txz: Upgraded. l/python-importlib_metadata-8.2.0-x86_64-1.txz: Upgraded. l/v4l-utils-1.28.1-x86_64-1.txz: Upgraded. n/c-ares-1.32.3-x86_64-1.txz: Upgraded. n/curl-8.9.0-x86_64-1.txz: Upgraded. n/htdig-3.2.0b6-x86_64-10.txz: Rebuilt. Patch XSS vulnerability. Thanks to jayjwa. Get this out of cgi-bin. Thanks to LuckyCyborg. For more information, see: https://www.cve.org/CVERecord?id=CVE-2007-6110 (* Security fix *) n/libtirpc-1.3.5-x86_64-1.txz: Upgraded. extra/fltk/fltk-1.3.9-x86_64-2.txz: Rebuilt. extra/tigervnc/tigervnc-1.13.1-x86_64-6.txz: Rebuilt. Not sure why 1.14.0 isn't compiling, but we'll rebuild this for now. testing/packages/grub-2.12-x86_64-12.txz: Upgraded. Remove 09_slackware_linux. 10_linux: don't rename Slackware ;-) This should configure the renamed kernel/initrd perfectly. Perhaps 10_linux should no longer accept initrd.gz as a valid name? For now it is accepted to avoid disrupting existing workflows. testing/packages/kernel-generic-6.10.1-x86_64-1.txz: Upgraded. testing/packages/kernel-headers-6.10.1-x86-1.txz: Upgraded. testing/packages/kernel-huge-6.10.1-x86_64-1.txz: Upgraded. testing/packages/kernel-modules-6.10.1-x86_64-1.txz: Upgraded. testing/packages/kernel-source-6.10.1-noarch-1.txz: Upgraded. testing/packages/mkinitrd-1.4.11-x86_64-35.txz: Upgraded. geninitrd: create initrd with initrd-version-name.img filename. Make compat symlinks by default. Always add LVM (I've seen it mistakenly skipped... if we can get to the bottom of that then we'll stop always adding it) Add /etc/default/geninitrd for configuration.
161 lines
4.8 KiB
Bash
Executable file
161 lines
4.8 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2006, 2007, 2008, 2009, 2010, 2018, 2024 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=htdig
|
|
VERSION=${VERSION:-3.2.0b6}
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
BUILD=${BUILD:-10}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-${PKGNAM}
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
# GCC 14 "fix":
|
|
SLKCFLAGS="$SLKCFLAGS -Wno-error=implicit-function-declaration"
|
|
|
|
cd $TMP
|
|
rm -rf ${PKGNAM}-${VERSION}
|
|
tar xvf $CWD/${PKGNAM}-$VERSION.tar.bz2 || exit 1
|
|
cd ${PKGNAM}-$VERSION
|
|
|
|
# Make sure ownerships and permissions are sane:
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# Get htdig-beta working again with new gcc/glibc/kernel:
|
|
zcat $CWD/htdig-3.2.0b6.diff.gz | patch -p1 --verbose || exit 1
|
|
|
|
# Fix "common dir" location and add "synonym_dictionary" entry:
|
|
zcat $CWD/htdig.conf.diff.gz | patch -p1 --verbose || exit 1
|
|
|
|
# Patch XSS vuln:
|
|
zcat $CWD/CVE-2007-6110.patch | patch -p1 --verbose || exit 1
|
|
|
|
# Configure:
|
|
CFLAGS="$SLKCFLAGS" \
|
|
CXXFLAGS="$SLKCFLAGS -std=gnu++98 -fpermissive -fno-delete-null-pointer-checks" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var/lib/htdig \
|
|
--with-apache=/usr/sbin/httpd \
|
|
--with-cgi-bin-dir=/usr/bin \
|
|
--with-config-dir=/etc/htdig \
|
|
--with-common-dir=/var/www/htdocs/htdig \
|
|
--with-database-dir=/var/lib/htdig \
|
|
--with-default-config-file=/etc/htdig/htdig.conf \
|
|
--with-image-dir=/var/www/htdocs/htdig \
|
|
--with-search-dir=/var/www/htdocs/htdig \
|
|
--with-ssl \
|
|
--with-zlib=/usr \
|
|
--mandir=/usr/man \
|
|
--enable-bigfile \
|
|
--enable-shared \
|
|
--disable-static \
|
|
--enable-tests \
|
|
--program-prefix= \
|
|
--program-suffix= \
|
|
--build=$ARCH-slackware-linux
|
|
|
|
# Build and install:
|
|
make $NUMJOBS || make || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
mv $PKG/etc/htdig/htdig.conf $PKG/etc/htdig/htdig.conf.new
|
|
|
|
# Strip binaries:
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
# Compress and link manpages, if any:
|
|
if [ -d $PKG/usr/man ]; then
|
|
( cd $PKG/usr/man
|
|
for manpagedir in $(find . -type d -name "man*") ; do
|
|
( cd $manpagedir
|
|
for eachpage in $( find . -type l -maxdepth 1) ; do
|
|
ln -s $( readlink $eachpage ).gz $eachpage.gz
|
|
rm $eachpage
|
|
done
|
|
gzip -9 *.*
|
|
)
|
|
done
|
|
)
|
|
fi
|
|
|
|
# Compress info files, if any:
|
|
if [ -d $PKG/usr/info ]; then
|
|
( cd $PKG/usr/info
|
|
rm -f dir
|
|
gzip -9 *
|
|
)
|
|
fi
|
|
|
|
# Add a documentation directory:
|
|
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
|
|
cp -a \
|
|
AUTHORS CHANGES COPYING LICENSE README \
|
|
$PKG/usr/doc/${PKGNAM}-$VERSION
|
|
|
|
mkdir -p $PKG/install
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/${PKGNAM}-$VERSION-$ARCH-$BUILD.txz
|
|
|