mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
a259c4df1e
d/python-setuptools-73.0.1-x86_64-1.txz: Upgraded. d/rust-bindgen-0.70.1-x86_64-1.txz: Upgraded. n/ModemManager-1.22.0-x86_64-1.txz: Upgraded. n/dhcpcd-10.0.10-x86_64-1.txz: Upgraded. n/epic5-2.4-x86_64-1.txz: Upgraded. n/libqmi-1.34.0-x86_64-2.txz: Rebuilt. Build against libqrtr-glib with -Dqrtr=true. n/libqrtr-glib-1.2.2-x86_64-1.txz: Added. ModemManager-1.22.0 needs libqmi to be linked with this. x/xorg-server-21.1.13-x86_64-3.txz: Rebuilt. Patched changing a type from unsigned long to unsigned long long which fixes the black screen seen on 32-bit with the modesetting driver. Seems fine on 64-bit as well, so the patch is applied for all builds. The patch to default to modesetting for Intel graphics is restored (and the one for nouveau is kept as well). Thanks to Lenard Spencer for reporting that nouveau was also hitting this. Thanks to Petri Kaukasoina for the patch. x/xorg-server-xephyr-21.1.13-x86_64-3.txz: Rebuilt. x/xorg-server-xnest-21.1.13-x86_64-3.txz: Rebuilt. x/xorg-server-xvfb-21.1.13-x86_64-3.txz: Rebuilt.
154 lines
5.2 KiB
Bash
Executable file
154 lines
5.2 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009, 2010, 2013, 2014, 2017, 2018, 2020, 2021 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=dhcpcd
|
|
VERSION=${VERSION:-$(echo dhcpcd-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
# By default, Slackware builds dhcpcd with privilege separation, which improves
|
|
# security by ensuring that any security vulnerabilies such as buffer overflows
|
|
# or shell metacharacter insertion would gain access to an unprivileged user
|
|
# (the dhcpcd user) rather than the root user.
|
|
PRIVSEP=${PRIVSEP:-yes}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-dhcpcd
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf dhcpcd-$VERSION
|
|
tar xvf $CWD/dhcpcd-$VERSION.tar.?z || exit 1
|
|
cd dhcpcd-$VERSION
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
patch -p1 --verbose < $CWD/patches/dhcpcd.conf-Don-t-invoke-wpa_supplicant-by-default.patch || exit 1
|
|
patch -p1 --verbose < $CWD/patches/use-hostname_short-in-dhcpcd.conf.patch || exit 1
|
|
patch -p1 --verbose < $CWD/patches/dhcpcd.conf-request_ntp_server_by_default.patch || exit 1
|
|
|
|
# At this point, it should be safe to assume that /var will be mounted by the
|
|
# time dhcpcd is called, as all non-root local filesystems are mounted from
|
|
# /etc/rc.d/rc.S, and /var should not be on a network filesystem. As such,
|
|
# we'll use the FHS layout instead of putting things in /etc/dhcpc
|
|
|
|
# Set options to build with or without privsep:
|
|
if [ "$PRIVSEP" = "yes" ]; then
|
|
PRIVSEP_OPTIONS="--enable-privsep --privsepuser=dhcpcd"
|
|
unset TAG
|
|
else
|
|
PRIVSEP_OPTIONS="--disable-privsep"
|
|
TAG="_noprivsep"
|
|
fi
|
|
|
|
# Yes, /lib/dhcpcd is correct, even on x86_64.
|
|
CFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--sbindir=/sbin \
|
|
--sysconfdir=/etc \
|
|
--dbdir=/var/lib/dhcpcd \
|
|
--libexecdir=/lib/dhcpcd \
|
|
--mandir=/usr/man \
|
|
--rundir=/run \
|
|
$PRIVSEP_OPTIONS \
|
|
--build=$ARCH-slackware-linux || exit 1
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make install DESTDIR=$PKG HOOKSCRIPTS="50-ntp.conf 50-yp.conf" || exit 1
|
|
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" \
|
|
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
# Let's not clobber the config file
|
|
mv $PKG/etc/dhcpcd.conf $PKG/etc/dhcpcd.conf.new
|
|
|
|
# Compress and link manpages, if any:
|
|
if [ -d $PKG/usr/man ]; then
|
|
( cd $PKG/usr/man
|
|
for manpagedir in $(find . -type d -name "man*") ; do
|
|
( cd $manpagedir
|
|
for eachpage in $( find . -type l -maxdepth 1) ; do
|
|
ln -s $( readlink $eachpage ).gz $eachpage.gz
|
|
rm $eachpage
|
|
done
|
|
gzip -9 *.?
|
|
)
|
|
done
|
|
)
|
|
fi
|
|
|
|
mkdir -p $PKG/usr/doc/dhcpcd-$VERSION
|
|
cp -a BUILDING* LICENSE* README* $PKG/usr/doc/dhcpcd-$VERSION
|
|
|
|
# If there's a ChangeLog, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r ChangeLog ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
|
|
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
|
|
touch -r ChangeLog $DOCSDIR/ChangeLog
|
|
fi
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/dhcpcd-$VERSION-$ARCH-$BUILD$TAG.txz
|