mirror of
git://slackware.nl/current.git
synced 2024-11-16 07:48:02 +01:00
6ffeb4181c
a/hostname-3.24-x86_64-1.txz: Upgraded. a/kernel-firmware-20241010_c410e4c-noarch-1.txz: Upgraded. a/kernel-generic-6.10.14-x86_64-1.txz: Upgraded. a/mkinitrd-1.4.11-x86_64-39.txz: Rebuilt. Symlink /boot/remove-orphaned-initrds into /usr/sbin to get it in the $PATH. a/pkgtools-15.1-noarch-14.txz: Rebuilt. Renamed kernel-backup to make-kernel-backup. We'll leave it in /boot where it's more likely to be noticed, but also add a symlink in /usr/sbin so that it's in the $PATH. Support /etc/default/make-kernel-backup. Test to see if $KERNEL_FILE is actually a Linux kernel. d/kernel-headers-6.10.14-x86-1.txz: Upgraded. k/kernel-source-6.10.14-noarch-1.txz: Upgraded. l/python-sphinx-8.1.0-x86_64-1.txz: Upgraded. l/python-sphinx_rtd_theme-3.0.1-x86_64-1.txz: Upgraded. n/c-ares-1.34.1-x86_64-1.txz: Upgraded. xap/mozilla-thunderbird-128.3.1esr-x86_64-1.txz: Upgraded. This release contains security fixes and improvements. For more information, see: https://www.mozilla.org/en-US/thunderbird/128.3.1esr/releasenotes/ (* Security fix *) isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. testing/packages/kernel-generic-6.11.3-x86_64-1.txz: Upgraded. testing/packages/kernel-headers-6.11.3-x86-1.txz: Upgraded. testing/packages/kernel-source-6.11.3-noarch-1.txz: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
172 lines
5.4 KiB
Bash
Executable file
172 lines
5.4 KiB
Bash
Executable file
#!/bin/sh
|
|
# Copyright 2018 Eric Hameleers, Eindhoven, Netherlands
|
|
# Copyright 2018, 2023 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=zstd
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$(uname -m)" in
|
|
i?86) ARCH=i586 ;;
|
|
arm*) readelf /usr/bin/file -A | grep -E -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) ARCH=$(uname -m) ;;
|
|
esac
|
|
export ARCH
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
if [ "$ARCH" = "i486" ]; then
|
|
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
|
SLKLDFLAGS=""
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "i586" ]; then
|
|
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
|
SLKLDFLAGS=""
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "s390" ]; then
|
|
SLKCFLAGS="-O2"
|
|
SLKLDFLAGS=""
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -fPIC"
|
|
SLKLDFLAGS="-L/usr/lib64"
|
|
LIBDIRSUFFIX="64"
|
|
elif [ "$ARCH" = "armv7hl" ]; then
|
|
SLKCFLAGS="-O2 -march=armv7-a -mfpu=vfpv3-d16"
|
|
SLKLDFLAGS=""
|
|
LIBDIRSUFFIX=""
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
SLKLDFLAGS=""
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-$PKGNAM
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf $PKGNAM-$VERSION
|
|
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
|
|
cd $PKGNAM-$VERSION || exit 1
|
|
|
|
|
|
# Make sure ownerships and permissions are sane:
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# Compile and install:
|
|
mkdir build/cmake/build
|
|
cd build/cmake/build
|
|
cmake \
|
|
-DCMAKE_C_FLAGS="$SLKCFLAGS" \
|
|
-DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
|
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
|
-DCMAKE_INSTALL_LIBDIR="lib$LIBDIRSUFFIX" \
|
|
-DDOC_INSTALL_DIR="doc" \
|
|
-DMAN_INSTALL_DIR=/usr/man/man1 \
|
|
-DZSTD_BUILD_STATIC=OFF \
|
|
-DZSTD_PROGRAMS_LINK_SHARED=ON \
|
|
-DZSTD_LZ4_SUPPORT=ON \
|
|
-DZSTD_LZMA_SUPPORT=ON \
|
|
-DZSTD_ZLIB_SUPPORT=ON \
|
|
.. || exit 1
|
|
make $NUMJOBS CFLAGS="$SLKCFLAGS" || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
cd ../../..
|
|
|
|
# Compile and install pzstd:
|
|
zcat $CWD/zstd.dont.link.pzstd.to.static.libzstd.a.diff.gz | patch -p1 --verbose || exit 1
|
|
make $NUMJOBS CFLAGS="$SLKCFLAGS" -C contrib/pzstd || exit 1
|
|
install -Dm755 contrib/pzstd/pzstd $PKG/usr/bin/pzstd || exit 1
|
|
|
|
## Don't ship static library:
|
|
#rm -f $PKG/usr/lib${LIBDIRSUFFIX}/*.a
|
|
|
|
# It might be advisable to have the libraries in /lib${LIBDIRSUFFIX}:
|
|
mkdir -p $PKG/lib${LIBDIRSUFFIX}
|
|
mv $PKG/usr/lib${LIBDIRSUFFIX}/libzstd.so.* $PKG/lib${LIBDIRSUFFIX}
|
|
( cd $PKG/usr/lib${LIBDIRSUFFIX}
|
|
rm -f libzstd.so
|
|
ln -sf ../../lib${LIBDIRSUFFIX}/libzstd.so.? libzstd.so
|
|
)
|
|
|
|
# Set the path of libzstd in cmake Targets (given by Steven Voges in SBo)
|
|
sed -i 's|${_IMPORT_PREFIX}||g' $PKG/usr/lib${LIBDIRSUFFIX}/cmake/zstd/zstdTargets-release.cmake
|
|
|
|
# zstdmt as the same as zstd, so just make a symlink:
|
|
( cd $PKG/usr/bin
|
|
ln -sf zstd zstdmt
|
|
)
|
|
|
|
# Strip binaries:
|
|
find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
# Compress and link manpages, if any:
|
|
if [ -d $PKG/usr/man ]; then
|
|
( cd $PKG/usr/man
|
|
for manpagedir in $(find . -type d -name "man*") ; do
|
|
( cd $manpagedir
|
|
for eachpage in $( find . -type l -maxdepth 1) ; do
|
|
ln -s $( readlink $eachpage ).gz $eachpage.gz
|
|
rm $eachpage
|
|
done
|
|
gzip -9 *.?
|
|
)
|
|
done
|
|
)
|
|
fi
|
|
|
|
# Add a documentation directory:
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
|
|
cp -a \
|
|
CONTRIBUTING* COPYING* LICENSE NEWS README* TESTING* \
|
|
$PKG/usr/doc/$PKGNAM-$VERSION
|
|
|
|
# Add a package description:
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
# Build package:
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
|