mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
03de904154
d/llvm-19.1.2-x86_64-1.txz: Upgraded. Shared library .so-version bump. d/python-setuptools-75.2.0-x86_64-1.txz: Upgraded. kde/calligra-3.2.1-x86_64-45.txz: Rebuilt. Recompiled against poppler-24.10.0. kde/cantor-23.08.5-x86_64-11.txz: Rebuilt. Recompiled against poppler-24.10.0. kde/kdevelop-23.08.5-x86_64-3.txz: Rebuilt. Recompiled against llvm-19.1.2. kde/kfilemetadata-5.116.0-x86_64-8.txz: Rebuilt. Recompiled against poppler-24.10.0. kde/kile-2.9.93-x86_64-38.txz: Rebuilt. Recompiled against poppler-24.10.0. kde/kitinerary-23.08.5-x86_64-9.txz: Rebuilt. Recompiled against poppler-24.10.0. kde/krita-5.2.6-x86_64-2.txz: Rebuilt. Recompiled against poppler-24.10.0. kde/labplot-2.11.1-x86_64-4.txz: Rebuilt. Recompiled against poppler-24.10.0. kde/okular-23.08.5-x86_64-9.txz: Rebuilt. Recompiled against poppler-24.10.0. l/libclc-19.1.2-x86_64-1.txz: Upgraded. Compiled against llvm-19.1.2. l/libssh2-1.11.1-x86_64-1.txz: Upgraded. src: add 'strict KEX' to fix CVE-2023-48795 "Terrapin Attack." For more information, see: https://www.cve.org/CVERecord?id=CVE-2023-48795 (* Security fix *) l/media-player-info-26-noarch-1.txz: Upgraded. l/poppler-24.10.0-x86_64-1.txz: Upgraded. Shared library .so-version bump. l/python-pillow-11.0.0-x86_64-1.txz: Upgraded. l/qt5-5.15.15_20240903_363456a6-x86_64-2.txz: Rebuilt. Patched and recompiled against llvm-19.1.2. l/qt6-6.7.3_20240920_90e86aee-x86_64-3.txz: Rebuilt. Patched and recompiled against llvm-19.1.2. l/spirv-llvm-translator-19.1.0-x86_64-1.txz: Upgraded. Shared library .so-version bump. Compiled against llvm-19.1.2. n/bind-9.20.3-x86_64-1.txz: Upgraded. n/c-ares-1.34.2-x86_64-1.txz: Upgraded. x/mesa-24.2.5-x86_64-1.txz: Upgraded. Compiled against llvm-19.1.2. x/xf86-input-evdev-2.11.0-x86_64-1.txz: Upgraded. x/xf86-input-libinput-1.5.0-x86_64-1.txz: Upgraded. extra/brltty/brltty-6.7-x86_64-1.txz: Upgraded. extra/xv/xv-6.0.2-x86_64-1.txz: Upgraded.
125 lines
4.1 KiB
Bash
Executable file
125 lines
4.1 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2021, 2023 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=spirv-llvm-translator
|
|
VERSION=${VERSION:-$(echo SPIRV-LLVM-Translator-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
MARCH=$( uname -m )
|
|
if [ -z "$ARCH" ]; then
|
|
case "$MARCH" in
|
|
i?86) export ARCH=i686 ;;
|
|
armv7hl) export ARCH=$MARCH ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$MARCH ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-${PKGNAM}
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
cd $TMP
|
|
rm -rf SPIRV-LLVM-Translator-${VERSION}
|
|
tar xvf $CWD/SPIRV-LLVM-Translator-$VERSION.tar.?z* || exit 1
|
|
cd SPIRV-LLVM-Translator-$VERSION || exit 1
|
|
|
|
# Make sure ownerships and permissions are sane:
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# This git pull needs a specific set of headers. These were obtained by letting
|
|
# the build download them, and then tarring them up and pointing to them with
|
|
# the -DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR option below.
|
|
tar xf $CWD/SPIRV-Headers.tar.lz
|
|
|
|
# Build and install:
|
|
mkdir -p build
|
|
cd build
|
|
cmake \
|
|
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
|
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
|
-DCMAKE_SKIP_RPATH=ON \
|
|
-DLIB_INSTALL_DIR=/usr/lib${LIBDIRSUFFIX} \
|
|
-DMAN_INSTALL_DIR=/usr/man \
|
|
-DSYSCONF_INSTALL_DIR=/etc \
|
|
-DINCLUDE_INSTALL_DIR=/usr/include \
|
|
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
|
|
-DCMAKE_BUILD_TYPE=Release \
|
|
-DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR=$TMP/SPIRV-LLVM-Translator-$VERSION/SPIRV-Headers \
|
|
-DBUILD_SHARED_LIBS=ON \
|
|
..
|
|
make $NUMJOBS || make || exit 1
|
|
make $NUMJOBS llvm-spirv || make llvm-spirv || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
cd -
|
|
|
|
mkdir -p $PKG/usr/bin
|
|
install -m 755 build/tools/llvm-spirv/llvm-spirv $PKG/usr/bin/
|
|
|
|
# Strip binaries:
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" \
|
|
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
# Add a documentation directory:
|
|
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
|
|
cp -a \
|
|
LICENSE.txt README* *.md \
|
|
$PKG/usr/doc/${PKGNAM}-$VERSION
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/${PKGNAM}-$VERSION-$ARCH-$BUILD.txz
|
|
|