slackware-current/source/l/sip/sip.SlackBuild
Patrick J Volkerding 440fde6336 Thu Dec 5 22:00:02 UTC 2024
a/kernel-firmware-20241203_06aea4d-noarch-1.txz:  Upgraded.
a/kernel-generic-6.12.2-x86_64-1.txz:  Upgraded.
a/shadow-4.16.0-x86_64-2.txz:  Rebuilt.
d/cmake-3.31.2-x86_64-1.txz:  Upgraded.
d/gdb-15.2-x86_64-3.txz:  Rebuilt.
  Removed files duplicated from binutils. Thanks to TommyC7 and gmgf.
d/kernel-headers-6.12.2-x86-1.txz:  Upgraded.
k/kernel-source-6.12.2-noarch-1.txz:  Upgraded.
l/libppd-2.1.0-x86_64-2.txz:  Rebuilt.
  Build without --enable-ppdc-utils. Thanks to TommyC7.
l/protobuf-29.1-x86_64-1.txz:  Upgraded.
l/python-six-1.17.0-x86_64-1.txz:  Upgraded.
l/sip-6.9.0-x86_64-1.txz:  Upgraded.
n/postfix-3.9.1-x86_64-1.txz:  Upgraded.
tcl/tcl-8.6.15-x86_64-2.txz:  Rebuilt.
  Rename sqlite3_analyzer to sqlite3_analyzer_tcl to avoid clobbering the ELF
  binary in the sqlite package. Likewise, rename the Thread.3 man page to
  Thread_tcl.3 so that we don't overwrite the one in the perl package.
  Thanks to TommyC7.
x/fslsfonts-1.0.7-x86_64-1.txz:  Upgraded.
x/libdrm-2.4.124-x86_64-1.txz:  Upgraded.
x/libwacom-2.14.0-x86_64-1.txz:  Upgraded.
x/mesa-24.3.1-x86_64-1.txz:  Upgraded.
x/oclock-1.0.6-x86_64-1.txz:  Upgraded.
x/transset-1.0.4-x86_64-1.txz:  Upgraded.
x/xkbevd-1.1.6-x86_64-1.txz:  Upgraded.
isolinux/initrd.img:  Rebuilt.
kernels/*:  Upgraded.
usb-and-pxe-installers/usbboot.img:  Rebuilt.
2024-12-05 23:45:17 +01:00

108 lines
3.7 KiB
Bash
Executable file

#!/bin/sh
# Copyright 2008 Aleksandar Samardzic <asamardzic@gmail.com>
# Copyright 2008, 2009, 2010, 2011, 2017, 2018, 2019, 2023, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Modified by Robby Workman <rworkman@slackware.com>
# Modified by Eric Hameleers <alien@slackware.com>
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=sip
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
i?86) ARCH=i686 ;;
arm*) readelf /usr/bin/file -A | grep -E -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$(uname -m) ;;
esac
export ARCH
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$(echo $VERSION | tr - _)-$ARCH-$BUILD.txz"
exit 0
fi
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
elif [ "$ARCH" = "armv7hl" ]; then
SLKCFLAGS="-O2 -march=armv7-a -mfpu=vfpv3-d16"
else
SLKCFLAGS="-O2"
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PKGNAM-$VERSION
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
cd $PKGNAM-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
python3 -m build --wheel --no-isolation || exit 1
python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a \
LICENSE* COPYING* ChangeLog NEWS* PKG-INFO* README* TODO \
$PKG/usr/doc/$PKGNAM-$VERSION
chown -R root:root $PKG/usr/doc
# If there's a ChangeLog, installing at least part of the recent history
# is useful, but don't let it get totally out of control:
if [ -r ChangeLog ]; then
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
touch -r ChangeLog $DOCSDIR/ChangeLog
fi
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$(echo $VERSION |tr - _)-$ARCH-$BUILD.txz