slackware-current/source/l/serf/serf.SlackBuild
Patrick J Volkerding 8b137cd835 Fri Jun 2 20:56:35 UTC 2023
a/hwdata-0.371-noarch-1.txz:  Upgraded.
ap/cups-2.4.3-x86_64-1.txz:  Upgraded.
  Fixed a heap buffer overflow in _cups_strlcpy(), when the configuration file
  cupsd.conf sets the value of loglevel to DEBUG, that could allow a remote
  attacker to launch a denial of service (DoS) attack, or possibly execute
  arbirary code.
  For more information, see:
    https://www.cve.org/CVERecord?id=CVE-2023-32324
  (* Security fix *)
d/git-2.41.0-x86_64-1.txz:  Upgraded.
d/llvm-16.0.5-x86_64-1.txz:  Upgraded.
kde/calligra-3.2.1-x86_64-29.txz:  Rebuilt.
  Recompiled against Imath-3.1.9.
kde/kimageformats-5.106.0-x86_64-3.txz:  Rebuilt.
  Recompiled against Imath-3.1.9.
kde/kio-extras-23.04.1-x86_64-3.txz:  Rebuilt.
  Recompiled against Imath-3.1.9.
kde/krita-5.1.5-x86_64-9.txz:  Rebuilt.
  Recompiled against Imath-3.1.9.
l/Imath-3.1.9-x86_64-1.txz:  Upgraded.
  Evidently the shared library .so-version bump in Imath-3.1.8 should not have
  happened, so this update reverts it to the previous value.
l/gst-plugins-bad-free-1.22.3-x86_64-3.txz:  Rebuilt.
  Recompiled against Imath-3.1.9.
l/imagemagick-7.1.1_11-x86_64-2.txz:  Rebuilt.
  Recompiled against Imath-3.1.9.
l/mozjs102-102.12.0esr-x86_64-1.txz:  Upgraded.
l/openexr-3.1.7-x86_64-3.txz:  Rebuilt.
  Recompiled against Imath-3.1.9.
l/serf-1.3.10-x86_64-1.txz:  Upgraded.
l/vte-0.72.2-x86_64-1.txz:  Upgraded.
n/nettle-3.9.1-x86_64-1.txz:  Upgraded.
n/ntp-4.2.8p16-x86_64-1.txz:  Upgraded.
  This update fixes bugs and security issues.
  For more information, see:
    https://www.cve.org/CVERecord?id=CVE-2023-26551
    https://www.cve.org/CVERecord?id=CVE-2023-26552
    https://www.cve.org/CVERecord?id=CVE-2023-26553
    https://www.cve.org/CVERecord?id=CVE-2023-26554
    https://www.cve.org/CVERecord?id=CVE-2023-26555
  (* Security fix *)
n/samba-4.18.3-x86_64-1.txz:  Upgraded.
tcl/tclx-8.6.2-x86_64-1.txz:  Upgraded.
x/ibus-libpinyin-1.15.3-x86_64-1.txz:  Upgraded.
x/libX11-1.8.5-x86_64-1.txz:  Upgraded.
xap/gimp-2.10.34-x86_64-4.txz:  Rebuilt.
  Recompiled against Imath-3.1.9.
xfce/xfce4-pulseaudio-plugin-0.4.7-x86_64-1.txz:  Upgraded.
2023-06-02 23:45:41 +02:00

105 lines
3.4 KiB
Bash
Executable file

#!/bin/bash
# Slackware build script for serf
# Copyright 2014 Andrzej Telszewski, Sabadell
# Copyright 2015, 2018, 2023 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=serf
VERSION=${VERSION:-$(echo serf-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
TMP=${TMP:-/tmp}
PKG=$TMP/package-serf
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf serf-$VERSION
tar xvf $CWD/serf-$VERSION.tar.?z* || exit 1
cd serf-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
# Disable build and install static library
# Thanks to LFS
# http://www.linuxfromscratch.org/blfs/view/svn/basicnet/serf.html
sed -i "/Default/s:lib_static,::" SConstruct
sed -i "/Alias/s:install_static,::" SConstruct
scons $NUMJOBS \
PREFIX=/usr \
LIBDIR=/usr/lib${LIBDIRSUFFIX} \
CFLAGS="$SLKCFLAGS" || exit 1
scons $NUMJOBS install --install-sandbox=$PKG || exit 1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a CHANGES design-guide.txt LICENSE NOTICE README $PKG/usr/doc/$PKGNAM-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz