slackware-current/source/l/rubygem-asciidoctor/rubygem-asciidoctor.SlackBuild
Patrick J Volkerding d0427a2e77 Thu Dec 26 23:27:30 UTC 2024
ap/itstool-2.0.7-x86_64-4.txz:  Rebuilt.
  [PATCH] Fix insufficiently quoted regular expressions.
  Thanks to reddog83.
ap/vim-9.1.0964-x86_64-1.txz:  Upgraded.
d/ruby-3.4.1-x86_64-1.txz:  Upgraded.
  Shared library .so-version bump.
d/subversion-1.14.5-x86_64-2.txz:  Rebuilt.
  Rebuilt against ruby-3.4.1.
kde/kross-interpreters-23.08.5-x86_64-3.txz:  Rebuilt.
  Rebuilt against ruby-3.4.1.
l/netpbm-11.09.00-x86_64-1.txz:  Upgraded.
l/nodejs-22.12.0-x86_64-1.txz:  Upgraded.
l/rubygem-asciidoctor-2.0.23-x86_64-1.txz:  Upgraded.
  Built against ruby-3.4.1.
n/epic5-3.0.2-x86_64-2.txz:  Rebuilt.
  Rebuilt against ruby-3.4.1.
n/obexftp-0.24.2-x86_64-15.txz:  Rebuilt.
  Rebuilt against ruby-3.4.1.
x/marisa-0.2.6-x86_64-13.txz:  Rebuilt.
  Rebuilt against ruby-3.4.1.
xap/vim-gvim-9.1.0964-x86_64-1.txz:  Upgraded.
xfce/xfce4-panel-profiles-1.0.15-x86_64-1.txz:  Upgraded.
xfce/xfce4-systemload-plugin-1.3.3-x86_64-1.txz:  Upgraded.
xfce/xfce4-taskmanager-1.5.8-x86_64-1.txz:  Upgraded.
xfce/xfce4-terminal-1.1.4-x86_64-1.txz:  Upgraded.
extra/bash-completion/bash-completion-2.16.0-noarch-1.txz:  Upgraded.
2024-12-27 01:02:08 +01:00

122 lines
4 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2021 Trevor D. Cook, Issaquah, WA, USA
# Copyright 2021 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=rubygem-asciidoctor
SRCNAM=asciidoctor
VERSION=${VERSION:-$(basename $(echo $SRCNAM-*.gem | cut -f 2 -d -) .gem)}
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
i?86) ARCH=i686 ;;
arm*) readelf /usr/bin/file -A | grep -E -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$(uname -m) ;;
esac
export ARCH
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j $(expr $(nproc) + 1) "}
if [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
DESTDIR=$( ruby -r rbconfig -e '
include RbConfig
printf("%s/%s/gems/%s\n",
CONFIG["libdir"],
CONFIG["RUBY_INSTALL_NAME"],
CONFIG["ruby_version"]
)
')
gem specification $CWD/$SRCNAM-$VERSION.gem | \
ruby -r yaml -r rbconfig -e '
c = RbConfig::CONFIG
path = sprintf("%s/%s/gems/%s",
c["libdir"],
c["RUBY_INSTALL_NAME"],
c["ruby_version"])
sys_gemspecs = Dir.glob(path + "/specifications/**/*.gemspec").map {|g| gs = Gem::Specification.load(g); gs.name }
obj = Gem::Specification.from_yaml($stdin)
obj.dependencies.each {|dep|
if not(dep.type == :runtime)
next
end
if not(sys_gemspecs.include?(dep.name))
$stderr.write("WARNING: #{dep.name} gem not found\n")
sleep 0.5
end
}'
gem install \
--local \
--no-update-sources \
--ignore-dependencies \
--backtrace \
--install-dir $PKG/$DESTDIR \
--bindir $PKG/usr/bin \
$CWD/$SRCNAM-$VERSION.gem || exit 1
# Strip binaries (there aren't any though):
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Add a documentation directory:
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a $PKG/usr/lib${LIBDIRSUFFIX}/ruby/gems/*/gems/asciidoctor-${VERSION}/CHANGELOG* $PKG/usr/doc/$PKGNAM-$VERSION
cp -a $PKG/usr/lib${LIBDIRSUFFIX}/ruby/gems/*/gems/asciidoctor-${VERSION}/LICENSE* $PKG/usr/doc/$PKGNAM-$VERSION
cp -a $PKG/usr/lib${LIBDIRSUFFIX}/ruby/gems/*/gems/asciidoctor-${VERSION}/README* $PKG/usr/doc/$PKGNAM-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz