mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
054967ebe9
a/cracklib-2.10.2-x86_64-1.txz: Upgraded. ap/ksh93-1.0.10-x86_64-1.txz: Upgraded. ap/nvme-cli-2.10.2-x86_64-1.txz: Upgraded. d/Cython-3.0.11-x86_64-1.txz: Upgraded. d/binutils-2.43-x86_64-1.txz: Upgraded. Shared library .so-version bump. d/cmake-3.30.2-x86_64-1.txz: Upgraded. Recompiled against binutils-2.43. d/oprofile-1.4.0-x86_64-14.txz: Rebuilt. kde/calligra-3.2.1-x86_64-43.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/cantor-23.08.5-x86_64-9.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/kfilemetadata-5.116.0-x86_64-5.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/kile-2.9.93-x86_64-36.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/kitinerary-23.08.5-x86_64-7.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/krita-5.2.3-x86_64-3.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/kstars-3.7.2-x86_64-1.txz: Upgraded. kde/labplot-2.11.1-x86_64-2.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/libindi-2.0.9-x86_64-1.txz: Upgraded. kde/okular-23.08.5-x86_64-7.txz: Rebuilt. Recompiled against poppler-24.08.0. l/SDL2-2.30.6-x86_64-1.txz: Upgraded. l/abseil-cpp-20240722.0-x86_64-1.txz: Upgraded. Shared library .so-version bump. l/ffmpeg-6.1.2-x86_64-1.txz: Upgraded. This is a temporary improvment. ;-) l/fluidsynth-2.3.6-x86_64-1.txz: Upgraded. l/libdeflate-1.21-x86_64-1.txz: Upgraded. l/libnvme-1.10-x86_64-1.txz: Upgraded. l/mozilla-nss-3.103-x86_64-1.txz: Upgraded. l/mozjs115-115.14.0esr-x86_64-1.txz: Upgraded. l/poppler-24.08.0-x86_64-2.txz: Rebuilt. Shared library .so-version bump. l/protobuf-27.3-x86_64-2.txz: Rebuilt. Recompiled against abseil-cpp-20240722.0. l/python-wheel-0.44.0-x86_64-1.txz: Upgraded. l/readline-8.2.013-x86_64-1.txz: Upgraded. n/c-ares-1.33.0-x86_64-1.txz: Upgraded. n/mosh-1.4.0-x86_64-3.txz: Rebuilt. Recompiled against abseil-cpp-20240722.0. x/libFS-1.0.10-x86_64-1.txz: Upgraded. x/libXfont2-2.0.7-x86_64-1.txz: Upgraded. x/libXtst-1.2.5-x86_64-1.txz: Upgraded. x/x11perf-1.7.0-x86_64-1.txz: Upgraded. xap/pavucontrol-6.1-x86_64-1.txz: Upgraded.
153 lines
4.8 KiB
Bash
Executable file
153 lines
4.8 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2005-2019 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=readline
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-readline
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
# Determine readline patchlevel:
|
|
PATCHLEVEL="$( cd $CWD/readline-${VERSION}-patches ; /bin/ls readline??-??? 2> /dev/null | tail -1 | cut -f 2 -d - 2> /dev/null )"
|
|
if [ "$PATCHLEVEL" = "" ]; then
|
|
PATCHLEVEL=000
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION.$PATCHLEVEL-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
cd $TMP
|
|
rm -rf readline-$VERSION
|
|
tar xvf $CWD/readline-$VERSION.tar.?z* || exit 1
|
|
cd readline-$VERSION || exit 1
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
if [ ! "$PATCHLEVEL" = "000" ]; then
|
|
for file in $CWD/readline-*-patches/readline*-??? ; do
|
|
cat $file | patch -p0 --verbose || exit 1
|
|
done
|
|
fi
|
|
|
|
CFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--mandir=/usr/man \
|
|
--infodir=/usr/info \
|
|
--docdir=/usr/doc/readline-$VERSION \
|
|
--with-curses \
|
|
--enable-multibyte \
|
|
--disable-static \
|
|
--build=$ARCH-slackware-linux-gnu || exit 1
|
|
|
|
# Link with libtinfo:
|
|
make $NUMJOBS static shared SHLIB_LIBS=-ltinfo || make static shared SHLIB_LIBS=-ltinfo || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
# build rlfe (ReadLine Front-End) from examples/
|
|
# NOTE: This will link against the currently installed libreadline!
|
|
# Build/install this package twice whenever there is an .soname bump.
|
|
( cd examples/rlfe || exit 1
|
|
CFLAGS="$SLKCFLAGS -Wno-error=implicit-function-declaration -Wno-error=implicit-int -Wno-error=int-conversion" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--mandir=/usr/man \
|
|
--infodir=/usr/info \
|
|
--docdir=/usr/doc/readline-$VERSION \
|
|
--build=$ARCH-slackware-linux-gnu || exit 1
|
|
make $NUMJOBS || exit 1
|
|
install -m 755 rlfe $PKG/usr/bin
|
|
cp -a README $PKG/usr/doc/readline-$VERSION/README.rlfe
|
|
) || exit 1
|
|
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" \
|
|
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
# Compress manual pages:
|
|
find $PKG/usr/man -type f -exec gzip -9 {} \+
|
|
for i in $( find $PKG/usr/man -type l ) ; do
|
|
ln -s $( readlink $i ).gz $i.gz
|
|
rm $i
|
|
done
|
|
|
|
# Compress info files, if any:
|
|
if [ -d $PKG/usr/info ]; then
|
|
( cd $PKG/usr/info
|
|
rm -f dir
|
|
gzip -9 *
|
|
)
|
|
fi
|
|
|
|
chmod 755 $PKG/usr/lib${LIBDIRSUFFIX}/lib*.so.*
|
|
|
|
mkdir -p $PKG/usr/doc/readline-$VERSION
|
|
cp -a \
|
|
CHANGELOG CHANGES COPYING* INSTALL MANIFEST README* USAGE \
|
|
$PKG/usr/doc/readline-$VERSION
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
# Build the package:
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/readline-$VERSION.$PATCHLEVEL-$ARCH-$BUILD.txz
|
|
|